[natty] exchange 2010 evolution-mapi - no folders or calendar, contact, tasks

Bug #740642 reported by Michael Flaig on 2011-03-23
182
This bug affects 33 people
Affects Status Importance Assigned to Milestone
evolution mapi
Fix Released
Medium
evolution-mapi (Ubuntu)
High
Jelmer Vernooij

Bug Description

Binary package hint: evolution-mapi

This applies to current natty. I newly configured a Exchange Account in Evolution but evolution-mapi seems to fail getting the folder list. Furthermore it seems there is no calendar. the global addressbook however is there and works.

https://bugs.launchpad.net/ubuntu/+source/evolution-exchange/+bug/694884 may be related, although it refers to evolution-exchange. evolution-exchange won't work with exchange 2010 imho due to dropped webdav support in owa2010.

mfl@yamato:~$ EXCHANGEMAPI_DEBUG=1 evolution

** (evolution:32563): CRITICAL **: categories_icon_theme_hack: assertion `filename != NULL && *filename != '\0'' failed
** (evolution:32563): DEBUG: Loading Exchange MAPI Plugin

** (evolution:32563): DEBUG: MAPI listener is constructed with 1 listed MAPI accounts
Migrating cached data
Migrating config data
Migrating local user data
  mv /home/mfl/.evolution/mail/local/folders.db /home/mfl/.local/share/evolution/mail/local/folders.db
  FAILED: Destination file already exists
  rmdir /home/mfl/.evolution/mail/local
  FAILED: Directory not empty (contents follows)
          folders.db
  rmdir /home/mfl/.evolution/mail
  FAILED: Directory not empty (contents follows)
          local
  rmdir /home/mfl/.evolution/tasks
  FAILED: Directory not empty (contents follows)
          tasks

(evolution:32563): GLib-GObject-CRITICAL **: Object class EMFolderTree doesn't implement property 'paste-target-list' from interface 'ESelectable'

(evolution:32563): GLib-GObject-CRITICAL **: Object class EMFolderTree doesn't implement property 'copy-target-list' from interface 'ESelectable'
[DEBUG] exchange-mapi-connection.c:3671: Entering mapi_profile_load
Unknown parameter encountered: "max log size"
Ignoring unknown parameter "max log size"
Unknown parameter encountered: "syslog"
Ignoring unknown parameter "syslog"
Unknown parameter encountered: "passdb backend"
Ignoring unknown parameter "passdb backend"
Unknown parameter encountered: "unix password sync"
Ignoring unknown parameter "unix password sync"
Unknown parameter encountered: "passwd program"
Ignoring unknown parameter "passwd program"
Unknown parameter encountered: "pam password change"
Ignoring unknown parameter "pam password change"
Unknown parameter encountered: "map to guest"
Ignoring unknown parameter "map to guest"
Unknown parameter encountered: "usershare allow guests"
Ignoring unknown parameter "usershare allow guests"
Unknown parameter encountered: "guest ok"
Ignoring unknown parameter "guest ok"
Unknown parameter encountered: "guest ok"
Ignoring unknown parameter "guest ok"
[DEBUG] Loading profile <email address hidden>@<IP of Exchange>
[DEBUG] exchange-mapi-connection.c:3712: Leaving mapi_profile_load
[DEBUG] exchange-mapi-connection.c:379: exchange_mapi_connection_new: lock(session/global_lock)
[DEBUG] exchange-mapi-connection.c:398: exchange_mapi_connection_new: unlock(session/global_lock)
[DEBUG] exchange-mapi-connection.c:400: exchange_mapi_connection_new: Connected
[DEBUG] exchange-mapi-connection.c:3215: Entering exchange_mapi_connection_get_folders_list
[DEBUG] exchange-mapi-connection.c:3217: exchange_mapi_connection_get_folders_list: lock(session/global_lock)
[DEBUG] exchange-mapi-connection.c:3342: exchange_mapi_connection_peek_folders_list: lock(session/global_lock)
[DEBUG] exchange-mapi-connection.c:3283: exchange_mapi_connection_get_folders_list: unlock(session/global_lock)
[DEBUG] exchange-mapi-connection.c:3285: Leaving exchange_mapi_connection_get_folders_list

(evolution:32563): camel-mapi-provider-WARNING **: Could not get folder list (GetHierarchyTable: MAPI error MAPI_E_NO_SUPPORT (0x80040102) occurred)

[DEBUG] exchange-mapi-connection.c:3215: Entering exchange_mapi_connection_get_folders_list
[DEBUG] exchange-mapi-connection.c:3217: exchange_mapi_connection_get_folders_list: lock(session/global_lock)
[DEBUG] exchange-mapi-connection.c:3215: Entering exchange_mapi_connection_get_folders_list
[DEBUG] exchange-mapi-connection.c:3217: exchange_mapi_connection_get_folders_list: lock(session/global_lock)
[DEBUG] exchange-mapi-connection.c:3283: exchange_mapi_connection_get_folders_list: unlock(session/global_lock)
[DEBUG] exchange-mapi-connection.c:3285: Leaving exchange_mapi_connection_get_folders_list
[DEBUG] exchange-mapi-connection.c:3345: exchange_mapi_connection_peek_folders_list: unlock(session/global_lock)
[DEBUG] exchange-mapi-connection.c:3342: exchange_mapi_connection_peek_folders_list: lock(session/global_lock)
[DEBUG] exchange-mapi-connection.c:3283: exchange_mapi_connection_get_folders_list: unlock(session/global_lock)
[DEBUG] exchange-mapi-connection.c:3285: Leaving exchange_mapi_connection_get_folders_list

(evolution:32563): camel-mapi-provider-WARNING **: Could not get folder list (GetHierarchyTable: MAPI error MAPI_E_NO_SUPPORT (0x80040102) occurred)

[DEBUG] exchange-mapi-connection.c:3345: exchange_mapi_connection_peek_folders_list: unlock(session/global_lock)
[DEBUG] exchange-mapi-connection.c:2507: Entering exchange_mapi_connection_get_default_folder_id
[DEBUG] exchange-mapi-connection.c:2509: exchange_mapi_connection_get_default_folder_id: lock(session/global_lock)
[DEBUG] exchange-mapi-connection.c:2518: exchange_mapi_connection_get_default_folder_id: unlock(session/global_lock)
[DEBUG] exchange-mapi-connection.c:2520: Leaving exchange_mapi_connection_get_default_folder_id
[DEBUG] exchange-mapi-connection.c:3215: Entering exchange_mapi_connection_get_folders_list
[DEBUG] exchange-mapi-connection.c:3217: exchange_mapi_connection_get_folders_list: lock(session/global_lock)
[DEBUG] exchange-mapi-connection.c:3283: exchange_mapi_connection_get_folders_list: unlock(session/global_lock)
[DEBUG] exchange-mapi-connection.c:3285: Leaving exchange_mapi_connection_get_folders_list
[DEBUG] exchange-mapi-connection.c:3342: exchange_mapi_connection_peek_folders_list: lock(session/global_lock)
[DEBUG] exchange-mapi-connection.c:3345: exchange_mapi_connection_peek_folders_list: unlock(session/global_lock)
[DEBUG] exchange-mapi-connection.c:3215: Entering exchange_mapi_connection_get_folders_list
[DEBUG] exchange-mapi-connection.c:3217: exchange_mapi_connection_get_folders_list: lock(session/global_lock)
[DEBUG] exchange-mapi-connection.c:3283: exchange_mapi_connection_get_folders_list: unlock(session/global_lock)
[DEBUG] exchange-mapi-connection.c:3285: Leaving exchange_mapi_connection_get_folders_list

Related branches

Michael Flaig (mflaig) wrote :

After some searching the Web I get the feeling not many people using evolution-mapi however that may just mean that it used to work right and nobody has had issues :-) Currently all my machines are natty already so I cannot test with maverick ATM. If someone else can please do so - I am very busy next 2 weeks and can not invest much time.

I think this bug should at least be checked before the launch of natty so we can be sure to have no regression here and make users with corporate accounts unhappy - yes? Please help. Thanks a lot.

tags: added: natty
summary: - exchange 2010 evolution-mapi - no folders or calendar, contact, tasks
+ [natty] exchange 2010 evolution-mapi - no folders or calendar, contact,
+ tasks
Steven Miano (mianosm) wrote :
Download full text (4.0 KiB)

I too am using exchange 2010, with evolution 2.32:
ii evolution-mapi 0.32.2-0ubuntu1 Exchange support for the Evolution groupware suite
ii evolution-mapi-dbg 0.32.2-0ubuntu1 debugging symbols for the Evolution MAPI provider
ii libexchangemapi-1.0-0 0.32.2-0ubuntu1 client library for accessing Exchange servers - runtime
ii libmapi0 1:0.11~bzr1932-1build1 Client library for the MAPI protocol
ii evolution 2.32.2-0ubuntu4 groupware suite with mail client and organizer
ii evolution-common 2.32.2-0ubuntu4 architecture independent files for Evolution
ii evolution-data-server 2.32.2-0ubuntu1 evolution database backend server
ii evolution-data-server-common 2.32.2-0ubuntu1 architecture independent files for Evolution Data Server
ii evolution-exchange 2.32.2-0ubuntu3 Exchange plugin for the Evolution groupware suite
ii evolution-indicator 0.2.14-0ubuntu3 GNOME panel indicator applet for Evolution
ii evolution-mapi 0.32.2-0ubuntu1 Exchange support for the Evolution groupware suite
ii evolution-mapi-dbg 0.32.2-0ubuntu1 debugging symbols for the Evolution MAPI provider
ii evolution-plugins 2.32.2-0ubuntu4 standard plugins for Evolution
ii evolution-webcal 2.32.0-0ubuntu2 webcal: URL handler for GNOME and Evolution
ii libebackend1.2-0 2.32.2-0ubuntu1 Utility library for evolution data servers
ii libebook1.2-10 2.32.2-0ubuntu1 Client library for evolution address books
ii libecal1.2-8 2.32.2-0ubuntu1 Client library for evolution calendars
ii libedata-book1.2-8 2.32.2-0ubuntu1 Backend library for evolution address books
ii libedata-cal1.2-10 2.32.2-0ubuntu1 Backend library for evolution calendars
ii libedataserver1.2-14 2.32.2-0ubuntu1 Utility library for evolution data servers
ii libedataserverui1.2-11 2.32.2-0ubuntu1 GUI utility library for evolution data servers
ii libevolution 2.32.2-0ubuntu4 evolution libraries

I am actually able to authenticate to the server, and sending mail is no problem at all, however folders will not sync and this means no inbox (owa works, and that is fine, but offline access is desired).

The errors I'm seeing are:

(evolution:3558): camel-mapi-provider-WARNING **: Could not get folder list (Ge...

Read more...

Fabien Poussin (fpoussin) wrote :

Confirmed by several people.

Changed in evolution-mapi (Ubuntu):
status: New → Confirmed

Confirming for Maverick (but using: Version: 0.32.0-0ubuntu1~maverick3 from https://launchpad.net/~suraia/+archive/ppa)

Leon (leonbo) wrote :

I'm wondering if it's broken for everyone or just for a particular configuration? Would be nice if this could be fixed before the release of natty. If it can't be fixed I would suggest to remove it from the repositories. If you install something from the default ubuntu repositories and it's broken, that's a real disappointment.

Fabien Poussin (fpoussin) wrote :

Found a workaround:

Seems like the TableFlags_UseUnicode Flag is causing problems.

"apt-get remove evolution-mapi plugin".

Then "apt-src install evolution plugin". (you might need to install apt-src)

patch -p1 < thepatch

./configure ; nice make -j5 ; sudo make install

Patch:
--- old/exchange-mapi-connection.c 2011-04-15 15:25:37.566310966 +0200
+++ new/exchange-mapi-connection.c 2011-04-15 15:32:46.726311163 +0200
@@ -40,6 +40,8 @@
 #include <param.h>

 #define DEFAULT_PROF_NAME "mapi-profiles.ldb"
+#define HAVE_LIBMAPI_CONTEXT_PARAM
+

 static void register_connection (ExchangeMapiConnection *conn);
 static void unregister_connection (ExchangeMapiConnection *conn);
@@ -2969,7 +2971,7 @@
        }

        /* Get the hierarchy table */
- ms = GetHierarchyTable (&obj_folder, &obj_table, TableFlags_Depth | TableFlags_NoNotifications | TableFlags_UseUnicode, &row_count);
+ ms = GetHierarchyTable (&obj_folder, &obj_table, TableFlags_Depth | TableFlags_NoNotifications, &row_count);
        if (ms != MAPI_E_SUCCESS) {
                make_mapi_error (perror, "GetHierarchyTable", ms);
                result = FALSE;

Fabien,

I'm not sure that I followed your instructions to the letter, and my results
are telling me I have not.

My history is:

225 sudo apt-get install apt-src
226 sudo apt-get remove evolution-mapi
227 sudo apt-src install evolution-mapi
228 cd evolution-mapi-0.32.2/
229 cd src/
230 cd libexchangemapi/
231 sudo vim exchange-mapi-connection.c
>>>At this point I added the: #define HAVE_LIBMAPI_CONTEXT_PARAM, as well as
removing the | TableFlags_UseUnicode from the file.
232 sudo ./configure ; nice make -j5 ; sudo make install

Upon running evolution I receive:

http://paste.ubuntu.com/594509/

Do I need to just copy your patch a file named "thepatch.txt" and apply it
with the patch -p1 < thepatch.txt style you stated instead of editing the
source?

Thanks,

~Steve

On Fri, Apr 15, 2011 at 9:37 AM, Fabien Poussin
<email address hidden>wrote:

> Found a workaround:
>
> Seems like the TableFlags_UseUnicode Flag is causing problems.
>
> "apt-get remove evolution-mapi plugin".
>
> Then "apt-src install evolution plugin". (you might need to install apt-
> src)
>
> patch -p1 < thepatch
>
> ./configure ; nice make -j5 ; sudo make install
>
> Patch:
> --- old/exchange-mapi-connection.c 2011-04-15 15:25:37.566310966 +0200
> +++ new/exchange-mapi-connection.c 2011-04-15 15:32:46.726311163 +0200
> @@ -40,6 +40,8 @@
> #include <param.h>
>
> #define DEFAULT_PROF_NAME "mapi-profiles.ldb"
> +#define HAVE_LIBMAPI_CONTEXT_PARAM
> +
>
> static void register_connection (ExchangeMapiConnection *conn);
> static void unregister_connection (ExchangeMapiConnection *conn);
> @@ -2969,7 +2971,7 @@
> }
>
> /* Get the hierarchy table */
> - ms = GetHierarchyTable (&obj_folder, &obj_table, TableFlags_Depth |
> TableFlags_NoNotifications | TableFlags_UseUnicode, &row_count);
> + ms = GetHierarchyTable (&obj_folder, &obj_table, TableFlags_Depth |
> TableFlags_NoNotifications, &row_count);
> if (ms != MAPI_E_SUCCESS) {
> make_mapi_error (perror, "GetHierarchyTable", ms);
> result = FALSE;
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/740642
>
> Title:
> [natty] exchange 2010 evolution-mapi - no folders or calendar,
> contact, tasks
>
> To unsubscribe from this bug, go to:
>
> https://bugs.launchpad.net/ubuntu/+source/evolution-mapi/+bug/740642/+subscribe
>

--
Miano, Steven M.
  727.244.9990
<http://stevenmiano.com> <http://facebook.com/mianosm>
<http://twitter.com/mianosm>
  <http://www.linkedin.com/in/mianosm>

Leon (leonbo) wrote :

I tried to apply the patch but it failed. Fabien, could you upload the patch as a .patch file? Maybe launchpad garbles the indent or line endings or something. Thanks in advance!

Steven Miano (mianosm) wrote :

I wouldn't mind a working .deb or a ppa to test/try out either if you wanted
to go those/that route.

Thanks!

~Steve

On Wed, Apr 20, 2011 at 6:01 AM, Leon <email address hidden> wrote:

> I tried to apply the patch but it failed. Fabien, could you upload the
> patch as a .patch file? Maybe launchpad garbles the indent or line
> endings or something. Thanks in advance!
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/740642
>
> Title:
> [natty] exchange 2010 evolution-mapi - no folders or calendar,
> contact, tasks
>
> To unsubscribe from this bug, go to:
>
> https://bugs.launchpad.net/ubuntu/+source/evolution-mapi/+bug/740642/+subscribe
>

--
Miano, Steven M.
  727.244.9990
<http://stevenmiano.com> <http://facebook.com/mianosm>
<http://twitter.com/mianosm>
  <http://www.linkedin.com/in/mianosm>

Simon (simon-turvey) wrote :

+1 for this bug. I've tried removing the flags to GetHierarchyTable() one at a time and get the same error even with a 0 value.

ghomem (gustavo) wrote :

Fabien,

Did you test accented folder names with your patched version?

Fabien Poussin (fpoussin) wrote :

Hi guys,

I'll try to re-patch and post the exact steps I followed. I might have missed something.

@ghomem:
Nope, I'm not using unicode on folder names. I guess it won't work since the unicode flag is gone.

Fabien Poussin (fpoussin) wrote :

By the way, I hade to remove the original package before patching, compiling and installing the new one.

make sure the old package is gone! (start evolution and ensure that MAPI is not available anymore)
then you can do the patching steps. (use apt-src, don't download the files manually or it won't work)

I had this problem at the beginning.

Leon (leonbo) wrote :

This is what I'm getting:

leon@polly:~/src/evolution-mapi/evolution-mapi-0.32.2/src/libexchangemapi$ patch -p1 < ~/src/evolution-mapi/evolution-mapi.patch
patching file exchange-mapi-connection.c
Hunk #2 FAILED at 2971.
1 out of 2 hunks FAILED -- saving rejects to file exchange-mapi-connection.c.rej
leon@polly:~/src/evolution-mapi/evolution-mapi-0.32.2/src/libexchangemapi$ cat exchange-mapi-connection.c.rej
--- exchange-mapi-connection.c 2011-04-15 15:25:37.566310966 +0200
+++ exchange-mapi-connection.c 2011-04-15 15:32:46.726311163 +0200
@@ -2971,7 +2973,7 @@
        }

        /* Get the hierarchy table */
- ms = GetHierarchyTable (&obj_folder, &obj_table, TableFlags_Depth | TableFlags_NoNotifications | TableFlags_UseUnicode, &row_count);
+ ms = GetHierarchyTable (&obj_folder, &obj_table, TableFlags_Depth | TableFlags_NoNotifications, &row_count);
        if (ms != MAPI_E_SUCCESS) {
                make_mapi_error (perror, "GetHierarchyTable", ms);
                result = FALSE;

Download full text (3.2 KiB)

Hello all.
Here is "my way".
===
1. Initial state
~$ aptitude search evolution-mapi
p evolution-mapi - Exchange support for the Evolution groupwa
p evolution-mapi-dbg - debugging symbols for the Evolution MAPI p
~$ aptitude search libexchangemapi
p libexchangemapi-1.0-0 - client library for accessing Exchange serv
p libexchangemapi-1.0-dev - client library for accessing Exchange serv
p libexchangemapi1.0-0 - transitional dummy package for exchangemap
p libexchangemapi1.0-dev - transitional dummy package for exchangemap

2. Getting the source
~$ mkdir mapi-fix
~$ cd mapi-fix/
~/mapi-fix$ sudo apt-src install evolution-mapi
~/mapi-fix$ ls -1sh
total 720K
4.0K evolution-mapi-0.32.2
8.0K evolution-mapi_0.32.2-0ubuntu1.debian.tar.gz
4.0K evolution-mapi_0.32.2-0ubuntu1.dsc
704K evolution-mapi_0.32.2.orig.tar.gz

3. Correction using the vim.
4. Making the patch (see the the attached file )
4.1 I've check this patch on the original file and you can apply it something like
~/mapi-fix$ sudo patch evolution-mapi-0.32.2/src/libexchangemapi/exchange-mapi-connection.c exchange-mapi-connection.c.patch
patching file evolution-mapi-0.32.2/src/libexchangemapi/exchange-mapi-connection.c
5. Building
sudo apt-get -b source evolution-mapi
5.1 Here are some deb's
~/mapi-fix$ ls -1sh
total 1.9M
4.0K evolution-mapi-0.32.2
8.0K evolution-mapi_0.32.2-0ubuntu1.debian.tar.gz
4.0K evolution-mapi_0.32.2-0ubuntu1.dsc
4.0K evolution-mapi_0.32.2-0ubuntu1_i386.changes
244K evolution-mapi_0.32.2-0ubuntu1_i386.deb
704K evolution-mapi_0.32.2.orig.tar.gz
768K evolution-mapi-dbg_0.32.2-0ubuntu1_i386.deb
4.0K exchange-mapi-connection.c.patch
 16K libexchangemapi1.0-0_0.32.2-0ubuntu1_all.deb
 88K libexchangemapi-1.0-0_0.32.2-0ubuntu1_i386.deb
 16K libexchangemapi1.0-dev_0.32.2-0ubuntu1_all.deb
 12K libexchangemapi-1.0-dev_0.32.2-0ubuntu1_i386.deb

6. Installing
6.1 libexchangemapi must be installed the FIRST
~/mapi-fix$ sudo dpkg -i libexchangemapi-1.0-0_0.32.2-0ubuntu1_i386.deb
Selecting previously deselected package libexchangemapi-1.0-0.
(Reading database ... 178271 files and directories currently installed.)
Unpacking libexchangemapi-1.0-0 (from libexchangemapi-1.0-0_0.32.2-0ubuntu1_i386.deb) ...
Setting up libexchangemapi-1.0-0 (0.32.2-0ubuntu1) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
6.2 evolution-mapi must be the SECOND
 ~/mapi-fix$ sudo dpkg -i evolution-mapi_0.32.2-0ubuntu1_i386.deb
Selecting previously deselected package evolution-mapi.
(Reading database ... 178279 files and directories currently installed.)
Unpacking evolution-mapi (from evolution-mapi_0.32.2-0ubuntu1_i386.deb) ...
Setting up evolution-mapi (0.32.2-0ubuntu1) ...

7. Check the state
~/mapi-fix$ aptitude search evolution-mapi
i evolution-mapi - Exchange support for the Evolution
p evolution-mapi-dbg - debugging symbols for the Evolution
~/mapi-fix$ aptitude search libexchangemapi
i libexchangemapi-1.0-0 - client library for accessing Exchan
p libexchangemapi-1.0-dev - client library for accessing Exchan
p libexchangemapi1.0-0 - transiti...

Read more...

Here are built deb's for the previous post.
* evolution-mapi_0.32.2-0ubuntu1_i386.deb http://db.tt/nKVNYiO
* libexchangemapi-1.0-0_0.32.2-0ubuntu1_i386.deb http://db.tt/6W8MPlF

tags: added: patch
Steven Miano (mianosm) wrote :

Thank you very much Maverick Crank Grey, I was able to follow your steps, and apply the patch to the source and achieve much success while attempting to sync my contacts, GAL, e-mail, and Calendar to an exchange 2010 server.

I have some built deb's (amd64 flavor for those that aren't on x86):

* evolution-mapi_0.32.2-0ubuntu1_amd64.deb
          http://stevenmiano.com/misc/evolution-mapi_0.32.2-0ubuntu1_amd64.deb
* libexchangemapi-1.0-0_0.32.2-0ubuntu1_amd64.deb
          http://stevenmiano.com/misc/libexchangemapi-1.0-0_0.32.2-0ubuntu1_amd64.deb

ghomem (gustavo) wrote :

I confirm that this patch works. As far as accented folder names are concerned, after applying the patch:

1- it is NOT possible to CREATE folder with accented names from Evolution
2- it is possible to RETRIEVE folders with accented names that were created vi OWA (web interface)

ghomem (gustavo) wrote :
Leon (leonbo) wrote :

Steven, you packages work like a charm! Thanks!

ghomem (gustavo) wrote :

I'm having a lot of problems on meeting requests for multiple participants, acceptance, refusal, status check etc, on Exchange 2010. Is it only me?

rod singleton (rod40cool) wrote :

Steven, your debs work great for email however, Calendar crashes out about 20% thru trying to sync and I get
"Error on mapi://[myusername]@192.168.110.65/ Failed to fetch changes from a server: QueryRows: MAPI error MAPI_E_NOT_IMPLEMENTED (0x80040fff) occurred",
followed by
"The Evolution calendar has quit unexpectedly."

Also, when I tried to create a new calendar appointment I get:-
"Cannot create a new event
'Calendar' is a read-only calendar and cannot be modified. Please select a different calendar from the side bar in the Calendar view."

To top that off, after a --force-shutdown and restart of Evoloution I now have two calendars called "Calendar" listed under the name of my Exchange 2010 account.

Jostein (josteinaj) wrote :

When can I expect to get the patched version through the Ubuntu repositories?

Mike Farmer (mike-farmer) wrote :

I was able to download the to .deb files and install which appears to have allowed my mail to download (it's in progress). My environment is Exchange 2010 (non-SP1) in a clustered CAS configuration.

Mike Farmer (mike-farmer) wrote :

OK, so after getting all mail to sync I can send/receive mail messages. however, the Global Address List/Calendar/Memo's seems very unstable. I get messages popping-up that say "evolution mapi_e_not_implemented" and then eventually it says that Evolution Memo has quit unexpectedly - your memos will not be available until evolution is restarted.

Axel H. (staff-pro-unreal) wrote :

I can confirm this issue and the patch solved the bug not being able to connect to the exchange 2010 server.
But I also receive MAPI_E_NOT_IMPLEMENTED errors randomly (Also on e-mail folders)

Christian Salway (ccsalway) wrote :

Running Exchange 2010 SP1 with all system updates as of today. Exchange servers are running with a Client Access Array.

The email folders sync fine, but the contacts, calendar and tasks don't.

I can create new contact lists but when I try to access any it says Invalid Source
I can add new calendars but can't add events to any calendar. When I try it says Unable to Open Calendar.
I can add task lists to tasks but cant add tasks within any lists. No error message is displayed.

Changes made from Office Outlook running at the same time on another machine, are not reflected in Evolution unless restarted.

So it's good for email but nothing else at the moment. Sorry, I would love to help further but I'm a C# developer :(

matlakzoli (matlakzoli) wrote :

I can confirm this issue and the patch solved the bug not being able to connect to the exchange 2010 server. Thanks

Sebastian Rothe (creeper-si) wrote :

Yes, the 64-bit debs fixed some things. I have access to my calendar now, which means it displays all my events.

Léa GRIS (lea-gris) wrote :

Same issue here with regular IMAP on a newly fresh install of Natty and only one email account on Evolution

isprewo (mrzx4-ubuntu) wrote :

The solution from Maverick Crank GRey works with my ubuntu 11.04 only for Mail and Contacts. But the Tasks and the Calender can't be opend e.g. when i want to create a new meeting.
Iḿ a newbee with linux maybe anyone can help me to troubleshoot the problem!

nucleuskore (doctorjohn2) wrote :

Running Ubuntu 11.04 64 bit. My institution migrated to Exchange 2010.
Thanks to Steven Miano (mianosm), your packages work fine. Am able to browse the calendar, addressbook and mail

Anthony (anthony-linnett) wrote :

+1 to nucleuskore. Running Ubuntu 10.04 64 bit, Exchange 2010 SP1.

Steven Miano (mianosm) 64bit debs solved the problem, however evolution gui was flaky when setting up the MAPI account. Mail is following fine now.

Thanks for the support guys!

Stephan Ruegamer (sadig) wrote :

I can also confirm that mapi connections are working, authentication works fine, but folder sync etc. are not.

I'll go for the proposed patch and eventually file an update request for natty ...

Jelmer Vernooij (jelmer) on 2011-08-13
Changed in evolution-mapi (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → High
assignee: nobody → Jelmer Vernooij (jelmer)
Changed in evolution-mapi:
importance: Unknown → Medium
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evolution-mapi - 3.1.5-0ubuntu1

---------------
evolution-mapi (3.1.5-0ubuntu1) oneiric; urgency=low

  * Update watch file.
  * New upstream release.
   + Fixes FTBFS with newer versions of evolution and OpenChange. LP: #740642
   + Fixes listing folders with Exchange 2010. LP: #653489
   + No longer discards remote recipients if there are local
     recipients in an email message. LP: #744880
   + Handles emails with empty body. LP: #808692
  * Bump standards version to 3.9.2 (no changes).
 -- Jelmer Vernooij <email address hidden> Fri, 19 Aug 2011 01:05:08 +0200

Changed in evolution-mapi (Ubuntu):
status: In Progress → Fix Released
Michael Flaig (mflaig) wrote :

Thank you for the update.

The dependencies are not right for evolution on oneiric as it seems, because during install dpkg gives the following feedback.
--- snip ---
The following packages have unmet dependencies:
 evolution-mapi : Depends: libevolution (< 3.1) but 3.1.5-0ubuntu2 is to be installed
                  Depends: evolution (< 3.1) but 3.1.5-0ubuntu2 is to be installed
--- snap ---

Michael Flaig (mflaig) wrote :

Ignore my comment, the new package hasn't hit my mirror yet. Sorry.

Evan Derickson (derickson-e) wrote :

I see that this is fixed with Evolution 3.x in Oneiric, but the fix is unlikely to make it to Natty. Is there any way to get evolution-mapi 0.32.2-2, which I believe fixes this specific bug, ported to Natty? That fix is described at https://bugzilla.gnome.org/show_bug.cgi?id=580621 and apparently made it into Fedora.

Jelmer Vernooij (jelmer) wrote :

Hi Evan,

Natty already has 0.32.2.

Evan Derickson (derickson-e) wrote :

Natty has 0.32.2-1, I believe. The package info says it went into Natty in March. A minor update, 0.32.2-2, was released in May, and I think it was to fix this issue. The author said it was the same fix that went into the 3.x branch, which I personally found to work.

Damayanthi Herath (shakyadh) wrote :

Thank you Maverick.I had the same issue in Evolution mapi in ubuntu 11.04 .The patch provided , solved my problem.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.