Ubuntu

evolution crashed with SIGSEGV in __strlen_sse2()

Reported by Philippe Gauthier on 2010-09-27
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
evolution-mapi (Ubuntu)
Medium
Unassigned

Bug Description

Evolution will crash while I am trying to set up a MAPI account since the update of libmapi to version 0.30. I attempted to start with a fresh Evolution setup (deleted .evolution, gconftool-2 --recursive-unset /apps/evolution) but I also get a crash when creating the MAPI account in the wizard.

The command "openchangeclient --database=.openchange/profiles.ldb --profile=$USER --fetchmail" also crashes in Logon(), but differently:
#0 0x00007ffff785c525 in ocpf_yyparse () from /usr/lib/libocpf.so.0
#1 0x00007ffff7ddb6a8 in ?? () from /usr/lib/libmapi.so.0
#2 0x0000000000623670 in ?? ()
#3 0x00007ffff7a731e8 in ?? () from /usr/lib/libmapi.so.0
#4 0x000000000036e7a0 in ?? ()
#5 0x0000000000618620 in ?? ()
#6 0x0000000000623840 in ?? ()
#7 0x0000000000623840 in ?? ()
#8 0x00007ffff7ddb6a8 in ?? () from /usr/lib/libmapi.so.0
#9 0x00007ffff7df1825 in _dl_runtime_resolve ()
    at ../sysdeps/x86_64/dl-trampoline.S:41
#10 0x00007ffff7ac992d in Logon () from /usr/lib/libmapi.so.0
#11 0x00007ffff7acd007 in MapiLogonProvider () from /usr/lib/libmapi.so.0
#12 0x00007ffff7acd26c in MapiLogonEx () from /usr/lib/libmapi.so.0
#13 0x0000000000409955 in ?? ()
#14 0x00007ffff6c8ad8e in __libc_start_main (main=<value optimized out>,
    argc=<value optimized out>, ubp_av=<value optimized out>,
    init=<value optimized out>, fini=<value optimized out>,
    rtld_fini=<value optimized out>, stack_end=0x7fffffffe218)
    at libc-start.c:226
#15 0x0000000000403479 in ?? ()
#16 0x00007fffffffe218 in ?? ()
#17 0x000000000000001c in ?? ()

I will try to get debug packages and upload a complete stack trace.

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: evolution 2.30.3-1ubuntu5
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
CheckboxSubmission: 0378b0df62dc16d1ca4403d7647600ef
CheckboxSystem: 6ce041aeed0a2c17b3343b66d157175d
CrashCounter: 1
Date: Mon Sep 27 17:04:18 2010
ExecutablePath: /usr/bin/evolution
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
ProcCmdline: evolution
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=fr_CA.utf8
SegvAnalysis:
 Segfault happened at: 0x7f3a3fbdfe52 <__strlen_sse2+18>: pcmpeqb (%rdi),%xmm2
 PC (0x7f3a3fbdfe52) ok
 source "(%rdi)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%xmm2" ok
 Stack memory exhausted (SP below stack segment)
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: evolution
StacktraceTop:
 __strlen_sse2 () at ../sysdeps/x86_64/multiarch/../strlen.S:31
 __strdup (s=0x0) at strdup.c:42
 krb5_appdefault_string () from /usr/lib/libkrb5.so.3
 krb5_appdefault_time () from /usr/lib/libgensec.so.0
 krb5_get_init_creds_opt_set_default_flags () from /usr/lib/libgensec.so.0
Title: evolution crashed with SIGSEGV in __strlen_sse2()
UserGroups: adm admin cdrom dialout libvirtd lpadmin plugdev sambashare
XsessionErrors:
 (polkit-gnome-authentication-agent-1:2347): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (nautilus:2350): GConf-CRITICAL **: gconf_value_free: assertion `value != NULL' failed

libmapi0:
  Installed: 1:0.9+svn2158-0ubuntu1
  Candidate: 1:0.9+svn2158-0ubuntu1
  Version table:
 *** 1:0.9+svn2158-0ubuntu1 0
        500 http://ca.archive.ubuntu.com/ubuntu/ maverick/universe amd64 Packages
        100 /var/lib/dpkg/status
openchangeclient:
  Installed: 1:0.9+svn2158-0ubuntu1
  Candidate: 1:0.9+svn2158-0ubuntu1
  Version table:
 *** 1:0.9+svn2158-0ubuntu1 0
        500 http://ca.archive.ubuntu.com/ubuntu/ maverick/universe amd64 Packages
        100 /var/lib/dpkg/status

StacktraceTop:
 __strlen_sse2 () at ../sysdeps/x86_64/multiarch/../strlen.S:31
 *__GI___strdup (s=0x0) at strdup.c:42
 krb5_appdefault_string (
 krb5_appdefault_time () from /usr/lib/libgensec.so.0
 krb5_get_init_creds_opt_set_default_flags ()

Changed in openchange (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace

This bug is probably a duplicate of bug #338982. However it is marked as Fix Released and I am still experiencing crashes.

Using an IP address instead of the host name is a workaround for this bug.

affects: openchange (Ubuntu) → evolution-mapi (Ubuntu)
visibility: private → public
MindFury (phil-mindfury) wrote :

I'm getting the exact same crash:

Program received signal SIGSEGV, Segmentation fault.
__strlen_sse2 () at ../sysdeps/x86_64/multiarch/../strlen.S:31
31 ../sysdeps/x86_64/multiarch/../strlen.S: No such file or directory.
 in ../sysdeps/x86_64/multiarch/../strlen.S

(gdb) bt
#0 __strlen_sse2 () at ../sysdeps/x86_64/multiarch/../strlen.S:31
#1 0x00007fffef970b76 in __strdup (s=0x0) at strdup.c:42
#2 0x00007fffeded5d38 in krb5_appdefault_string () from /usr/lib/libkrb5.so.3
#3 0x00007fffdb4ce23e in krb5_appdefault_time () from /usr/lib/libgensec.so.0
#4 0x00007fffdb4ede63 in krb5_get_init_creds_opt_set_default_flags () from /usr/lib/libgensec.so.0
#5 0x00007fffdb42ba9d in kerberos_kinit_password_cc () from /usr/lib/libgensec.so.0
#6 0x00007fffdb435253 in kinit_to_ccache () from /usr/lib/libgensec.so.0
#7 0x00007fffdb433c15 in cli_credentials_get_named_ccache () from /usr/lib/libgensec.so.0
#8 0x00007fffdb433cd6 in cli_credentials_get_ccache () from /usr/lib/libgensec.so.0
#9 0x00007fffdb433f38 in cli_credentials_get_client_gss_creds () from /usr/lib/libgensec.so.0
#10 0x00007fffdb43768c in ?? () from /usr/lib/libgensec.so.0

(gdb) disassemble
Dump of assembler code for function __strlen_sse2:
   0x00007fffef970e40 <+0>: pxor %xmm2,%xmm2
   0x00007fffef970e44 <+4>: mov %rdi,%rcx
   0x00007fffef970e47 <+7>: mov %rdi,%r8
   0x00007fffef970e4a <+10>: and $0xfffffffffffffff0,%rdi
   0x00007fffef970e4e <+14>: movdqa %xmm2,%xmm1
=> 0x00007fffef970e52 <+18>: pcmpeqb (%rdi),%xmm2
   0x00007fffef970e56 <+22>: or $0xffffffffffffffff,%esi
   0x00007fffef970e59 <+25>: sub %rdi,%rcx
   0x00007fffef970e5c <+28>: shl %cl,%esi
   0x00007fffef970e5e <+30>: pmovmskb %xmm2,%edx

I deleted $HOME/.evolution, $HOME/.gconf/apps/evolution, logged out and back in. The crash occurs when I switch to Exchange MAPI from the setup wizard, enter in my Exchange server (still crashes, by IP or hostname), and click Authenticate.

Pablo Borjas (jpborjas) wrote :

I just started seeing this today. I use the system on a daily basis, and I haven't updated or upgraded anything in my system since Feb 14th. I use Evolution-Exchange, not Mapi, as I connect to a 2003 server.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers