Ubuntu

MAPI - can't send mails to addresses on same server

Reported by Brad Johnson on 2009-04-15
60
This bug affects 9 people
Affects Status Importance Assigned to Milestone
evolution mapi
Fix Released
High
evolution-mapi (Ubuntu)
Low
Unassigned

Bug Description

When I send emails using openchange's mapi support on evolution, I can email
others with a different mail server than mine (if mine is x@a.com, they would
be y@b.com)

I cannot email others on my own email server (y@a.com).

This issue is also logged on the openchange bug list, but may be with the
plugin and not the openchange libraries.

http://trac.openchange.org/ticket/125

Steps to reproduce:
1. Send email to someone with same email server *@myserver.com
2. Receive email from mailserver stating " The e-mail account does not exist
at the organization this message was sent to. Check the e-mail address, or
contact the recipient directly to find out the correct address."

Actual results:

Expected results:

Does this happen every time?
Yes.

Brad Johnson (kkhww1902) on 2009-04-15
affects: ubuntu → evolution-mapi (Ubuntu)
Changed in evolution-mapi:
status: Unknown → Confirmed
Changed in evolution-mapi (Ubuntu):
importance: Undecided → Low
status: New → Triaged
MetaCarpal (metacarpal) wrote :

Seeing same behavior in Fedora 11. This is a bug with openchange itself, not evolution-mapi. Trying to send emails from the command line using openchangeclient results in the same message rejection pattern for email addresses on the same domain.

I see this behaviour too. (Ubuntu Jaunty all latest packages, 64bit)

Scott Brown (scotty-b-brown) wrote :

Same here - jaunty - 64bit.

Changed in evolution-mapi:
status: Confirmed → In Progress
ndv (ndv-excite) wrote :

Confirmed here, I cannot send mail to my coworker.
this is what I receive when I try to send a message to myself or any coworker:

from: <email address hidden> <email address hidden>
Reply-to: "<email address hidden>" <<email address hidden>

this is the address resolved by the plugin:

IMCEAEX-_O=FIRST+20ORGANIZATION_OU<email address hidden>

I use Exchange 2007

Tom Durrant (thdurrant) wrote :

Same here (jaunty, all latest packages) . I get a message very similar to ndv above, using exchange 2007.

cosmic (cosmicdreams) wrote :

I was able to get a test email to work. I don't know everything about my server details but I'll post more as I find out more information. Here's what I know.

I was not able to send email messages to lists or email aliases. For example we have a email address called people that is a distribution list.

But when I used the full email address <firstname>.<lastname>@<mydomain>.com it worked.

Perhaps this problem is only for aliases and distribution lists. Can anyone confirm that this problem exists in other versions of Exchange?

HfX (krasnojarsk) wrote :

Same here (karmic) on Kubuntu.
openchangeclient from command line, same result. internal works external does not work.
I can provide some more details from the exchange server that I got by mail:

/SNIP
Diagnoseinformationen für Administratoren:

Generierender Server: xxxxx.nortiw.wiroot.local

<email address hidden>

#550 5.1.1 RESOLVER.ADR.ExRecipNotFound; not found ##

Ursprüngliche Nachrichtenkopfzeilen:

Received: from CLUSTER.nortiw.tooriw.local ([fe80::c093:1dcf:5d6d:12be])

 by xxxxx.nortiw.tooriw.local ([110.110.110.110]) with mapi; Tue, 15 Dec

 2009 15:35:06 +0100

Content-Type: application/ms-tnef; name="winmail.dat"

Content-Transfer-Encoding: binary

From: "Peter, Peter" <email address hidden>

To: Peter <email address hidden>

Date: Tue, 15 Dec 2009 15:35:05 +0100

Subject: Betreff

Thread-Topic: Betreff

Thread-Index: Acp9k8tb5X1ZmoDPREmvl7AmK/CP+A==

Message-ID: <email address hidden>

Accept-Language: de-DE

Content-Language: de-DE

X-MS-Has-Attach:

X-MS-TNEF-Correlator: <email address hidden>

MIME-Version: 1.0

\SNAP

openchangeclient -V
  Version 0.8 (Cochrane)

Maybe the problem is this long string:

To: Peter <email address hidden>

I think, the part "20ADMINISTRATIVE+20..." must look like:

<IMCEAEX-_O=NORTIW_OU=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=CLUSTER is at CURRENTCLUSTERHOSTNAME.nortiw.tooriw.local

Maybe that's the problem??

P.S.
I changed IPs and hostnames in the above output.

HfX (krasnojarsk) wrote :

I have another useful information.

I could sent to a user in my exchange organisation (the one that was failing before) when NOT using his primary SMTP-address.

I used one of its 2 other smtp adresses (in this case <email address hidden>) and it worked.

So it looks like this might have something to do with searching in the global addressbook before sending?

I also tried with this users 3rd smtp address and it worked fine,too.

So what we now now is, that the problem can be limited to the primary smtp address of the user. I also tried "LastName, Firstname" which does not work either.
I think it has to to something with the global address book.

Bug was gone as soon as I updated my Fedora 12 evolution packages to the following versions:

evolution-mapi-0.28.2-1.fc12.x86_64
evolution-2.28.2-1.fc12.x86_64
evolution-help-2.28.2-1.fc12.noarch
evolution-data-server-2.28.2-1.fc12.x86_64

Bryan Moore (moore-bryan) wrote :

Unfortunately, I have the same install as Jhonny, but still can't send emails housed on the same server. Any ideas about movement on this issue?

Bryan Moore (moore-bryan) wrote :

It would _seem_ openchange posted a [url="http://trac.openchange.org/changeset/1649"]fix[/url], but I'm not sure how to apply it... any ideas?

Could this be a caused by cross domain trusts or dns? In my case, we
have 2 domains and exchange only runs in 1. The workstation I was
testing with was getting dns from domain 2. The dns search suffix
being domain 2 might have done sth to this.

On 2/3/10, Bryan Moore <email address hidden> wrote:
> It would _seem_ openchange posted a
> [url="http://trac.openchange.org/changeset/1649"]fix[/url], but I'm not
> sure how to apply it... any ideas?
>
> --
> MAPI - can't send mails to addresses on same server
> https://bugs.launchpad.net/bugs/361993
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Sent from my mobile device

Antony Jones (wrh) wrote :

This bug makes using exchange mail on Linux impossible which means that we can't use Linux in a corporate environment. I'm confused as to why this is considered low priority.

Steve Romanow (slestak989) wrote :

Not completely useless. Imap and OWA are still connection points.

thomas (tva) wrote :

Also a problem on fully updated ubuntu 9.10. This must be fixed - not sending emails within the same server makes Ubuntu totally useless for any company use......

Randy Goddard (randage) wrote :

I see the same on 9.10 64-bit with the latest updates against an Exchange 2007 server. Please, please escalate the priority of this defect. We've been waiting years for a mapi plugin that would work consistently against Exchange 2007, and now that we have it, we cannot sent messages to those on the same server. Ouch!

If there is any additional debug information I can provide, or if a gdb core would help, please let me know. I'm happy to help in any way I can.

Steve Romanow (slestak989) wrote :

Has anyone looked upstream to see if this problem is already reported? This package is MOTU, so it is not maintained by Ubuntu. Saying ubuntu is completely useless in the enterprise is a slight over-reaction.

No other distro has a fully functional mapi client either :)

It is very very strange that this is considered Low Importance. If Ubuntu's ever going to get accepted in companies we must have support for Exchange, like it or not. I think it should be High Importance. I can not reply to ANY of my coworkers mail with this. Completely useless to use Evolution if we can't get this to work ASAP. What can we do about it? How can we escalate this?

Anyway: Sending mails from "scratch" works fine for me. Replying to mail in my inbox does not work.

I think this bug also is the same as:
https://bugs.launchpad.net/ubuntu/+source/evolution-exchange/+bug/187723

The reason for not being able to reply to meeting request is probably that the reply mail gets stuck because of THIS bug.

sam tygier (samtygier) wrote :

the upstream bug is marked fixed, but the patch looks quite big.

ubuntu used quite an old releases of evolution for lucid (they considered the changes from 2.28 to 2.30 to be big and have a potential for regressions). so i would not be surprised if using some more up to date packages would help. has anyone tested in 10.10 yet?

personally i am accessing an exchange server in evolution using IMAP, which works fine.

Colin Watson (cjwatson) wrote :

evolution-mapi (0.30.3-1ubuntu1) maverick; urgency=low

  * Merge from debian to get a working evolution-mapi with evolution 2.30
    in maverick, remaining changes: (LP: #616294)
    - debian/control:
      transitional packages from libexchangemapi1.0-0 to libexchangemap-1.0-0
      and libexchangemapi1.0-dev to libexchangemapi-1.0-dev
  * New version fixing:
    - crash in mapi_sync_deleted (Milan Crha) (LP: #456651)
    - Sending mail fails for cluster setup (Bharath Acharya) (LP: #361993)
    - Store sent messages in Sent Items, not Outbox (Milan Crha) (LP: #561794)
    - Crashed with SIGSEGV in get_SPropValue (Milan Crha) (LP: #510527)
    - To field is not shown in sent item folder (Johnny Jacob) (LP: #574994)
    - Evolution Core Dumps when creating a MAPI account (Milan Crha)
      (LP: #338982, #340532, #355045)

 -- Didier Roche <email address hidden> Tue, 14 Sep 2010 20:50:55 +0200

Changed in evolution-mapi (Ubuntu):
status: Triaged → Fix Released
Changed in evolution-mapi:
importance: Unknown → High
status: In Progress → Fix Released
Sebastian Martinez (tychocity) wrote :

same problem with today updates

therblack (therblack) wrote :

Still a problem after updating evolution today

therblack (therblack) wrote :

Any news on this? Should I open a separate bug?

For me, at any rate, it is a high priority (as I can't send emails internally!)

vold (ubuntu-garaidh) wrote :

Me too, fully updated Maverick. Evolution with debugging enabled shows nothing useful in a terminal, I just get
"Error while Sending message.

Could not send message"

Sending to external addresses works fine.

This is really a show stopper for Ubuntu in a corporate evironment. I appreciate the bug has been classified as High now, but this plugin really needs a bit more testing and it should be in Main. Of course Im not discounting that possibility that our Exchange servers are broken, but I see so many bug reports about this plugin I have to wonder if it is even worth including in Ubuntu unless it is going to be seriously maintained and supported by Canonical.

Sebastian Martinez (tychocity) wrote :

same problem maverick fully update, exchange 2003 cluster.

Hi,

I'm a newcomer to this forum and found some great answers. Thank you all for that ;)

But to keep it on track, I was about to say I've got the same problem. And though I do have it, I also have a partial solution. I'm running a windows small business 2008 server with exchange 2007 installed. On my client I run Ubuntu 10.10 with Evolution 2.30.3 installed. This with the exchange mapi plugin.

I found that I could mail to myself both within our domain as to my gmail account. Then I found I could not mail to my coworkers, so in my journey in finding a solution to this I came to this forum. Now I find everybody here has the same problem. So I started working on a solution to give something back to the community. I tried to mail to a couple of coworkers all together and I found that there was 1 coworker that received my mail. :s So here I present part of the problem/solution.

Everybody (at least in the unix based world) knows that solaris/unix/linux etc is case sensitive and windows isn't. My coworker that received the mail has a mailaddress that is listed in exchange with all lowercase letters. The coworkers that didn't receive a mail all had at least 1 capital letter in their mailaddress. I tried to change the mail address of another coworker to all lowercase letters, but it didn't solve the problem. Probably because windows doesn't mind the case... So I created a new user account with all lowercase letters, attached a mailbox to it. Presto !!! I can mail to that user as well.

Bottom line : If the receiver has a mailaddress that was created using lowercase letters then the problem is solved. Who can confirm this?

Johan,

I can confirm that. If I send to <email address hidden> it works perfectly. If I try <email address hidden> it just sits in the Outbox and eventually that cannot send error pops up. Good call!

-Matt

In addition to my previous post I found something else that could cause a problem.

After recreating all mailboxes in my environment with lowercase letters, I was still unable to send mail to 2 persons. The mailboxes in question are : <email address hidden> and <email address hidden>. These users have these displaynames in exchanges : "rené lastname" and "juliëtte lastname". After changing the firstname in the displayfield to : "rene" and "juliette" within the exchange environment I could send mail to both these people. Also there is someone that has a mailaddress : <email address hidden>, there is no problem in sending mail to this box.

My guess is that when there is an ascii character above 128 it doesn't work properly. This besides the upper/lower case problem.

At this moment I'm able to send mail from evolution in my ubuntu using the exchange mapi plugin to ALL users in my environment :D :D

Mark Van Goth (mark-van-goth) wrote :

HI All,

I've solved this problem.It is related with the default configuration of evolution and evolution mapi.

This is how I solved the problem(3-step-Instructions).

1)After lanching evolution and setting up the account, click on ''Edit''(On the Main toolbar) and Preferences.Here you have the ''Mail Account'' section.

2)Select your account and click the button ''Edit''(Top right-corner of the window)

3)Now the ''Identity'' tab should be opened.Check ''Make this my default account''.Close Evolution and relaunch it.

That's it!!!

Repeat the whole operation for every account you add, and there will be no problem.

Mark Van Goth (mark-van-goth) wrote :

HI All,

I've solved this problem.It is related to the default configuration of evolution and evolution mapi.

This is how I solved the problem(3-step-Instructions).

1)After lanching evolution and setting up the account, click on ''Edit''(On the Main toolbar) and Preferences.Here you have the ''Mail Account'' section.

2)Select your account and click the button ''Edit''(Top right-corner of the window)

3)Now the ''Identity'' tab should be opened.Check ''Make this my default account''.Close Evolution and relaunch it.

That's it!!!

Repeat the whole operation for any other account which uses the mapi protocol , and there will be no problem.You need only once (the first time) to ''make it the default account''.Once everything is set up, you can define your permanent default account.

Good job Mark.

On Wed, Apr 4, 2012 at 5:14 AM, Mark Van Goth <email address hidden> wrote:
> HI All,
>
> I've solved this problem.It is related to the default configuration of
> evolution and evolution mapi.
>
> This is how I solved the problem(3-step-Instructions).
>
> 1)After lanching evolution and setting up the account, click on
> ''Edit''(On the Main toolbar) and Preferences.Here you have the ''Mail
> Account'' section.
>
> 2)Select your account and click the button ''Edit''(Top right-corner of
> the window)
>
> 3)Now the ''Identity'' tab should be opened.Check ''Make this my default
> account''.Close Evolution and relaunch it.
>
> That's it!!!
>
> Repeat the whole operation for any other account which uses the mapi
> protocol , and there will be no problem.You need only once (the first
> time) to ''make it the default account''.Once everything is set up, you
> can define your permanent default account.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/361993
>
> Title:
>  MAPI - can't send mails to addresses on same server
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/evolution-mapi/+bug/361993/+subscriptions

LinkedIn
------------

Bug,

I'd like to add you to my professional network on LinkedIn.

- Steve

Steve Romanow
Application Developer
Greater Grand Rapids, Michigan Area

Confirm that you know Steve Romanow:
https://www.linkedin.com/e/-ijpy85-hbfa3ee5-24/isd/10241136033/DCaopzeV/?hs=false&tok=0WPEwljTMT7BA1

--
You are receiving Invitation to Connect emails. Click to unsubscribe:
http://www.linkedin.com/e/-ijpy85-hbfa3ee5-24/XXVn_Yu8-XPXfdcZu9XaBAo8wuBHoaN7xnj08OC/goo/361993%40bugs%2Elaunchpad%2Enet/20061/I3406801776_1/?hs=false&tok=2jbwXmaiYT7BA1

(c) 2012 LinkedIn Corporation. 2029 Stierlin Ct, Mountain View, CA 94043, USA.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.