evolution 2.25.92 evolution-mapi evolution exits on mapi preferences authentication.

Bug #340532 reported by EMallory on 2009-03-10
124
This bug affects 16 people
Affects Status Importance Assigned to Milestone
evolution mapi
Fix Released
Critical
evolution-mapi (Ubuntu)
Medium
Unassigned
Nominated for Karmic by Clint Foster
Nominated for Lucid by Clint Foster

Bug Description

Open Evolution
Edit-> Prefs-> choose Mapi Account
Click Edit
Click the Receiving Email tab
Fill in the values for server user and domain
Click Authenticate

exchange-mapi-connection.c:1233: Leaving exchange_mapi_connection_fetch_items: folder-id 6855766165268987X Create profile with f282c439 ad exchange-01.ad.wichita.edu
libexchangemapi-Message: exchange-mapi-connection.c:2880: exchange_mapi_create_profile: lock(connect_lock)
    MAPIInitialize : MAPI_E_SESSION_LIMIT (0x80040112)
Logging into the server... succeeded
libexchangemapi-Message: exchange-mapi-connection.c:146: exchange_mapi_connection_close: lock(connect_lock)
Segmentation fault (core dumped)

I'd attach a core file... but I /etc/security/limits.conf doesn't seem to affect my session, even after logout and log in... heck I I'd put it through gdb myself if I had a core file.

jtuchscherer (jtuchscherer) wrote :

Hi,

I had the same problem. I marked my bug as a duplicate of this one. Here is a link to it:
https://bugs.launchpad.net/ubuntu/+source/evolution-mapi/+bug/346065

My bug report was generated by Apport and contains all the files that apport generates. You might want to take a look at it.

jari (jaript) wrote :

Mine seems similar too... though this is when creating a new account with the initial wizard. Same thing, filling in the values and clicking authenticate and then it crashes. Here's what's output to the terminal:

** (evolution:22191): DEBUG: Loading Exchange MAPI Plugin

** (evolution:22191): DEBUG: MAPI listener is constructed with 0 listed MAPI accounts
e-data-server-ui-Message: Unable to find password(s) in keyring (Keyring reports: No matching results)
e-data-server-ui-Message: Key file does not have group 'Passwords-ExchangeMAPI'
Create profile with ******** *** ********.*******.****.***
libexchangemapi-Message: exchange-mapi-connection.c:2880: exchange_mapi_create_profile: lock(connect_lock)
Unknown parameter encountered: "max log size"
Ignoring unknown parameter "max log size"
Unknown parameter encountered: "syslog"
Ignoring unknown parameter "syslog"
Unknown parameter encountered: "passdb backend"
Ignoring unknown parameter "passdb backend"
Unknown parameter encountered: "unix password sync"
Ignoring unknown parameter "unix password sync"
Unknown parameter encountered: "passwd program"
Ignoring unknown parameter "passwd program"
Unknown parameter encountered: "pam password change"
Ignoring unknown parameter "pam password change"
Unknown parameter encountered: "map to guest"
Ignoring unknown parameter "map to guest"
Unknown parameter encountered: "usershare allow guests"
Ignoring unknown parameter "usershare allow guests"
Unknown parameter encountered: "guest ok"
Ignoring unknown parameter "guest ok"
Unknown parameter encountered: "guest ok"
Ignoring unknown parameter "guest ok"
Logging into the server... succeeded
libexchangemapi-Message: exchange-mapi-connection.c:146: exchange_mapi_connection_close: lock(connect_lock)

[1]+ Segmentation fault (core dumped) evolution

Version:
evolution-mapi-0.26.0.1-0ubuntu1
evolution-2.26.0-0ubuntu2
Ubuntu Jaunty beta

Yunnus (tarik-benammar) wrote :

Same symptoms here.

Evolution crashes when I try to authenticate to the exchange server.

Here's what I got:

Unknown parameter encountered: "max log size"
Ignoring unknown parameter "max log size"
Unknown parameter encountered: "syslog"
Ignoring unknown parameter "syslog"
Unknown parameter encountered: "passdb backend"
Ignoring unknown parameter "passdb backend"
Unknown parameter encountered: "unix password sync"
Ignoring unknown parameter "unix password sync"
Unknown parameter encountered: "passwd program"
Ignoring unknown parameter "passwd program"
Unknown parameter encountered: "pam password change"
Ignoring unknown parameter "pam password change"
Unknown parameter encountered: "map to guest"
Ignoring unknown parameter "map to guest"
Unknown parameter encountered: "usershare allow guests"
Ignoring unknown parameter "usershare allow guests"
Unknown parameter encountered: "guest ok"
Ignoring unknown parameter "guest ok"
Unknown parameter encountered: "guest ok"
Ignoring unknown parameter "guest ok"
Logging into the server... Failed to bind to uuid 1544f5e0-613c-11d1-93df-00c04fd7bd09 - NT_STATUS_NET_WRITE_FAULT
Failed to bind to uuid f5cc5a18-4264-101a-8c59-08002b2f8426 - NT_STATUS_NET_WRITE_FAULT
    MapiLogonProvider : MAPI_E_LOGON_FAILED (0x80040111)
(evolution:5185): libexchangemapi-DEBUG: Deleting profile <email address hidden>@acme.com
Segmentation fault (core dumped)

Version:
evolution-mapi-0.26.0.1-0ubuntu1
evolution-2.26.0-0ubuntu2
Ubuntu Jaunty beta

** (evolution:16795): DEBUG: Loading Exchange MAPI Plugin

** (evolution:16795): DEBUG: MAPI listener is constructed with 0 listed MAPI accounts
** (evolution:16795): DEBUG: mailto URL command: evolution %s
** (evolution:16795): DEBUG: mailto URL program: evolution
** (evolution:16795): DEBUG: EI: SHELL STARTUP
EI: MAIL PREFSe-data-server-ui-Message: Unable to find password(s) in keyring (Keyring reports: Nenhum resultado encontrado)
e-data-server-ui-Message: Arquivo de chave não tem grupo "Passwords-ExchangeMAPI"
Create profile with coordtecrc unijorge.edu.br webmail.unijorge.edu.br
libexchangemapi-Message: exchange-mapi-connection.c:2874: exchange_mapi_create_profile: lock(connect_lock)
libexchangemapi-Message: exchange-mapi-connection.c:2887: exchange_mapi_create_profile: unlock(connect_lock)

(evolution:16795): e-data-server-ui-WARNING **: Unable to find password(s) in keyring (Keyring reports: Nenhum resultado encontrado)
e-data-server-ui-Message: Unable to find password(s) in keyring (Keyring reports: Nenhum resultado encontrado)
e-data-server-ui-Message: Arquivo de chave não tem grupo "Passwords-ExchangeMAPI"
Create profile with coordtecrc unijorge.edu.br fjadex01
libexchangemapi-Message: exchange-mapi-connection.c:2874: exchange_mapi_create_profile: lock(connect_lock)
Unknown parameter encountered: "max log size"
Ignoring unknown parameter "max log size"
Unknown parameter encountered: "syslog"
Ignoring unknown parameter "syslog"
Unknown parameter encountered: "passdb backend"
Ignoring unknown parameter "passdb backend"
Unknown parameter encountered: "unix password sync"
Ignoring unknown parameter "unix password sync"
Unknown parameter encountered: "passwd program"
Ignoring unknown parameter "passwd program"
Unknown parameter encountered: "pam password change"
Ignoring unknown parameter "pam password change"
Unknown parameter encountered: "map to guest"
Ignoring unknown parameter "map to guest"
Unknown parameter encountered: "usershare allow guests"
Ignoring unknown parameter "usershare allow guests"
Unknown parameter encountered: "guest ok"
Ignoring unknown parameter "guest ok"
Unknown parameter encountered: "guest ok"
Ignoring unknown parameter "guest ok"
Logging into the server... Failed to bind to uuid 1544f5e0-613c-11d1-93df-00c04fd7bd09 - NT_STATUS_NET_WRITE_FAULT
succeeded
libexchangemapi-Message: exchange-mapi-connection.c:146: exchange_mapi_connection_close: lock(connect_lock)
Falha de segmentação (core dumped)

Changed in evolution-mapi (Ubuntu):
status: New → Confirmed
mizu (michal-zimen) wrote :

Hi,
  Partial success in my case:

  I tried to rename /etc/samba/smb.conf to /etc/samba/smb.conf_OLD and evolution-mapi works quite well.
I don't use samba now. But I'm able to read my exchange emails now :)

Jaunty with evolution-mapi-0.26.1 (compiled from sources)

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a backtrace following the instructions at http://wiki.ubuntu.com/DebuggingProgramCrash and upload the backtrace (as an attachment) to the bug report. This will greatly help us in tracking down your problem.

Changed in evolution-mapi (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Matt Curtis (mattcurtis) wrote :

I had the same problem; I tried mizu's solution, which is to disable Samba by renaming smb.conf, and evolution-mapi now works beautifully. Just FYI.

Jonathan Knowles (jsk) wrote :

Confirming a similar failure when using a fresh installation of Ubuntu 9.04 i386 Desktop.

I'm connecting to Exchange 2007. Here's the error message produced when running Evolution for the first time from the console:

jsk@xenon:~$ evolution
** (evolution:3137): DEBUG: Loading Exchange MAPI Plugin

** (evolution:3137): DEBUG: MAPI listener is constructed with 0 listed MAPI accounts
e-data-server-ui-Message: Unable to find password(s) in keyring (Keyring reports: No matching results)
e-data-server-ui-Message: Key file does not have group 'Passwords-ExchangeMAPI'
Create profile with <user-name> <domain-name> <server-name>
libexchangemapi-Message: exchange-mapi-connection.c:2874:
exchange_mapi_create_profile: lock(connect_lock)
Unknown parameter encountered: "max log size"
Ignoring unknown parameter "max log size"
Unknown parameter encountered: "syslog"
Ignoring unknown parameter "syslog"
Unknown parameter encountered: "passdb backend"
Ignoring unknown parameter "passdb backend"
Unknown parameter encountered: "unix password sync"
Ignoring unknown parameter "unix password sync"
Unknown parameter encountered: "passwd program"
Ignoring unknown parameter "passwd program"
Unknown parameter encountered: "pam password change"
Ignoring unknown parameter "pam password change"
Unknown parameter encountered: "map to guest"
Ignoring unknown parameter "map to guest"
Unknown parameter encountered: "usershare allow guests"
Ignoring unknown parameter "usershare allow guests"
Unknown parameter encountered: "guest ok"
Ignoring unknown parameter "guest ok"
Unknown parameter encountered: "guest ok"
Ignoring unknown parameter "guest ok"
Logging into the server... succeeded
libexchangemapi-Message: exchange-mapi-connection.c:146:
exchange_mapi_connection_close: lock(connect_lock)
Segmentation fault

I will post a back-trace when I have a moment later on.

Alex Mauer (hawke) wrote :

Same problem for me; renaming / removing smb.conf did the job for me too. Is there any information I can provide that might help diagnose the problem?

Ryan Steele (rgsteele) wrote :

I'm experiencing the same issue. When I first tried to authenticate against the Exchange server, I got an error saying "CreateProfileStore:MAPI_E_NO_ACCESS" and the program stopped responding. Subsequent attempts to authenticate are resulting in the segfault. I've installed (hopefully) all the relevant dbgsym packages and performed a backtrace.

Changed in evolution-mapi (Ubuntu):
status: Incomplete → Confirmed
Sebastien Bacher (seb128) wrote :

Could somebody having the issue open the bug on http://bugzilla.gnome.org where exchange hackers will read it and can work on it? The ubuntu bug triagers have no access to exchange server

sikke (siukola-antti) wrote :

Confirm: Rename smb.conf

Changed in evolution-mapi:
status: Unknown → New
Stephen Loeckle (sloeckle) wrote :

Confirmed rename smb.conf as well in a new installation of 9.04 i386

BVanderark (bryan-vanderark) wrote :

Renaming smb.conf got me going with Exchange 2000 on 9.04 i386. Now I need to figure out how to get my contacts, calendars, etc. working.

Changed in evolution-mapi:
status: New → Invalid
chifamba (rchifamba) wrote :

You need to make sure your smb.conf is correctly configured.

I got past this error by enabling wins with the and he name resolve order.

nemoinis (nemoinis) wrote :

chifamba, your comment #15 seems garbled. Can you rephrase and say exactly what you did to get past this error? thanks!

Ryan Steele (rgsteele) on 2009-10-23
Changed in evolution-mapi:
status: Invalid → Unknown
ender wiggin (end3er) wrote :
Download full text (4.0 KiB)

Back trace as requested:

eax 0xb43b7374 -1271172236
ecx 0xb7841ff4 -1216077836
edx 0x80040605 -2147219963
ebx 0xb43fdff4 -1270882316
esp 0xbfffe050 0xbfffe050
ebp 0xbfffe068 0xbfffe068
esi 0x0 0
edi 0xb4315c30 -1271833552
eip 0xb4315c5b 0xb4315c5b <emsmdb_disconnect_dtor+43>
eflags 0x210282 [ SF IF RF ID ]
cs 0x73 115
ss 0x7b 123
ds 0x7b 123
es 0x7b 123
fs 0x0 0
gs 0x33 51

#0 0xb4315c5b in emsmdb_disconnect_dtor () from /usr/lib/libmapi.so.0
#1 0xb4d067c2 in ?? () from /usr/lib/libtalloc.so.1
#2 0xb4d06657 in ?? () from /usr/lib/libtalloc.so.1
#3 0xb4d06657 in ?? () from /usr/lib/libtalloc.so.1
#4 0xb4d095f6 in _talloc_free () from /usr/lib/libtalloc.so.1
#5 0xb430f1bd in MAPIUninitialize () from /usr/lib/libmapi.so.0
#6 0xb4d7a6eb in exchange_mapi_connection_new () from /usr/lib/libexchangemapi-1.0.so.0
#7 0xb4d7ad50 in exchange_mapi_create_profile () from /usr/lib/libexchangemapi-1.0.so.0
#8 0xb1f5fca8 in ?? () from /usr/lib/evolution/2.28/plugins/liborg-gnome-exchange-mapi.so
#9 0xb6a8e9fc in g_cclosure_marshal_VOID__VOID () from /usr/lib/libgobject-2.0.so.0
#10 0xb6a81072 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#11 0xb6a967a8 in ?? () from /usr/lib/libgobject-2.0.so.0
#12 0xb6a97b2d in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#13 0xb6a97fb6 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#14 0xb6eb388a in gtk_button_clicked () from /usr/lib/libgtk-x11-2.0.so.0
#15 0xb6eb4ea8 in ?? () from /usr/lib/libgtk-x11-2.0.so.0
#16 0xb6a8e9fc in g_cclosure_marshal_VOID__VOID () from /usr/lib/libgobject-2.0.so.0
#17 0xb6a7f6f9 in ?? () from /usr/lib/libgobject-2.0.so.0
#18 0xb6a81072 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#19 0xb6a960b0 in ?? () from /usr/lib/libgobject-2.0.so.0
#20 0xb6a97b2d in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#21 0xb6a97fb6 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#22 0xb6eb392a in gtk_button_released () from /usr/lib/libgtk-x11-2.0.so.0
#23 0xb6eb3963 in ?? () from /usr/lib/libgtk-x11-2.0.so.0
#24 0xb6f73474 in ?? () from /usr/lib/libgtk-x11-2.0.so.0
#25 0xb6a7f6f9 in ?? () from /usr/lib/libgobject-2.0.so.0
#26 0xb6a81072 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#27 0xb6a9649e in ?? () from /usr/lib/libgobject-2.0.so.0
#28 0xb6a979b8 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#29 0xb6a97fb6 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#30 0xb708f95e in ?? () from /usr/lib/libgtk-x11-2.0.so.0
#31 0xb6f6bc20 in gtk_propagate_event () from /usr/lib/libgtk-x11-2.0.so.0
#32 0xb6f6cea9 in gtk_main_do_event () from /usr/lib/libgtk-x11-2.0.so.0
#33 0xb6db862a in ?? () from /usr/lib/libgdk-x11-2.0.so.0
#34 0xb69f2e88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#35 0xb69f6730 in ?? () from /lib/libglib-2.0.so.0
#36 0xb69f6b9f in g_main_loop_run () from /lib/libglib-2.0.so.0
#37 0xb6f6d419 in gtk_main () from /usr/lib/libgtk-x...

Read more...

Ryan Steele (rgsteele) wrote :

A patch has been committed upstream:

https://bugzilla.gnome.org/attachment.cgi?id=153276

Did some mad a new deb pakkage voor i386 and amd64 ?

Leon (leonbo) wrote :
Leon (leonbo) wrote :

@Bas van den Dikkenberg: I tried to apply the patch but it failed (chunk 2, 3 and 8)

Leon (leonbo) wrote :

I also tried installing samba and winbind. But that didn't help.

When I try to login with openchangclient I get the following error:
GSS Import name of <email address hidden> failed: Miscellaneous failure (see text): unable to find realm of host polly
Failed to start GENSEC client mech gssapi_krb5: NT_STATUS_INVALID_PARAMETER

Maybe this helps?

Leon (leonbo) wrote :

OK. I resolved my problems. First I installed likewise-open.
Then I read this: http://mailman.openchange.org/pipermail/devel/2009-December/001426.html
and this: http://blogs.msexchange.org/walther/2009/08/30/exchange-2010-and-outlook-2003-clients-connection-issues/

And that fixed it. Now I'm gonna try and remove likewise and see wat hapens...

I have this same issue, I have isolated down to one line in smb.conf

security = [server,ADS,domain]

error when running evolution from command line.

exchange-mapi-connection.c:77: Entering mapi_profile_load Unknown enumerated value 'ADS' for 'security'

if you comment this line out, evolution operates fine.

Changed in evolution-mapi:
status: Unknown → Fix Released
Uphaar Agrawalla (uphaar) wrote :

Hello,
Upstream has just committed a fix for this - is there a chance we can get it before the Lucid RC is released?

geoff (geoff-wong) wrote :

Just upgraded to Lucid. Still not working.

I found a workaround for evolution not starting due to samba3 / samba4 incompatible smb.conf:

Simply start evolution as follows:
SMB_CONF_PATH=/etc/samba/smb4.conf evolution &

Then you may at your discretion supply a clean smb4.conf, or you simply leave it out.

Works for me.

The problem with the workaround in the comment above is that for some reason it doesn't make the calender component and the address book work.

So here is another stab at the problem (a very crude one as such): If you encounter the issue, it's because you use Samba 3 in a configuration that is not understood by the Samba 4 libraries linked into Evolution-MAPI. The trick is to mutilate Samba 4 to the point that it simply cannot find the incompatible Samba 3 configuration any more.

The approach below edits the affected Samba 4 binary libs such that instead of the environment variable SMB_CONFIG_PATH they interpret SMB4_DUMMY_PA and then supply that variable pointing nowhere. dpkg-divert makes the change survive package upgrades by telling dpkg to upgrade the original copy instead of the edited file. It also makes the system ignore security updates of the affected Samba 4 libs :-( That being said, here we go:

sudo su
mkdir /usr/lib/SMB4_DUMMY_PA
for lib in libdcerpc_atsvc.so.0.0.1 libdcerpc_samr.so.0.0.1 libdcerpc.so.0.0.1 libsamba-hostconfig.so.0.0.1 libndr.so.0.0.1; do
    dpkg-divert --divert /usr/lib/SMB4_DUMMY_PA/$lib --local --rename --add /usr/lib/$lib
    sed 's/SMB_CONF_PATH/SMB4_DUMMY_PA/' /usr/lib/SMB4_DUMMY_PA/$lib > /usr/lib/$lib
done
echo 'SMB4_DUMMY_PA=/etc/samba/smb4.conf' >> /etc/environment
reboot

tags: added: patch-accepted-upstream
Changed in evolution-mapi:
importance: Unknown → Critical
Colin Watson (cjwatson) wrote :

evolution-mapi (0.30.3-1ubuntu1) maverick; urgency=low

  * Merge from debian to get a working evolution-mapi with evolution 2.30
    in maverick, remaining changes: (LP: #616294)
    - debian/control:
      transitional packages from libexchangemapi1.0-0 to libexchangemap-1.0-0
      and libexchangemapi1.0-dev to libexchangemapi-1.0-dev
  * New version fixing:
    - crash in mapi_sync_deleted (Milan Crha) (LP: #456651)
    - Sending mail fails for cluster setup (Bharath Acharya) (LP: #361993)
    - Store sent messages in Sent Items, not Outbox (Milan Crha) (LP: #561794)
    - Crashed with SIGSEGV in get_SPropValue (Milan Crha) (LP: #510527)
    - To field is not shown in sent item folder (Johnny Jacob) (LP: #574994)
    - Evolution Core Dumps when creating a MAPI account (Milan Crha)
      (LP: #338982, #340532, #355045)

 -- Didier Roche <email address hidden> Tue, 14 Sep 2010 20:50:55 +0200

Changed in evolution-mapi (Ubuntu):
status: Confirmed → Fix Released
jedioetzi (jedioetzi) wrote :

in maverick

evolution --disable-eplugin
(evolution:5091): libexchangemapi-DEBUG: exchange-mapi-connection.c:189: exchange_mapi_connection_new: lock(connect_lock)
Unknown parameter encountered: "max log size"
Ignoring unknown parameter "max log size"
Unknown parameter encountered: "syslog"
Ignoring unknown parameter "syslog"
Unknown parameter encountered: "passdb backend"
Ignoring unknown parameter "passdb backend"
Unknown parameter encountered: "unix password sync"
Ignoring unknown parameter "unix password sync"
Unknown parameter encountered: "passwd program"
Ignoring unknown parameter "passwd program"
Unknown parameter encountered: "pam password change"
Ignoring unknown parameter "pam password change"
Unknown parameter encountered: "map to guest"
Ignoring unknown parameter "map to guest"
Unknown parameter encountered: "message command"
Ignoring unknown parameter "message command"
Unknown parameter encountered: "usershare allow guests"
Ignoring unknown parameter "usershare allow guests"
Segmentation fault

evolution 2.30.3-1ubuntu6
evolution mapi 0.30.3-1ubuntu1

Paul Macdonnell (pgmac) wrote :

After upgrading to maverick, I'm seeing the same errors as jedioetzi.
It was working fine in lucid.

This is my evolution installed package:
evolution 2.30.3-1ubuntu6

These are the MAPI packages I have installed:
evolution-mapi 0.30.3-1ubuntu1
libexchangemapi-1.0-0 0.30.3-1ubuntu1
libmapi0 1:0.9+svn2158-0ubuntu1
libmapiadmin0 1:0.9+svn2158-0ubuntu1

The error message I get when testing the Authentication from within Evolution is:
Authentication failed.
MapiLogonProvider:MAPI_E_LOGON_FAILED

Jogarem (jogi) wrote :
Download full text (10.8 KiB)

I have the same problem in maverick using:

evolution 2.30.3-1ubuntu7.3
evolution-mapi 0.30.3-1ubuntu1
libmapi0 1:0.9+svn2158-0ubuntu1
libmapiadmin0 1:0.9+svn2158-0ubuntu1
libexchangemapi-1.0-0 0.30.3-1ubuntu1

Trace:

evolution
** (evolution: 6890): DEBUG: Loading Exchange MAPI Plugin

** (evolution: 6890): DEBUG: MAPI listener is constructed with 0 listed MAPI accounts
e-data-server-ui-Message: Unable to find password (s) in keyring (Keyring reports: No matching results)
e-data-server-ui-Message: Key file does not contain the group 'Passwords-ExchangeMAPI "
(evolution: 6890): libexchangemapi-DEBUG: Create profile with <MYUSER> <MYDOMAIN> <MYSERVER>

(evolution: 6890): libexchangemapi-DEBUG: exchange-mapi-connection.c: 3301: exchange_mapi_create_profile: lock (connect_lock)
(evolution: 6890): libexchangemapi-DEBUG: exchange-mapi-connection.c: 87: ensure_mapi_init_called: lock (connect_lock)
(evolution: 6890): libexchangemapi-DEBUG: exchange-mapi-connection.c: 123: ensure_mapi_init_called: unlock (connect_lock)
(evolution: 6890): libexchangemapi-DEBUG: logging into the server ...
segmentation fault

Renaming the smb file do not solve that problem for me.

Maybe good to know:
I'm using really SECURE password with special characters (e.g.: "!)$%& and so on) I don't know if this can cause problems?!

--------------------------------------

When using openchangeclient:

mapiprofile --profile=MYPROF --username=MYUSER --address=MYSERVER --domain=MYDOMAIN --realm=MYREALM --create --debuglevel=100 --password='MYPASS' --seal=true
Using binding ncacn_ip_tcp:MYSERVER
Mapped to DCERPC endpoint 135
added interface ip=xx.xx.xx.159 nmask=255.255.255.0
added interface ip=xx.xx.xx.159 nmask=255.255.255.0
     epm_Map: struct epm_Map
        in: struct epm_Map
            object : *
                object : 00000000-0000-0000-0000-000000000000
            map_tower : *
                map_tower: struct epm_twr_t
                    tower_length : 0x0000004b (75)
                    tower: struct epm_tower
                        num_floors : 0x0005 (5)
                        floors: ARRAY(5)
                            floors: struct epm_floor
                                lhs: struct epm_lhs
                                    protocol : EPM_PROTOCOL_UUID (13)
                                    lhs_data : DATA_BLOB length=18
[0000] E0 F5 44 15 3C 61 D1 11 93 DF 00 C0 4F D7 BD 09 ..D.<a.. ....O...
[0010] 01 00 ..
                                rhs : union epm_rhs(case 13)
                                uuid: struct epm_rhs_uuid
                                    unknown : DATA_BLOB length=2
[0000] 00 00 ..
                            floors: struct epm_floor
                                lhs: struct epm_lhs
                                    protocol : EPM_PRO...

Jogarem (jogi) wrote :

only a hint because of my previous comment:

I have tried it with a non-secure trivial password and it crashes with the same error..

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.