Removing package "evolution" does not remove "Set up mail..." from the Messaging Menu

Bug #663988 reported by Matthew Pirocchi on 2010-10-20
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
evolution-indicator (Ubuntu)
Low
Charles Kerr

Bug Description

Binary package hint: evolution

I don't use twitter or desktop email, so on a new install of Ubuntu 10.10, I run "sudo aptitude remove gwibber evolution". After I do this and log in again, "Set Up Broadcast..." has disappeared from the Messaging Menu as expected, but "Set Up Mail..." is still there. If I click on "Set Up Mail...", nothing happens.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: evolution (not installed)
ProcVersionSignature: Ubuntu 2.6.35-22.35-generic-pae 2.6.35.4
Uname: Linux 2.6.35-22-generic-pae i686
Architecture: i386
Date: Wed Oct 20 12:06:32 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: evolution

Sebastien Bacher (seb128) wrote :

seems a duplicate

affects: evolution (Ubuntu) → indicator-messages (Ubuntu)
Changed in indicator-messages (Ubuntu):
importance: Undecided → Low
Ted Gould (ted) wrote :

Could you check to see if this happens on a Natty install? It doesn't for me, so it might be fixed. Thanks!

Changed in indicator-messages:
status: New → Incomplete
Changed in indicator-messages (Ubuntu):
status: New → Incomplete
Changed in indicator-messages:
importance: Undecided → Low

Will do, but I won't have time to install Natty before the beta, so it will be a while.

Still occurs in Natty Alpha 3.

DavidBriscoe (idbrii) wrote :

Set up mail still shows after removing evolution in the official Natty release.

DavidBriscoe (idbrii) wrote :

Looks like the problem is that evolution-indicator doesn't depend on evolution:

$ apt-cache rdepends evolution-indicator
evolution-indicator
Reverse Depends:
  ubuntu-sugar-remix
  ubuntu-chinese-desktop
  ubuntu-desktop

If you remove the evolution-indicator package, the "Set up mail" item goes away.

Matthew Paul Thomas (mpt) wrote :

(Reopening based on Matthew Pirocchi's comment.)

Changed in indicator-messages:
status: Incomplete → New
Changed in indicator-messages (Ubuntu):
status: Incomplete → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-messages (Ubuntu):
status: New → Confirmed
affects: indicator-messages (Ubuntu) → evolution-indicator (Ubuntu)
Changed in evolution-indicator (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
no longer affects: indicator-messages
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evolution-indicator - 0.2.20-0ubuntu4

---------------
evolution-indicator (0.2.20-0ubuntu4) precise; urgency=low

  * debian/control
    - depend on evolution so evolution-indicator will get removed if
      evolution is uninstalled (LP: #663988)
 -- Ken VanDine <email address hidden> Tue, 13 Dec 2011 09:59:18 -0500

Changed in evolution-indicator (Ubuntu):
status: Confirmed → Fix Released
no longer affects: evolution-indicator
Changed in evolution-indicator (Ubuntu):
assignee: Ken VanDine (ken-vandine) → nobody
Charles Kerr (charlesk) on 2012-03-16
Changed in evolution-indicator (Ubuntu):
assignee: nobody → Charles Kerr (charlesk)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints