Eviolution crash - invalid pointer munmap_chunk()

Bug #1272469 reported by Phil Wyett
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu GNOME
Undecided
Unassigned
evolution-indicator (Ubuntu)
Medium
Unassigned

Bug Description

Eviolution crash - invalid pointer munmap_chunk(). Crashes collecting mail. App does not stay up long enough to really know.

GDB BT:

Core was generated by `evolution'.
Program terminated with signal SIGABRT, Aborted.
#0 0x00007f215af7cf39 in __GI_raise (sig=sig@entry=6)
    at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
56 ../nptl/sysdeps/unix/sysv/linux/raise.c: No such file or directory.
(gdb) bt
#0 0x00007f215af7cf39 in __GI_raise (sig=sig@entry=6)
    at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#1 0x00007f215af80348 in __GI_abort () at abort.c:89
#2 0x00007f215afb9bb4 in __libc_message (do_abort=do_abort@entry=2,
    fmt=fmt@entry=0x7f215b0c8ec8 "*** Error in `%s': %s: 0x%s ***\n")
    at ../sysdeps/posix/libc_fatal.c:175
#3 0x00007f215afc4907 in malloc_printerr (action=<optimised out>,
    str=0x7f215b0c8ef0 "munmap_chunk(): invalid pointer", ptr=<optimised out>)
    at malloc.c:4924
#4 0x00007f2119957b2a in e_plugin_lib_enable ()
   from /tmp/apport_sandbox_3iFBHQ/usr/lib/evolution/3.10/plugins/liborg-freedesktop-evolution-indicator.so
#5 0x00007f2134f8edd3 in plugin_lib_loadmodule (
    plugin=plugin@entry=0x7f2162482c00) at e-plugin-lib.c:84
#6 0x00007f2134f8ee79 in plugin_lib_get_symbol (
    plugin=plugin@entry=0x7f2162482c00,
    name=name@entry=0x7f2162482bb0 "org_gnome_mail_read_notify")
    at e-plugin-lib.c:102
#7 0x00007f2134f8efa7 in plugin_lib_invoke (plugin=0x7f2162482c00,
    name=0x7f2162482bb0 "org_gnome_mail_read_notify", data=0x7f21629cb8b0)
    at e-plugin-lib.c:126
#8 0x00007f215efc334b in e_event_emit (event=event@entry=0x7f2160191380,
    id=id@entry=0x7f213739cba9 "message.reading", target=0x7f21629cb8b0)
---Type <return> to continue, or q <return> to quit---
    at e-event.c:273
#9 0x00007f213735fd25 in mail_reader_message_loaded (reader=0x7f21624f9f50,
    message_uid=0x7f21629e68d0 "1390588328.31464_2.aura-yoda",
    message=0x7f21000062a0) at e-mail-reader.c:3087
#10 0x00007f215b61f278 in g_closure_invoke (closure=0x7f2162534660,
    return_value=0x0, n_param_values=3, param_values=0x7fff13611fc0,
    invocation_hint=0x7fff13611f60)
    at /build/buildd/glib2.0-2.39.3/./gobject/gclosure.c:777
#11 0x00007f215b6309eb in signal_emit_unlocked_R (
    node=node@entry=0x7f2162534690, detail=detail@entry=0,
    instance=instance@entry=0x7f21624f9f50,
    emission_return=emission_return@entry=0x0,
    instance_and_params=instance_and_params@entry=0x7fff13611fc0)
    at /build/buildd/glib2.0-2.39.3/./gobject/gsignal.c:3594
#12 0x00007f215b638919 in g_signal_emit_valist (instance=<optimised out>,
    signal_id=<optimised out>, detail=<optimised out>,
    var_args=var_args@entry=0x7fff13612178)
    at /build/buildd/glib2.0-2.39.3/./gobject/gsignal.c:3312
#13 0x00007f215b638bd2 in g_signal_emit (
    instance=instance@entry=0x7f21624f9f50, signal_id=<optimised out>,
    detail=detail@entry=0)
    at /build/buildd/glib2.0-2.39.3/./gobject/gsignal.c:3368
#14 0x00007f213735f232 in mail_reader_message_loaded_cb (
---Type <return> to continue, or q <return> to quit---
    folder=0x7f21601de500, result=0x7f2104002d20, closure=0x7f216017bc20)
    at e-mail-reader.c:2706
#15 0x00007f215b8d04f7 in g_simple_async_result_complete (
    simple=0x7f2104002d20)
    at /build/buildd/glib2.0-2.39.3/./gio/gsimpleasyncresult.c:770
#16 0x00007f215b8d0579 in complete_in_idle_cb_for_thread (_data=0x7f21629a26a0)
    at /build/buildd/glib2.0-2.39.3/./gio/gsimpleasyncresult.c:838
#17 0x00007f215b355a35 in g_main_dispatch (context=0x7f216005b680)
    at /build/buildd/glib2.0-2.39.3/./glib/gmain.c:3068
#18 g_main_context_dispatch (context=context@entry=0x7f216005b680)
    at /build/buildd/glib2.0-2.39.3/./glib/gmain.c:3643
#19 0x00007f215b355d98 in g_main_context_iterate (context=0x7f216005b680,
    block=block@entry=1, dispatch=dispatch@entry=1, self=<optimised out>)
    at /build/buildd/glib2.0-2.39.3/./glib/gmain.c:3714
#20 0x00007f215b35605a in g_main_loop_run (loop=0x7f2162485570)
    at /build/buildd/glib2.0-2.39.3/./glib/gmain.c:3908
#21 0x00007f215bd729b5 in gtk_main ()
    at /build/buildd/gtk+3.0-3.10.6/./gtk/gtkmain.c:1158
#22 0x00007f215f7499cf in main (argc=1, argv=0x7fff13612588) at main.c:683
(gdb)

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: evolution 3.10.3-0ubuntu3
ProcVersionSignature: Ubuntu 3.13.0-5.20-generic 3.13.0
Uname: Linux 3.13.0-5-generic x86_64
ApportVersion: 2.13.1-0ubuntu1
Architecture: amd64
CurrentDesktop: GNOME
Date: Fri Jan 24 18:53:34 2014
InstallationDate: Installed on 2014-01-24 (0 days ago)
InstallationMedia: Ubuntu-GNOME 14.04 "Trusty Tahr" - Alpha amd64 (20140124)
SourcePackage: evolution
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Phil Wyett (aura-yoda) wrote :
description: updated
Revision history for this message
Phil Wyett (aura-yoda) wrote :

Removing package 'evolution-indicator' corrects the issue, but not ideal.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in evolution (Ubuntu):
status: New → Confirmed
affects: evolution (Ubuntu) → evolution-indicator (Ubuntu)
Revision history for this message
Dave Gilbert (ubuntu-treblig) wrote :

medium: Normal application seg.

Changed in evolution-indicator (Ubuntu):
importance: Undecided → Medium
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evolution-indicator - 0.2.20-0ubuntu15

---------------
evolution-indicator (0.2.20-0ubuntu15) trusty; urgency=medium

  * debian/patches/evolution-indicator-eds3.6_v2.patch:
    - don't try to free a static string (lp: #1272469)
 -- Sebastien Bacher <email address hidden> Mon, 17 Feb 2014 15:49:42 +0100

Changed in evolution-indicator (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers