error loading addressbook from Exchange

Bug #92130 reported by Rob Byrd on 2007-03-14
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
evolution-exchange
Expired
Medium
evolution-exchange (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: evolution

When trying to check an addressee in the 'To:' of an Evolution email I got the following error dialog:

Error loading addressbook.
We were unable to open this addressbook. This either means you have entered an incorrect URI, or the server is unreachable.

There is usually (in Outlook) a complete list of students and faculty. The calendar data was imported fine. And two personal contacts were available in the "Contacts" link, but when I clicked on Global Addressbook is when I got the error dialog. The addresses are reachable via the web-based version of Outlook (using FireFox on Feisty) and when I dual boot Windows using the same computer and network connection. Is it possible that I set up Evolution incorrectly? (What else is there besides username & password?)

ProblemType: Bug
Architecture: i386
Date: Tue Mar 13 23:01:22 2007
DistroRelease: Ubuntu 7.04
Uname: Linux byrdr-desktop 2.6.20-10-generic #2 SMP Mon Mar 12 00:02:49 UTC 2007 i686 GNU/Linux

Sebastien Bacher (seb128) wrote :

Thanks for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: http://bugzilla.gnome.org/show_bug.cgi?id=418167

Changed in evolution:
importance: Undecided → Medium
status: Unconfirmed → Confirmed
Changed in evolution-exchange:
status: Unknown → Unconfirmed

No change one and a half years later, except that the error message has been shortened towards

----
Error loading addressbook.
----

This refers to Ubuntu 8.10 64-Bit and Evolution 2.24.1. Note that on Alpha and Beta versions of Ubuntu 8.10, this already worked. When choosing "Global Address Book", the address choosing window went half white and Evolution seemed to crash, but after a minute or more very often it recovered and choosing and address from the Global Address Book was possible. What's the reason for the regression?

runout (office-runout) wrote :

still not resolved?

ubuntu 8.10 64bit
evolution 2.24.3

i get this error even when evolution tries to load local addressbooks.
sometimes it loads the addressbook but mostly not.
so maybe that is not really the same bug as posted in the bugzilla link above or the bug has not really/only to do with exchange.

Still not solved here either. Ubuntu 8.10 64-Bit. By now it's Evolution 2.24.3. With that version, it hasn't worked andy time so far.

runout (office-runout) wrote :

because the initial bug report says 32 bit and "Global Addressbook" i'm not sure if it is the same bug. because its happening with all of my local addressbooks. and 64 bit.
also it seems the error message has changed inbetween. looks like the developers are not interested in solving this bug. but it would be very importent because it makes evolution contacts unusable.

esofron (esofronas) wrote :

Hello,

i have the same problem. Could someone of the developers take a look on this?

Thanks

Dak Ralter (dak.ralter) wrote :

I also have the same problem. Address list worked for Gutsy but not on any installations of Hardy that I have. When I click "To:", and then select "Global Address List" or "Contacts" from my exchange account it says "Error loading address book" at the bottom left hand corner.

Kenneth Degel (kennethdegel) wrote :

I have found that you need to make specify where the Global Catalog Server name is (ask your admin)
Menu -> Preferences
select mail accounts, select your account name, click the 'Edit' button
in the 'Receiving Options' tab put your Global Catalog server name in (often your domain name, your OWA URL may be at example.com but your domain is corp.example.com)
Hope this helps

Changed in evolution-exchange (Ubuntu):
status: Confirmed → Triaged
Bob Maria (bobmaria57) wrote :

When i faced same problem of corrupted exchange database server, i came to knew from some technical experts that it can be retained by a third party edb recovery software. I used it and my problem was solved then. If you wanna try then just go through - <a href="www.edbrecovery.net">www.edbrecovery.net</a>

Changed in evolution-exchange:
importance: Unknown → Medium
Changed in evolution-exchange:
status: New → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.