Ubuntu

evolution-exchange is ignoring already translated menu-items (Permissions..., Berechtigungen...)

Reported by Michael Basse on 2012-01-03
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Medium
Unassigned
evolution-exchange
Fix Released
Medium
evolution (Ubuntu)
Medium
Unassigned
evolution-exchange (Ubuntu)
Medium
Vibhav Pant

Bug Description

using evoltion-exchange in german has two items which are not translated, or better, the translation does not have any effect.

The file po/de.po
is holding msgstr "Berechtigungen …" which means "Permissions..."

also see

https://translations.launchpad.net/ubuntu/precise/+source/evolution-exchange/+pots/evolution-exchange/de/158/+translate

but that translation does not show up in evolution-exchange

see the menu file/Datei http://alpha-unix.de/~iceroot/ubuntu/evolution-missing-translation.png

so i guess its an error in the source-code and not in the ubuntu-translation-technic from launchpad

grep on the source-package founds the correct german translation.

There is a second missing translation (see the screenshot again)

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: evolution-exchange 3.2.1-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-7.13-generic 3.2.0-rc7
Uname: Linux 3.2.0-7-generic i686
ApportVersion: 1.90-0ubuntu1
Architecture: i386
Date: Tue Jan 3 15:39:49 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110426)
ProcEnviron:
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: evolution-exchange
UpgradeStatus: Upgraded to precise on 2011-12-04 (30 days ago)

Changed in evolution-exchange:
importance: Unknown → Medium
status: Unknown → New
Changed in evolution-exchange:
status: New → Confirmed
Changed in evolution-exchange:
status: Confirmed → Fix Released

adding german translators because i dont know the next steps. If i am correct the issue was in the source-code of evolution. The template was not used correctly. Its fixed upstream and sill affecting 11.10 and 12.04

Vibhav Pant (vibhavp) on 2012-03-28
Changed in evolution-exchange (Ubuntu):
assignee: nobody → Vibhav Pant (vibhavp)
Vibhav Pant (vibhavp) wrote :

Attached debdiff

Gabor Kelemen (kelemeng) on 2012-04-09
Changed in ubuntu-translations:
status: New → Triaged
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evolution-exchange - 3.2.1-2ubuntu2

---------------
evolution-exchange (3.2.1-2ubuntu2) precise; urgency=low

  * debian/patches/gettext_support_menu_items.patch
    - Added gettext support to menu items from plugins which were earlier not translated (LP: #911269)
 -- Vibhav Pant <email address hidden> Wed, 28 Mar 2012 16:34:47 +0530

Changed in evolution-exchange (Ubuntu):
status: New → Fix Released
Changed in ubuntu-translations:
status: Triaged → Fix Released
Martin Pitt (pitti) wrote :

Note that this failed to build: https://launchpadlibrarian.net/101596222/buildlog_ubuntu-precise-i386.evolution-exchange_3.2.1-2ubuntu2_FAILEDTOBUILD.txt.gz

This was obviously uploaded without being tested, I'll revert this for now.

Martin Pitt (pitti) wrote :

evolution-exchange (3.2.1-2ubuntu3) precise; urgency=low

  * Drop gettext_support_menu_items.patch again.
    e_action_group_add_actions_localized() is defined nowhere, so this can't
    possibly work. This was apparently uploaded without any testing. Fixes
    FTBFS.

 -- Martin Pitt <email address hidden> Fri, 13 Apr 2012 08:31:54 +0200

Changed in evolution-exchange (Ubuntu):
status: Fix Released → Triaged

Looks like this is actually missing a patch to evolution's e-util; it should be pretty straightforward to get it added since nothing would be using that function (e_action_group_add_actions_localized()) yet. See http://mail.gnome.org/archives/commits-list/2012-January/msg01662.html, though one would probably want to go find the commit on git.gnome.org/browse/evolution to make the patch easier to include in the evolution package.

I'm fixing up the package assignations.

Vibhav, do you want to give a go to fixing evolution first, then we can upload evolution-exchange again with the translations fix?

Changed in evolution (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Changed in evolution-exchange (Ubuntu):
importance: Undecided → Medium

Since this will need more work / fixing at the evolution level first, I'm unsubscribing the Ubuntu Sponsors Team.

Gabor Kelemen (kelemeng) on 2012-04-24
Changed in ubuntu-translations:
status: Fix Released → Triaged

Any news about this bug? The package from 12.04 is still affected.

Can i help in some way to get htis fixed?

Vibhav Pant (vibhavp) on 2012-06-25
Changed in evolution-exchange (Ubuntu):
assignee: Vibhav Pant (vibhavp) → nobody
Vibhav Pant (vibhavp) on 2012-06-25
Changed in evolution-exchange (Ubuntu):
assignee: nobody → Vibhav Pant (vibhavp)
Changed in ubuntu-translations:
assignee: nobody → Ubuntu German Translators (Community-Team) (ubuntu-l10n-de-community)
Hendrik Knackstedt (hennekn) wrote :

Cannot test this. Is it still a problem?

Changed in ubuntu-translations:
assignee: Ubuntu German Translators (Community-Team) (ubuntu-l10n-de-community) → nobody

Hi Hendrik,
at the moment i am using 13.04 which does not have the package evolution-exchange anymore, so i cant test it too to confirm my initial bug-report.

i installed 12.04 in virtualbox to test this bug. I installed evolution-exchange but the entries are complety gone now. I am not sure if it is because i am not connected to an exchange-server (dont have a server anymore) or if the fix was causing a new bug.

See attached "Bildschirmfoto vom 2013-05-22 23:26:27.png"

Hendrik Knackstedt (hennekn) wrote :

I think you have to run the setup-utility and configure an exchange server. Otherwise Evolution won't even notice the extension. That's the reason why I cannot test it, because I don't have access to a valid exchange server.

Nevertheless, this bug is fixed upstream and if the package got removed from Ubuntu anyway there is not much sense in trying to get this fixed for Precise since the chances are very low that a fix will ever be released (would need a SRU and translation bugs usually don't apply to this).

If this is still a problem for anybody using Precise I suggest to install the package manually.

Closing as Fix Released since Upstream fix is available.

Changed in ubuntu-translations:
status: Triaged → Fix Released
Changed in evolution (Ubuntu):
status: Triaged → Invalid
status: Invalid → Fix Released
Changed in evolution-exchange (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.