evolution-exchange: depends on libsoup2.2-3 which isn't available

Bug #7698 reported by Debian Bug Importer on 2004-08-31
6
Affects Status Importance Assigned to Milestone
evolution-exchange (Debian)
Fix Released
Unknown
evolution-exchange (Ubuntu)
Critical
Jeff Waugh

Bug Description

Automatically imported from Debian bug report #269199 http://bugs.debian.org/269199

Debian Bug Importer (debzilla) wrote :

Automatically imported from Debian bug report #269199 http://bugs.debian.org/269199

Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Tue, 31 Aug 2004 13:11:32 +0200
From: =?ISO-8859-1?Q?No=E8l_K=F6the?= <email address hidden>
To: <email address hidden>
Subject: evolution-exchange: depends on libsoup2.2-3 which isn't available

Package: evolution-exchange
Version: 1.5.90-2
Severity: serious
Justification: depends on not existing package

Hello,

I'm trying to install evolution-exchange but dselect tells me:

evolution-exchange depends on libsoup2.2-3 (>= 2.1.8)
libsoup2.2-3 does not appear to be available

-- System Information:
Debian Release: 3.1
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: i386 (i686)
Kernel: Linux 2.6.8-1-k7
Locale: LANG=C, LC_CTYPE=C

Matt Zimmerman (mdz) wrote :

evolution-exchange is installable in Warty

Matt Zimmerman (mdz) wrote :

Not anymore it isn't

And it is also a FTBFS:

exchange-account.c: In function `get_password':
exchange-account.c:804: warning: passing arg 6 of `e_passwords_ask_password'
makes pointer from integer without a cast
exchange-account.c:804: warning: passing arg 7 of `e_passwords_ask_password'
from incompatible pointer type
exchange-account.c:804: error: too many arguments to function
`e_passwords_ask_password'
make[3]: *** [exchange-account.o] Error 1
make[3]: Leaving directory `/usr/src/wartyfix/ximian-connector-1.5.92/storage'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/usr/src/wartyfix/ximian-connector-1.5.92'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/usr/src/wartyfix/ximian-connector-1.5.92'
make: *** [debian/stamp-makefile-build] Error 2

so a recompilation is not enough.

Matt Zimmerman (mdz) wrote :

FTBFS should be fixed in 1.5.92-1ubuntu2

Matt Zimmerman (mdz) wrote :

evolution-exchange confirmed installable again

tag 269199 + fixed-in-experimental

quit

This message was generated automatically in response to an
upload to the experimental distribution. The .changes file follows.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Sat, 4 Sep 2004 08:03:02 +1000
Source: ximian-connector
Binary: evolution-exchange
Architecture: source i386
Version: 1.5.94.1-1
Distribution: experimental
Urgency: low
Maintainer: Jeff Waugh <email address hidden>
Changed-By: Jeff Waugh <email address hidden>
Description:
 evolution-exchange - Exchange plugin for the Evolution groupware suite
Closes: 269199
Changes:
 ximian-connector (1.5.94.1-1) experimental; urgency=low
 .
   * New upstream release (Closes: #269199).
     - Special thanks to Jeff Bailey for his loving care and attention in
       our times of need.
Files:
 d7943b013da21c12dcb72b68ff32b568 748 gnome optional ximian-connector_1.5.94.1-1.dsc
 8ab6dc4ef389627fb520d296866a8e08 1623315 gnome optional ximian-connector_1.5.94.1.orig.tar.gz
 4c0c060db2276b1265734d37197020f3 1787 gnome optional ximian-connector_1.5.94.1-1.diff.gz
 eae03d02497a4d09db4c7e690a6580d7 617936 gnome optional evolution-exchange_1.5.94.1-1_i386.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.5 (GNU/Linux)

iD8DBQFBQOOI5M5hmdCYCpkRAuFqAJ462K9IByMgIpPcOTkJPLl4+MOaXACgig5a
Rw0cqp/hU5rZ8tOIv5HNL84=
=2blF
-----END PGP SIGNATURE-----

Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Thu, 09 Sep 2004 19:17:11 -0400
From: Jeff Waugh <email address hidden>
To: <email address hidden>
Cc: Jeff Waugh <email address hidden>
Subject: Fixed in upload of ximian-connector 1.5.94.1-1 to experimental

tag 269199 + fixed-in-experimental

quit

This message was generated automatically in response to an
upload to the experimental distribution. The .changes file follows.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Sat, 4 Sep 2004 08:03:02 +1000
Source: ximian-connector
Binary: evolution-exchange
Architecture: source i386
Version: 1.5.94.1-1
Distribution: experimental
Urgency: low
Maintainer: Jeff Waugh <email address hidden>
Changed-By: Jeff Waugh <email address hidden>
Description:
 evolution-exchange - Exchange plugin for the Evolution groupware suite
Closes: 269199
Changes:
 ximian-connector (1.5.94.1-1) experimental; urgency=low
 .
   * New upstream release (Closes: #269199).
     - Special thanks to Jeff Bailey for his loving care and attention in
       our times of need.
Files:
 d7943b013da21c12dcb72b68ff32b568 748 gnome optional ximian-connector_1.5.94.1-1.dsc
 8ab6dc4ef389627fb520d296866a8e08 1623315 gnome optional ximian-connector_1.5.94.1.orig.tar.gz
 4c0c060db2276b1265734d37197020f3 1787 gnome optional ximian-connector_1.5.94.1-1.diff.gz
 eae03d02497a4d09db4c7e690a6580d7 617936 gnome optional evolution-exchange_1.5.94.1-1_i386.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.5 (GNU/Linux)

iD8DBQFBQOOI5M5hmdCYCpkRAuFqAJ462K9IByMgIpPcOTkJPLl4+MOaXACgig5a
Rw0cqp/hU5rZ8tOIv5HNL84=
=2blF
-----END PGP SIGNATURE-----

Hi,

any estimation about when this dependency problem will be fixed?

regards
Hadmut

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Sun, 26 Sep 2004 20:46:12 +0200
From: Hadmut Danisch <email address hidden>
To: <email address hidden>
Subject: Current state?

Hi,

any estimation about when this dependency problem will be fixed?

regards
Hadmut

Hi,

btw, evolution 2.0.0 is available at
http://gnome.org/projects/evolution/stable.shtml

regards
Hadmut

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Mon, 27 Sep 2004 11:16:07 +0200
From: Hadmut Danisch <email address hidden>
To: <email address hidden>
Subject: 2.0.0 available

Hi,

btw, evolution 2.0.0 is available at
http://gnome.org/projects/evolution/stable.shtml

regards
Hadmut

<quote who="Hadmut Danisch">

> btw, evolution 2.0.0 is available at
> http://gnome.org/projects/evolution/stable.shtml

It has been uploaded to my repository, but my sponsor has not uploaded it to
experimental yet.

- Jeff

--
linux.conf.au 2005: Canberra, Australia http://linux.conf.au/

       "Having strings in a language seems to be a case of premature
                        optimization." - Paul Graham

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Mon, 27 Sep 2004 23:16:45 +1000
From: Jeff Waugh <email address hidden>
To: Hadmut Danisch <email address hidden>, <email address hidden>
Subject: Re: Bug#269199: 2.0.0 available

<quote who="Hadmut Danisch">

> btw, evolution 2.0.0 is available at
> http://gnome.org/projects/evolution/stable.shtml

It has been uploaded to my repository, but my sponsor has not uploaded it to
experimental yet.

- Jeff

--
linux.conf.au 2005: Canberra, Australia http://linux.conf.au/

       "Having strings in a language seems to be a case of premature
                        optimization." - Paul Graham

Ximian-connector has now been uploaded to unstable, closing this bug.

--
I do not agree with a word you say, but I will defend to the death your
right to say it.
 - Voltaire

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Wed, 20 Oct 2004 21:18:09 -0700
From: Jeff Bailey <email address hidden>
To: <email address hidden>
Subject: Upload done to unstable, closing this bug

Ximian-connector has now been uploaded to unstable, closing this bug.

--
I do not agree with a word you say, but I will defend to the death your
right to say it.
 - Voltaire

Changed in evolution-exchange:
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.