evolution-exchange: Newest version does not work

Bug #7166 reported by Debian Bug Importer on 2004-07-26
6
Affects Status Importance Assigned to Milestone
evolution-exchange (Debian)
Fix Released
Unknown
evolution-exchange (Ubuntu)
High
Jeff Waugh

Bug Description

Automatically imported from Debian bug report #261533 http://bugs.debian.org/261533

Debian Bug Importer (debzilla) wrote :

Automatically imported from Debian bug report #261533 http://bugs.debian.org/261533

Debian Bug Importer (debzilla) wrote :
Download full text (5.4 KiB)

Message-Id: <1090857466.14321.2.camel@localhost>
Date: Mon, 26 Jul 2004 10:57:46 -0500
From: Alex Malinovich <email address hidden>
To: <email address hidden>
Subject: evolution-exchange: Newest version does not work

--=-MoIIfzYPcrFgCjy2Yi1s
Content-Type: text/plain
Content-Transfer-Encoding: quoted-printable

Subject: evolution-exchange: Newest version does not work
Package: evolution-exchange
Version: 1.5.90-2
Severity: grave
Justification: renders package unusable

Sorry I couldn't be more descriptive with the subject. I just updated to
the newest version of evolution-exchange and evolution1.5, and my
exchange accounts no longer work. The account still shows up in the
account listing, but I never get prompted for a password, the plugin
never connects to the server, etc. Rolling back to evolution 1.4 and the
old 1.4.7 plugin works just fine. I've tried purging evolution, removing
~/.evolution, and unsetting all evolution gconf entries, and nothing has
worked. If there's any other info I can supply, please let me know. I
know this doesn't have too much detail in it, but I can't really think
of where else to look for more info.

-- System Information:
Debian Release: testing/unstable
  APT prefers experimental
  APT policy: (600, 'experimental'), (50, 'unstable')
Architecture: i386 (i686)
Kernel: Linux 2.6.6-1-686
Locale: LANG=3Den_US.UTF-8, LC_CTYPE=3Den_US.UTF-8

Versions of packages evolution-exchange depends on:
pi evolution-data-server 0.0.96-1 evolution database backend ser=
ver
ii evolution1.5 1.5.91-1 The groupware suite
ii libart-2.0-2 2.3.16-5 Library of functions for 2D gr=
aphi
ii libasn1-6-heimdal 0.6.2-3 Libraries for Heimdal Kerberos
ii libatk1.0-0 1.6.1-2 The ATK accessibility toolkit
ii libaudiofile0 0.2.6-4 Open-source version of SGI's a=
udio
ii libbonobo2-0 2.6.2-4 Bonobo CORBA interfaces librar=
y
ii libbonoboui2-0 2.6.1-1 The Bonobo UI library
ii libc6 2.3.2.ds1-13 GNU C Library: Shared librarie=
s an
ii libcomerr2 1.35-6 The Common Error Description l=
ibra
ii libdb4.2 4.2.52-16 Berkeley v4.2 Database Librari=
es [
ii libesd-alsa0 [libesd0] 0.2.29-1 Enlightened Sound Daemon (ALSA=
) -=20
ii libfontconfig1 2.2.2-2 generic font configuration lib=
rary
ii libfreetype6 2.1.7-2.1 FreeType 2 font engine, shared=
 lib
ii libgal2.2-0 2.1.12-1 G App Libs (run time library)
ii libgconf2-4 2.7.1-1 GNOME configuration database s=
yste
ii libgcrypt7 1.1.90-9 LGPL Crypto library - runtime =
libr
ii libglade2-0 1:2.4.0-1 Library to load .glade files a=
t ru
ii libglib2.0-0 2.4.4-1 The GLib library of C routines
ii libgnome-keyring0 0.2.1-2 GNOME keyring services library
ii libgnome2-0 2.7.1-2 The GNOME 2 library - runtime =
file
ii libgnomecanvas2-0 2.7.1-1 A powerful object-oriented dis=
play
ii libgnomep...

Read more...

This was posted today to the connector mailing list by Ben Armstrong
(<email address hidden>) . Following these directions, I've got
everything working OK. So either evolution-exchange or evolution-data-
server need to be 'fixed'.

--begin quote--
Hi,

Today I made the switch to evo 1.5 from Debian experimental (1.5.91)
plus the current evolution-exchange package from Jeff's site that
depends on evolution1.5. It looks good so far, but I did want to
caution anyone trying this out that evolution1.5 1.5.91 depends on
evolution-data-server 0.0.96, which provides libegroupwise.so.3, not
libegroupwise.so.2, as ximian-connector-setup-1.5 and the latest
exchange plugin require. Thus, it is necessary to symlink
libegroupwise.so.2 -> libegroupwise.so.3.0.0 to get this combination of
packages to work.

Ben
--end quote--

Debian Bug Importer (debzilla) wrote :

Message-Id: <1090948611.32443.3.camel@localhost>
Date: Tue, 27 Jul 2004 12:16:51 -0500
From: Alex Malinovich <email address hidden>
To: <email address hidden>
Subject: more info

--=-Gpb9p400Em7RMQ8H2xAv
Content-Type: text/plain
Content-Transfer-Encoding: quoted-printable

This was posted today to the connector mailing list by Ben Armstrong
(<email address hidden>) . Following these directions, I've got
everything working OK. So either evolution-exchange or evolution-data-
server need to be 'fixed'.

--begin quote--
Hi,

Today I made the switch to evo 1.5 from Debian experimental (1.5.91)
plus the current evolution-exchange package from Jeff's site that
depends on evolution1.5. It looks good so far, but I did want to
caution anyone trying this out that evolution1.5 1.5.91 depends on
evolution-data-server 0.0.96, which provides libegroupwise.so.3, not
libegroupwise.so.2, as ximian-connector-setup-1.5 and the latest
exchange plugin require. Thus, it is necessary to symlink
libegroupwise.so.2 -> libegroupwise.so.3.0.0 to get this combination of
packages to work.

Ben
--end quote--

--=-Gpb9p400Em7RMQ8H2xAv
Content-Type: application/pgp-signature; name=signature.asc
Content-Description: This is a digitally signed message part

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)

iD8DBQBBBo4DBPYwh6bSSDcRAkL4AJ0V2WeVwsZUrowW9v6H4StvcaJL8wCgnHt/
CRl4i4WE7DyfMj4XQlemKCw=
=gi6o
-----END PGP SIGNATURE-----

--=-Gpb9p400Em7RMQ8H2xAv--

tag 261533 + fixed-in-experimental

quit

This message was generated automatically in response to an
upload to the experimental distribution. The .changes file follows.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Fri, 30 Jul 2004 23:13:32 -0700
Source: ximian-connector
Binary: evolution-exchange
Architecture: source i386
Version: 1.5.91-1
Distribution: experimental
Urgency: low
Maintainer: Jeff Waugh <email address hidden>
Changed-By: Jeff Waugh <email address hidden>
Description:
 evolution-exchange - Exchange plugin for the Evolution groupware suite
Closes: 261533
Changes:
 ximian-connector (1.5.91-1) experimental; urgency=low
 .
   * New upstream release (Closes: #261533).
Files:
 37ae36540b4cb9cbc6c19b21bb9d8175 728 gnome optional ximian-connector_1.5.91-1.dsc
 9ab0bdef5fa05d043de32893da93b60c 1263311 gnome optional ximian-connector_1.5.91.orig.tar.gz
 f44fe3c8843a4676ce6c1b64c180f774 1846 gnome optional ximian-connector_1.5.91-1.diff.gz
 f704a35f11fb1dd293c2e2da7e17134c 445646 gnome optional evolution-exchange_1.5.91-1_i386.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)

iD8DBQFBDuKJmHaJYZ7RAb8RAqE7AJ4+BIT+y/f7pVoncv9U/fm8qMhKIgCfX1XJ
rgal5oZ2zogq5uXzS8mM/Yc=
=ld0F
-----END PGP SIGNATURE-----

Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Mon, 02 Aug 2004 21:17:11 -0400
From: Jeff Waugh <email address hidden>
To: <email address hidden>
Cc: Jeff Waugh <email address hidden>
Subject: Fixed in upload of ximian-connector 1.5.91-1 to experimental

tag 261533 + fixed-in-experimental

quit

This message was generated automatically in response to an
upload to the experimental distribution. The .changes file follows.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Fri, 30 Jul 2004 23:13:32 -0700
Source: ximian-connector
Binary: evolution-exchange
Architecture: source i386
Version: 1.5.91-1
Distribution: experimental
Urgency: low
Maintainer: Jeff Waugh <email address hidden>
Changed-By: Jeff Waugh <email address hidden>
Description:
 evolution-exchange - Exchange plugin for the Evolution groupware suite
Closes: 261533
Changes:
 ximian-connector (1.5.91-1) experimental; urgency=low
 .
   * New upstream release (Closes: #261533).
Files:
 37ae36540b4cb9cbc6c19b21bb9d8175 728 gnome optional ximian-connector_1.5.91-1.dsc
 9ab0bdef5fa05d043de32893da93b60c 1263311 gnome optional ximian-connector_1.5.91.orig.tar.gz
 f44fe3c8843a4676ce6c1b64c180f774 1846 gnome optional ximian-connector_1.5.91-1.diff.gz
 f704a35f11fb1dd293c2e2da7e17134c 445646 gnome optional evolution-exchange_1.5.91-1_i386.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)

iD8DBQFBDuKJmHaJYZ7RAb8RAqE7AJ4+BIT+y/f7pVoncv9U/fm8qMhKIgCfX1XJ
rgal5oZ2zogq5uXzS8mM/Yc=
=ld0F
-----END PGP SIGNATURE-----

Matt Zimmerman (mdz) wrote :

Since this bug was apparently fixed in 1.5.91-1, and warty has 1.5.92-1ubuntu1,
I assume it is fixed in warty.

fixed-in-experimental for an experimental package -> closed

Debian Bug Importer (debzilla) wrote :

Message-Id: <1094300472.6106.0.camel@seb128>
Date: Sat, 04 Sep 2004 14:21:12 +0200
From: Sebastien Bacher <email address hidden>
To: <email address hidden>
Subject: Re: evolution-exchange: Newest version does not work

fixed-in-experimental for an experimental package -> closed

Changed in evolution-exchange:
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.