Evolution tasks are incompatible to Outlook tasks

Bug #69688 reported by Kuropka on 2006-11-01
2
Affects Status Importance Assigned to Milestone
Evolution
Fix Released
Medium
evolution-exchange (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

I am working with both Evolution and MS-Outlook (unfortunatelly I need to continue doing this until I can handle all MS-Documents without problems with Ubuntu). Therefore I noticed the following incompatiblity between tasks stored by Outlook in the exchange server and tasks stored by Evolution in the exchange server:

Outlook does not differentiate between tasks with "normal" and "(none)" priorty. Both concepts are handled as tasks with "normal" priority. Unfortunatelly Outlook stores tasks with "normal" priority without any priority label (as "(none)" priority task). This results in all these tasks without a priority label are shown in Evolution as "(none)" tasks. This is a minior bug but it is really nasty because it puzzles the ordering of tasks: high, normal, low, (none). Causing all "normal" tasks stored by Outlook to be shown in the last position in Evolution instead of in between of "high" and "low" (when ordering is activated).

In the opposite direction these problem seems not to occur.

Can anybody do me the favour and add somewhere in the many lines of Evolution-Code a proper line which makes Evolution handling tasks without a priority label as "normal" priorised tasks?

Thank you and best regards,
Dominik Kuropka

Changed in evolution:
importance: Undecided → Wishlist
Daniel Holbach (dholbach) wrote :

Thanks for your bug report.

Somebody of the team should forward this upstream.

Changed in evolution:
assignee: nobody → desktop-bugs
Sebastien Bacher (seb128) wrote :

I've forwarded that upstream: http://bugzilla.gnome.org/show_bug.cgi?id=404002

What version of Ubuntu do you use?

Changed in evolution:
status: Unconfirmed → Confirmed
importance: Wishlist → Low
Changed in evolution:
status: Unknown → Unconfirmed
Kuropka (d2) wrote :

I am using Ubuntu 6.10 - the Edgy Eft.

Kuropka (d2) wrote :

Unfortunatelly this is still an issue with Ubuntu 7.10 Gutsy Gibbon Beta :-(

Changed in evolution:
status: New → In Progress
Changed in evolution:
status: In Progress → Fix Released
Pedro Villavicencio (pedro) wrote :

This has been fixed upstream, thanks you.

Changed in evolution-exchange:
status: Confirmed → Fix Committed
Sebastien Bacher (seb128) wrote :

the bug is fixed in hardy

Changed in evolution-exchange:
status: Fix Committed → Fix Released
Changed in evolution:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.