segmentation fault in vfprintf / e_proxy_setup_proxy

Bug #662983 reported by Sam Post on 2010-10-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
evolution-exchange (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: evolution-exchange

I'm running Ubuntu 10.10 Desktop amd64 (uname -r = 2.6.35-22-generic), and have been following bugs #661094 and #631395 as my exchange email is currently broken.

In the process of experimenting with evolution settings, I tried changing my proxy settings to see if the proxy was at fault. Somehow this messed up my configuration so that evolution segfaults on startup, backtrace is below. I have tried removing all evolution packages (sudo apt-get remove --purge evolution evolution-common evolution-data-server evolution-couchdb evolution-exchange evoluton) and re-installing them, with no effect.

Can someone suggest a workaround / fix? I'm very anxious to try the workaround in #661094 (evolution-exchange 2.30.3-0ubuntu2~ppa1) but can't get past the segfault to see if this works.

Thanks

Sam

Sam Post (sampost) wrote :
Sam Post (sampost) wrote :

I am able to work around the crash by modifying the following settings with gconf-editor:
   /apps/evolution/shell/network_config/proxy_type = 1 (no proxy)
   /apps/evolution/shell/network_config/use_http_proxy = 0

This crash should probably still be investigated and fixed, as not every person will want to hunt through gconf looking for these settings.

Thanks!

Sam

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments