Slow startup - "Fetching summary information for new messages"

Bug #60901 reported by John Leach
This bug affects 7 people
Affects Status Importance Assigned to Milestone
evolution-exchange (Ubuntu)

Bug Description

In Edgy, Evolution takes a LONG time to startup with an Exchange account. We're talking 10 minutes or more. During this time Evolution is useless - I can't use my other IMAP account until the exchange startup is finished.

Watching network traffic during this time shows short bursts of up to 1MBytes/s (this is across a LAN) and long periods of no traffic.

The backtrace (below) seems to suggest Evolution is blocking waiting on our Exchange server, but we have 600 other users accessing it fine (mostly through Outlook, but I've tested webmail with no problems too).

I have a few public folders set as favourites, some of which have tens of thousands of messages in.

I have Evolution configured *not* to sync messages locally.

backtrace during the "Fetching.." stage:

(gdb) bt
#0 0xffffe410 in __kernel_vsyscall ()
#1 0xb6eec6d8 in recv () from /lib/tls/i686/cmov/
#2 0xb721bf1e in _gnutls_handshake_io_write_flush () from /usr/lib/
#3 0xb721c35b in _gnutls_io_read_buffered () from /usr/lib/
#4 0xb7218e8c in _gnutls_recv_int () from /usr/lib/
#5 0xb7219da6 in gnutls_record_recv () from /usr/lib/
#6 0xb728406f in soup_dns_init () from /usr/lib/
#7 0xb6e71543 in g_io_channel_read_chars () from /usr/lib/
#8 0xb7292589 in soup_socket_write () from /usr/lib/
#9 0xb729285e in soup_socket_read_until () from /usr/lib/
#10 0xb72887c4 in soup_message_io_stop () from /usr/lib/
#11 0xb7288a48 in soup_message_io_stop () from /usr/lib/
#12 0xb728762f in soup_message_send_request_internal () from /usr/lib/
#13 0xb727ff2e in soup_connection_new () from /usr/lib/
#14 0xb7281f56 in send_request () from /usr/lib/
#15 0xb727f077 in soup_connection_send_request () from /usr/lib/
#16 0xb728fb73 in soup_session_sync_new () from /usr/lib/
#17 0xb728d315 in soup_session_send_message () from /usr/lib/
#18 0xb72c05d4 in e2k_context_send_message () from /usr/lib/
#19 0xb72c0da1 in e2k_context_delete () from /usr/lib/
#20 0xb72cba02 in e2k_result_iter_free () from /usr/lib/
#21 0xb72cba9d in e2k_result_iter_next () from /usr/lib/
#22 0x0805d50f in mail_stub_exchange_new ()
#23 0x0805f7ab in mail_stub_exchange_new ()
#24 0x08063fc3 in mail_stub_get_type ()
#25 0xb6ea3d1d in g_io_channel_unix_get_fd () from /usr/lib/
#26 0xb6e7a872 in g_main_context_dispatch () from /usr/lib/
#27 0xb6e7d84f in g_main_context_check () from /usr/lib/
#28 0xb6e7dbf9 in g_main_loop_run () from /usr/lib/
#29 0xb714ea23 in bonobo_main () from /usr/lib/
#30 0x0805b9a3 in main ()

Revision history for this message
mvandeg (mvandegiessen) wrote :

I can confirm this bug. Although I do not use public folders, evolution still takes very long to start up. The odd thing is that first evolution checks for new messages. And even if I do not have new messages "Fetching summary information for new messages" takes a few minutes.

Revision history for this message
rfvuhbtg (rfvuhbtg) wrote :

Can anyone confirm whether this is an upstream bug in evolution or simply a bug in Ubuntu's evolution package? (i.e. would the same bug occur in evolution installed on another distro?)

Revision history for this message
gcstang (gcstang) wrote :

I can confirm it takes forever on Fedora 8 as well.

Revision history for this message
Matthew Tighe (tighem) wrote :

Slow for me too, Hardy Alpha 6 + updates (Mon Mar 17). Takes about two minutes before it opens up. No error messages. Even after it appears, it says "loading" for another 3 minutes or so. And then after it loads, it can still be a couple more minutes before you can select and see an e-mail.

Changed in evolution-exchange:
status: New → Confirmed
Matthew Tighe (tighem)
Changed in evolution-exchange:
assignee: nobody → desktop-bugs
Revision history for this message
Matthew Tighe (tighem) wrote :

This maybe related to the Global Catalog Name server setting. If it's available it's much faster.

Removing it also speeds things up...

Revision history for this message
Matthew Tighe (tighem) wrote :

Pretty much confirmed it is the Global Catalog Name Server setting for me. If it's available (via VPN), Evolution is down right speedy. If it is not, it takes forever to load.

This should time out much faster, or better yet, only try to contact it when doing things in the Global Address book (there's no reason to try and ping before that).

Revision history for this message
MSGHALEB (mohamed-ghaleb) wrote :

Me too, it takes very very long time to start, I can see it's starting and then everything disappear, in the begining I though it wont start, after few times I observed it takes 5 to 10 mins to start and show the interface.

Revision history for this message
drieteenmeeuw (drieteenmeeuw) wrote :

My evolution wouldn't start up either today (after booting up my pc), staying busy = being unresponsive for a long time without using much cpu or memory. Even killall evolution and starting evolution didn't work. I did ps aux | grep evolution and killed all additional processes which had to do with evolution (I had thought killall would do that). Then evolution started without a problem.

Changed in evolution-exchange:
assignee: desktop-bugs → nobody
importance: Undecided → Low
Revision history for this message
Rune Philosof (olberd) wrote :

I'm using Ubuntu 9.04.
Very anoying bug, this one.
Takes many minuttes until the GUI shows up.
Until then it's not obvious that I actually tried to start the program.
Which often causes me to start evolution twice.

Revision history for this message
zepita (zepita) wrote :

Same here, running ubuntu 9.10. Evolution takes too long to start.

Revision history for this message
Robert Petry (robert-hro) wrote :

This works worked for me on: Samsung Netbook N150 with Lucix-lynx 2.6.32-33

I actually found a solution while checking how to delete mails from my trash-folder that wouldn't delete no matter how often I told evolution to do it.

So here's how it goes.

1. Run a back-up.
2. Go to your home folder.
3. Check the "show hidden files" in the view menu to see all the files.
4. Navigate to ".evolution/mail/local" folder.
5. Select and DELETE all files EXCEPT ending in ".data" AND EXCEPT all files without file-extensions.

First start-up will take a while, because evolution will index your files, but next start-up will be in a flash :D

I hope this will work out for you, too.

Revision history for this message
Robert Petry (robert-hro) wrote :

Oupsie and I've only got pop3 folders.!

Revision history for this message
Jacques Malaprade (malapradej) wrote :

Thanks. This worked for me too in Ubuntu 12.04 except the folder is in ~/.local/share/evolution/mail/local.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.