evolution can't find subfolders in exchange other user mailbox

Bug #385973 reported by Federico on 2009-06-11
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
evolution-exchange
Won't Fix
Medium
evolution-exchange (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: evolution-exchange

First, the info of the packages:
evolution 2.26.1-0ubuntu2
evolution-exchange 2.60.0-0ubuntu3
evolution-data-server 2.60.0-0ubuntu3

I'm using Ubuntu 9.04 and my exchange (version 2003) is in a Windows Server 2003

Well, with my personal account I can view all subfolders. But when subscribe my account to other user mailbox, I can view only the inbox, but not the subfolders. The second account has the correct permissions (in fact, I tried giving me owner permissions). I tried in windows and can view all the subfolders of the second account in MS Outlook.

When I run the evolution whit debugging mode whit env E2K_DEBUG=5 evolution >& evo.log
I found the next info when evolution starts to update the folders:

(evolution:7908): camel-exchange-provider-WARNING **: Unable to load Exchage summary for folder personal: no such table: personal

** (evolution:7908): DEBUG: EI: mail_read_notify
** (evolution:7908): DEBUG: MAIL SERVER: Count changed: 0

(evolution:7908): camel-exchange-provider-WARNING **: Unable to load Exchage summary for folder personal/Bandeja de entrada/fedeede: no such table: personal/Bandeja de entrada/fedeede

(evolution:7908): camel-exchange-provider-WARNING **: Unable to load Exchage summary for folder personal/Bandeja de entrada/prueba: no such table: personal/Bandeja de entrada/prueba

(evolution:7908): camel-exchange-provider-WARNING **: Unable to load Exchage summary for folder personal/Bandeja de salida: no such table: personal/Bandeja de salida

(evolution:7908): camel-exchange-provider-WARNING **: Unable to load Exchage summary for folder personal/Borradores: no such table: personal/Borradores

(evolution:7908): camel-exchange-provider-WARNING **: Unable to load Exchage summary for folder personal/Diario: no such table: personal/Diario

(evolution:7908): camel-exchange-provider-WARNING **: Unable to load Exchage summary for folder personal/Fuentes RSS: no such table: personal/Fuentes RSS

(evolution:7908): camel-exchange-provider-WARNING **: Unable to load Exchage summary for folder personal/Notas: no such table: personal/Notas

(evolution:7908): camel-exchange-provider-WARNING **: Unable to load Exchage summary for folder personal/Problemas de sincronización: no such table: personal/Problemas de sincronización

(evolution:7908): camel-exchange-provider-WARNING **: Unable to load Exchage summary for folder personal/Problemas de sincronización/Conflictos: no such table: personal/Problemas de sincronización/Conflictos

(evolution:7908): camel-exchange-provider-WARNING **: Unable to load Exchage summary for folder personal/Problemas de sincronización/Errores del servidor: no such table: personal/Problemas de sincronización/Errores del servidor

(evolution:7908): camel-exchange-provider-WARNING **: Unable to load Exchage summary for folder personal/Problemas de sincronización/Errores locales: no such table: personal/Problemas de sincronización/Errores locales

(evolution:7908): camel-exchange-provider-WARNING **: Unable to load Exchage summary for folder <email address hidden>: no such table: <email address hidden>

_____________________________________________

All the subfolders with personal/* are really empty but the last warning, but not the address of the second user mailbox.

Another thing I tried is create a new folder from evolution in the inbox of the second user, but I get a generic error. In the debug log I get this line:

DEBUG: <email address hidden>/Bandeja de entrada/testfolder (exchange://MYUSER;<email address hidden><email address hidden>/Bandeja%20de%20entrada/testfolder)

Possibly all the matter is a bug of evolution-exchange but I'm not sure. If anyone know something please take a look at this

Pedro Villavicencio (pedro) wrote :

Thanks for your report, that's something to send directly upstream at http://bugzilla.gnome.org by someone having the issue most of the triagers and developers doesn't have access to an exchange server to test with, for forwarding instructions please read http://wiki.ubuntu.com/Bugs/Upstream/GNOME, Thanks in advance.

Changed in evolution-exchange (Ubuntu):
importance: Undecided → Low
Federico (elfede521) wrote :

Thanks for the advice. I'm doing what you tell me

Pedro Villavicencio (pedro) wrote :

awesome, please let us know the bug number of the upstream report after you open it there so we can track it here with the report you filed.

Federico (elfede521) wrote :

Pedro, the number of the ticket of upstream is 585448.

Greetings

Pedro Villavicencio (pedro) wrote :

Awesome, thanks for the pointer, linking the report.

Changed in evolution-exchange (Ubuntu):
status: New → Triaged
Changed in evolution-exchange:
status: Unknown → New
yolen (plasmajens) wrote :

using ubuntu 9.10. linking to an exchange server. Cannot see "inbox" subfolders but is able to see "personal folder" subfolders

Jan Roubos (jan-roubos) wrote :

Using ubuntu 9.10, evolution 2.28.1, connecting to an Exchange server. The personal/private folders works fine, but indeed the subfolders of an other user (in out case a shared mailbox) are not shown. I'm also the owner of the subfolders in the shared mailbox, and the subfolders are shown te me in Outlook. But unfortunately not in Evolution.

At this moment is this a little show-stopper for are Windows XP -> Ubuntu desktop migration, while we need to access the subfolders of a shared mailbox. I hope there will be a fix soon.

Changed in evolution-exchange:
importance: Unknown → Medium
Changed in evolution-exchange:
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.