evolution-exchange-storage: /build/buildd/libical-0.43/src/libical/icalerror.c:106: icalerror_set_errno: Assertion `0' failed.

Bug #353187 reported by Mark Beierl on 2009-04-01
38
This bug affects 2 people
Affects Status Importance Assigned to Milestone
evolution-exchange
Fix Released
High
evolution-exchange (Ubuntu)
Medium
Ubuntu Desktop Bugs
Jaunty
Medium
Unassigned

Bug Description

Binary package hint: evolution

Simply upon loading OWA calendars, the exchange-storage process crashes. This can be reproduced very easily.

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: evolution 2.26.0-0ubuntu2
ProcEnviron:
 PATH=(custom, user)
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
SourcePackage: evolution
Uname: Linux 2.6.28-11-generic x86_64

Mark Beierl (mbeierl) wrote :
Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, your crash report is either missing or challenging to deal with as a ".crash" file. Please follow these instructions to have apport report a new bug about your crash that can be dealt with by the automatic retracer.

If you are running the Ubuntu Stable Release you might need to enable apport in /etc/default/apport and restart.

If you are using Ubuntu with the Gnome desktop environment - launch nautilus and navigate to your /var/crash directory and double click on the crash report you wish to submit.

If you are using Kubuntu or Xubuntu you can file the crash using /usr/share/apport/apport-qt --crash-file=/var/crash/_my_crash_report.crash in a terminal - where _my_crash_report.crash is the crash you would like to report.

I'm closing this bug report since the process outlined above will automatically open a new bug report which can then dealt with more efficiently. Thanks in advance for your cooperation and understanding.

Changed in evolution (Ubuntu):
status: New → Invalid
Mark Beierl (mbeierl) wrote :

Unfortunately, despite having set ulimit -c unlimited and running the program from the cli and seeing "core dumped", I cannot find the crash or core file anywhere. Any help on how to find it would be appreciated.

It is not in /var/crash nor in the current working directory.

Mark Beierl (mbeierl) wrote :

Please help in creating the crash file as it is not appearing in /var/crash nor in cwd when ulimit -c unlimited is set.

Changed in evolution:
assignee: nobody → pvillavi
status: Invalid → Incomplete
Pedro Villavicencio (pedro) wrote :

Then please try to obtain a backtrace of the crash http://wiki.ubuntu.com/DebuggingProgramCrash and attach the file to the bug report. This will greatly help us in tracking down your problem.

Changed in evolution (Ubuntu):
assignee: pvillavi → desktop-bugs
importance: Undecided → Medium
Kib Reed (kib) wrote :

I am having the same issue. Here is the bug I submitted on bugzilla as I have been trying to work on this issue: http://bugzilla.gnome.org/show_bug.cgi?id=577361

I may be wrong as I don't know a lot about coding in c, but it appears it may be a timezone issue in the calendar entry.

I can provide more as I am able to run this with debug symbols. I have also confirmed this issue exists in Evolution 2.26.1 compiled from SVN trunk as of tonight as I have been debugging this issue.

affects: evolution (Ubuntu) → evolution-exchange (Ubuntu)
Changed in evolution-exchange (Ubuntu):
status: Incomplete → Triaged
Changed in evolution-exchange:
status: Unknown → Invalid
Kib Reed (kib) wrote :

Here is a backtrace from today with debug symbols.

C de-Avillez (hggdh2) wrote :

Updated upstream link to reflect the original bug was set as a duplicate.

Changed in evolution-exchange:
status: Invalid → Unknown
Changed in evolution-exchange:
status: Unknown → New
C de-Avillez (hggdh2) wrote :

BTW -- apport does not process SIGABRT signals...

Kib Reed (kib) wrote :

The issue appears to be fixed upstream now. Per bug 577105 (http://bugzilla.gnome.org/show_bug.cgi?id=577105), there was a patch committed that I added to evolution-exchange source from Jaunty and now I am able to work in Evolution again.

For those that are unfamiliar and want to test it, you can do:
1. mkdir evolution; cd evolution
2. sudo apt-get build-dep evolution-exchange
3. wget http://bugzilla.gnome.org/attachment.cgi?id=133182&action=view
4. sudo apt-get source evolution-exchange
5. cd evolution-exchange
6. patch -p0 < ../eex.patch
7. sudo dpkg-buildpackage
8. sudo dpkg -i ../evolution-exchange_2.26.0-0ubuntu2_amd64.deb
9. evolution --force-shutdown

Then restart evolution and it should be stable.

Can this patch be added to evolution-exchange in Ubuntu Jaunty at some point in the near future?

C de-Avillez (hggdh2) wrote :

Created a debdiff for the patch (targeting e-e-0ubuntu3); will SRU. Thank you, Kib, for your help!

Impact on Users: this bug makes the personal exchange calendar unavailable for those affected. It is unclear how to reproduce it (i.e., to have some of the affected fields set to NULL).

Fix: this is an upstream fix, already commited to 2.26 stable and trunk. Kib has tested it, and it seems to work.

Patch: Please see attached debdiff targeting jaunty-proposed, evolution-exchange-0ubuntu3.

Test Case: unavailable, since it depends on having some of the internal ical pointers set to NULL; it is unknown how this happens.

Regression potential: This bug is new on e-e-2.26; only evolution-exchange users will be affected; usptream could not reproduce the issue, and suffered no visible regression when testing; Kib did have the issue, and the patch resolved it.

Sebastien Bacher (seb128) wrote :

thank you for your work there

Changed in evolution-exchange (Ubuntu Jaunty):
importance: Undecided → Medium
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Accepted evolution-exchange into jaunty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Kib Reed (kib) wrote :

I have installed the update and it appears to be working properly (ie, not locking up or crashing). Thanks for getting this in so quickly!

$ dpkg --status evolution-exchange
Package: evolution-exchange
Status: install ok installed
Priority: optional
Section: gnome
Installed-Size: 3512
Maintainer: Ubuntu Core Developers <email address hidden>
Architecture: amd64
Version: 2.26.0-0ubuntu3

Martin Pitt (pitti) on 2009-04-28
tags: added: verification-done
removed: verification-needed
Anton Keks (anton-azib) wrote :

I confirm that yesterday's update fixes the problem for me as well.

Johan Wiezell (johan-wiezell) wrote :

The patch seems to fix my problem as well (as reported in bug #367890).

The patch worked for me as well

On 4/29/09, Johan Wiezell <email address hidden> wrote:
> The patch seems to fix my problem as well (as reported in bug #367890).
>
> --
> evolution-exchange-storage:
> /build/buildd/libical-0.43/src/libical/icalerror.c:106: icalerror_set_errno:
> Assertion `0' failed.
> https://bugs.launchpad.net/bugs/353187
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in Evolution Exchange - Exchange Plugin for Exchange: New
> Status in “evolution-exchange” source package in Ubuntu: Triaged
> Status in evolution-exchange in Ubuntu Jaunty: Fix Committed
>
> Bug description:
> Binary package hint: evolution
>
> Simply upon loading OWA calendars, the exchange-storage process crashes.
> This can be reproduced very easily.
>
> ProblemType: Bug
> Architecture: amd64
> DistroRelease: Ubuntu 9.04
> NonfreeKernelModules: nvidia
> Package: evolution 2.26.0-0ubuntu2
> ProcEnviron:
> PATH=(custom, user)
> LANG=en_CA.UTF-8
> SHELL=/bin/bash
> SourcePackage: evolution
> Uname: Linux 2.6.28-11-generic x86_64
>

--
_____________________________________________________________
Jon Zakaras
<email address hidden> | c: (949)614-9544 | o: (623)399-4975 | f: (623)321-6344

Bruce Weyrauch (bweyrauch) wrote :

I applied the evolution-exchange patch from jaunty -proposed, and it solved my issue. (as described in bug #366471) Exchange personal calendar working correctly now.

Zaris (zaris) wrote :

Same here. Installed proposed, no improvements.

C de-Avillez (hggdh2) wrote :

@Jari: sorry, did it work or not?

Zaris (zaris) wrote :

Sorry, my post went to wrong thread. Last week Jaunty-proposed did not help me, but now this latest update did. Now I can use exchange calendar.

$ dpkg --status evolution-exchange
Package: evolution-exchange
Status: install ok installed
Priority: optional
Section: gnome
Installed-Size: 3460
Maintainer: Ubuntu Core Developers <email address hidden>
Architecture: i386
Version: 2.26.0-0ubuntu3
Replaces: ximian-connector
Provides: ximian-connector

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evolution-exchange - 2.26.0-0ubuntu3

---------------
evolution-exchange (2.26.0-0ubuntu3) jaunty-proposed; urgency=low

  * debian/patches/20_fix-crash-on-personal-calendar.patch:
     - fixes a crash when enabling the personal calendar (LP: #353187)

 -- C de-Avillez <email address hidden> Mon, 27 Apr 2009 12:12:17 -0600

Changed in evolution-exchange (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

copied to karmic

Changed in evolution-exchange (Ubuntu):
status: Triaged → Fix Released
Changed in evolution-exchange:
status: New → Fix Released
Changed in evolution-exchange:
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.