evolution fails to Authenticate in Microsoft Exchange Assistant dialog

Bug #292651 reported by Gábor Lipták on 2008-11-02
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
evolution-exchange
Won't Fix
High
evolution-exchange (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: evolution

I'm using the Account Assistant dialog to setup a Microsoft Exchange account.

Using:

Username: Domain\Domainuser
OWA URL: http://owa.company.com/exchange
Mailbox: <email address hidden> (which is the same as the email I set for the account, except capitalization, I tried with and without filling out this field)

Getting message, "Could not connect to server. Make sure the URL is correct and try again"

Here is the console debug message (starting as E2K_DEBUG=5 evolution):

e-data-server-ui-Message: Unable to find password(s) in keyring (Keyring reports: No matching results)
e-data-server-ui-Message: Key file does not have group 'Passwords-Exchange'
> GET /exchange HTTP/1.1
> Soup-Debug-Timestamp: 1225638406
> Soup-Debug: SoupSessionSync 1 (0xad14360), SoupMessage 1 (0xb0d95670), SoupSocket 1 (0xa1abb48)
> Host: owa.company.com
> Accept-Language: en-US, en
> Authorization: NTLM TlRMYYYYTUAABAAZZZZZZZZZZZZZZZZZZZA
> User-Agent: Evolution/2.24.1

There are some similar bugs reported, but in those cases the users were able to authenticate, then manually change configuration as a workaround.

Thanks

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 8.10
Package: evolution 2.24.1-0ubuntu2
ProcEnviron:
 PATH=/home/username/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/home/username/apache-maven-2.0.8/bin
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: evolution
Uname: Linux 2.6.27-7-generic i686

Gábor Lipták (gliptak) wrote :
Sebastien Bacher (seb128) wrote :

thank you for your bug report, you should open the bug on bugzilla.gnome.org where the people writting the code will read it though, there is no ubuntu bug triager having access to an exchange server so the bug is not likely to be worked there

Changed in evolution:
importance: Undecided → Low
Pedro Villavicencio (pedro) wrote :

Any news about this? did you sent the bug to Gnome? could yo utell us the bug number there?

Gábor Lipták (gliptak) wrote :
Pedro Villavicencio (pedro) wrote :

Thanks for sent it upstream.

Changed in evolution-exchange (Ubuntu):
status: New → Triaged
Changed in evolution-exchange:
status: Unknown → New
Christopher Covington (cov) wrote :

This bug is still present for me in 9.04. I think that bug #334890 is a duplicate of this bug.

Christopher Covington (cov) wrote :

On reading the upstream bug report, it seems to describe the issue differently than in this bug and what I am experiencing. (Could not configure Exchange account because an unknown error occurred. Check the URL, username, and password, and try again.)

I'm wondering if the real cause is actually NTLMv2 being unsupported by Evolution. This is http://bugzilla.gnome.org/show_bug.cgi?id=323619. In my case, this is likely.

Changed in evolution-exchange:
status: New → Invalid
Changed in evolution-exchange:
status: Invalid → New
Changed in evolution-exchange:
importance: Unknown → High
Changed in evolution-exchange:
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.