Evolution forgets Exchange account password and folder settings often

Bug #26097 reported by Vermyndax on 2005-11-23
8
Affects Status Importance Assigned to Milestone
evolution-exchange
Fix Released
Medium
evolution-exchange (Ubuntu)
Medium
Sebastien Bacher

Bug Description

Quite often while using Evolution in Breezy, Evolution will suddenly stop
connecting to my Contacts/Calendar/Tasks folders on the Exchange server. You
can tell when it's happening when you go there and Evolution unchecks the box to
set these folders to display, even though the local ones still work.

What's happening there is that Evolution has forgotten my Exchange password, but
yet still uses it for checking mail (because mail still works). To fix this, I
have to go into account properties, receiving mail... then click
"Authentication"... at this point I receive an error that my password is wrong.
 I have to click OK and then click "Authentication" again and put in my
password... then restart Evolution. It will then work again for a little while
until it decides to forget it again, usually later in the day.

The other problem that occurs about the same frequency is that Evolution forgets
which folders I have set for my Sent Items and Drafts folders. Evolution will
just suddenly start redirecting everything to my Inbox when I send an email or
whatnot. I have to visit the account properties to reset this... probably at
least three times a week.

http://bugzilla.gnome.org/show_bug.cgi?id=323123: http://bugzilla.gnome.org/show_bug.cgi?id=323123

Sebastien Bacher (seb128) wrote :

Thanks for your bug. Is that specific to exchange setup? Are doing changes to
your gconf configuration? Do you have some issues with others applications using
gconf?

Vermyndax (vermyndax) wrote :

I have one IMAP account and one Exchange account set up in Evolution. This only happens on the Exchange account.

I have not noticed any other problems related to gconf, no... but it could be that I'm just not aware of it. If the
system forgetting passwords is considered one such problem, that does not happen in other applications.

Sebastien Bacher (seb128) wrote :

I've forwarded your bug upstream: http://bugzilla.gnome.org/show_bug.cgi?id=323123

Sebastien Bacher (seb128) wrote :

Upstream comment:

"Sebastien: This bug "Evolution forgets
which folders I have set for my Sent Items and Drafts folders. Evolution will
just suddenly start redirecting everything to my Inbox when I send an email or
whatnot. I have to visit the account properties to reset this... probably at
least three times a week.' must have been addressed in separate bug. At present
there is already a bug entry for this issue.

Regarding password issue, in exchange 2.5.4 some password issues has been
fixed, reporter of the bug can use that. If the bug is still reproducible in
2.5.4 reopen this bug."

Please let we know if you try with 2.5.4

Vermyndax (vermyndax) wrote :

Sorry for taking so long to respond further on this. I'll need to compile 2.5.4 from source to look into it further as they requested but I'm sure you knew that ;)

Sebastien Bacher (seb128) wrote :

No need to bother rebuilding the new stack on 5.10. You can wait to update to dapper and comment on the bug then

Carthik Sharma (carthik) wrote :

Changing to needs info since Sebastien Bacher has asked reporter to try a newer version and report back.

Thanks!

Changed in evolution-exchange:
status: Unconfirmed → Needs Info
Carthik Sharma (carthik) wrote :

Closing this as the upstream bug has been resolved. If you still have the issue when using the 2.6.x version, please reopen this bug.

Thank you for reporting this bug.

Changed in evolution-exchange:
status: Needs Info → Fix Released
Changed in evolution-exchange:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.