evolution-exchange: unable to setup exchange account: e2k_properties_get_prop: assertion `props != NULL' failed

Bug #25106 reported by Debian Bug Importer on 2005-11-07
60
This bug affects 1 person
Affects Status Importance Assigned to Milestone
evolution-exchange
Expired
Medium
evolution-exchange (Debian)
Fix Released
Unknown
evolution-exchange (Ubuntu)
High
Ubuntu Desktop Bugs

Bug Description

Automatically imported from Debian bug report #337957 http://bugs.debian.org/337957

Debian Bug Importer (debzilla) wrote :

Automatically imported from Debian bug report #337957 http://bugs.debian.org/337957

Debian Bug Importer (debzilla) wrote :
Download full text (4.9 KiB)

Message-Id: <email address hidden>
Date: Mon, 07 Nov 2005 16:31:52 +0100
From: Bartlomiej Ochman <email address hidden>
To: Debian Bug Tracking System <email address hidden>
Subject: evolution-exchange: unable to setup exchange account

Package: evolution-exchange
Version: 2.2.3-3
Severity: grave
Justification: renders package unusable

-- System Information:
Debian Release: testing/unstable
  APT prefers testing
  APT policy: (800, 'testing'), (60, 'unstable')
Architecture: i386 (i686)
Shell: /bin/sh linked to /bin/bash
Kernel: Linux 2.6.14-p2-mppe
Locale: LANG=C, LC_CTYPE=pl_PL (charmap=ISO-8859-2)

When trying to setup new exchange account with ximian-connector-setup-2.2,
get an error message: Could not configure Exchange account because
an unknown error ocured.

And on stderr:
** (ximian-connector-setup-2.2:3187): CRITICAL **: e2k_properties_get_prop: assertion `props != NULL' failed

It's also impossible to setup an account with exchange setup plugin,
it quits with the same error message as above.
On stderr:
** (evolution:3256): CRITICAL **: e2k_properties_get_prop: assertion `props != NULL' failed

Versions of packages evolution-exchange depends on:
ii evolution 2.2.3-4 The groupware suite
ii libart-2.0-2 2.3.17-1 Library of functions for 2D graphi
ii libatk1.0-0 1.10.3-1 The ATK accessibility toolkit
ii libaudiofile0 0.2.6-6 Open-source version of SGI's audio
ii libbonobo2-0 2.10.1-1 Bonobo CORBA interfaces library
ii libbonoboui2-0 2.10.1-1 The Bonobo UI library
ii libc6 2.3.5-7 GNU C Library: Shared libraries an
ii libcamel1.2-0 1.2.3-2 The Evolution MIME message handlin
ii libcomerr2 1.38-2 common error description library
ii libdb4.1 4.1.25-18 Berkeley v4.1 Database Libraries [
ii libebook1.2-3 1.2.3-2 Client library for evolution addre
ii libecal1.2-2 1.2.3-8 Client library for evolution calen
ii libedata-book1.2-2 1.2.3-2 Backend library for evolution addr
ii libedata-cal1.2-1 1.2.3-2 Backend library for evolution cale
ii libedataserver1.2-4 1.2.3-8 Utily library for evolution data s
ii libedataserverui1.2-4 1.2.3-2 GUI utily library for evolution da
ii libesd0 0.2.36-1 Enlightened Sound Daemon - Shared
ii libfontconfig1 2.3.2-1 generic font configuration library
ii libfreetype6 2.1.10-1 FreeType 2 font engine, shared lib
ii libgal2.4-0 2.4.3-1.1 G App Libs (run time library)
ii libgconf2-4 2.10.1-6 GNOME configuration database syste
ii libgcrypt11 1.2.2-1 LGPL Crypto library - runtime libr
ii libglade2-0 1:2.5.1-2 library to load .glade files at ru
ii libglib2.0-0 2.8.3-1 The GLib library of C routines
ii libgnome-keyring0 0.4.5-1 GNOME keyring services library
ii libgnome2-0 2.10.1-1 The G...

Read more...

Download full text (5.3 KiB)

Bartlomiej Ochman [<email address hidden>] wrote:
> Package: evolution-exchange
> Version: 2.2.3-3
> Severity: grave
> Justification: renders package unusable
>
>
>
> -- System Information:
> Debian Release: testing/unstable
> APT prefers testing
> APT policy: (800, 'testing'), (60, 'unstable')
> Architecture: i386 (i686)
> Shell: /bin/sh linked to /bin/bash
> Kernel: Linux 2.6.14-p2-mppe
> Locale: LANG=C, LC_CTYPE=pl_PL (charmap=ISO-8859-2)
>
> When trying to setup new exchange account with ximian-connector-setup-2.2,
> get an error message: Could not configure Exchange account because
> an unknown error ocured.
>
> And on stderr:
> ** (ximian-connector-setup-2.2:3187): CRITICAL **: e2k_properties_get_prop: assertion `props != NULL' failed
>
> It's also impossible to setup an account with exchange setup plugin,
> it quits with the same error message as above.
> On stderr:
> ** (evolution:3256): CRITICAL **: e2k_properties_get_prop: assertion `props != NULL' failed
>
> Versions of packages evolution-exchange depends on:
> ii evolution 2.2.3-4 The groupware suite
> ii libart-2.0-2 2.3.17-1 Library of functions for 2D graphi
> ii libatk1.0-0 1.10.3-1 The ATK accessibility toolkit
> ii libaudiofile0 0.2.6-6 Open-source version of SGI's audio
> ii libbonobo2-0 2.10.1-1 Bonobo CORBA interfaces library
> ii libbonoboui2-0 2.10.1-1 The Bonobo UI library
> ii libc6 2.3.5-7 GNU C Library: Shared libraries an
> ii libcamel1.2-0 1.2.3-2 The Evolution MIME message handlin
> ii libcomerr2 1.38-2 common error description library
> ii libdb4.1 4.1.25-18 Berkeley v4.1 Database Libraries [
> ii libebook1.2-3 1.2.3-2 Client library for evolution addre
> ii libecal1.2-2 1.2.3-8 Client library for evolution calen
> ii libedata-book1.2-2 1.2.3-2 Backend library for evolution addr
> ii libedata-cal1.2-1 1.2.3-2 Backend library for evolution cale
> ii libedataserver1.2-4 1.2.3-8 Utily library for evolution data s
> ii libedataserverui1.2-4 1.2.3-2 GUI utily library for evolution da
> ii libesd0 0.2.36-1 Enlightened Sound Daemon - Shared
> ii libfontconfig1 2.3.2-1 generic font configuration library
> ii libfreetype6 2.1.10-1 FreeType 2 font engine, shared lib
> ii libgal2.4-0 2.4.3-1.1 G App Libs (run time library)
> ii libgconf2-4 2.10.1-6 GNOME configuration database syste
> ii libgcrypt11 1.2.2-1 LGPL Crypto library - runtime libr
> ii libglade2-0 1:2.5.1-2 library to load .glade files at ru
> ii libglib2.0-0 2.8.3-1 The GLib library of C routines
> ii libgnome-keyring0 0.4.5-1 GNOME keyring services library
> ii libgnome2-0 2.10.1-1 The GNOME 2 library - runtime file
> ii libgnomecanvas2-0 2.10.2-2 A powerful object-oriente...

Read more...

Download full text (6.3 KiB)

Message-ID: <email address hidden>
Date: Mon, 7 Nov 2005 14:03:01 -0800
From: Lawrence Walton <email address hidden>
To: Bartlomiej Ochman <email address hidden>, <email address hidden>
Cc: Debian Bug Tracking System <email address hidden>
Subject: Re: Bug#337957: evolution-exchange: unable to setup exchange account

--r5Pyd7+fXNt84Ff3
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

Bartlomiej Ochman [<email address hidden>] wrote:
> Package: evolution-exchange
> Version: 2.2.3-3
> Severity: grave
> Justification: renders package unusable
>=20
>=20
>=20
> -- System Information:
> Debian Release: testing/unstable
> APT prefers testing
> APT policy: (800, 'testing'), (60, 'unstable')
> Architecture: i386 (i686)
> Shell: /bin/sh linked to /bin/bash
> Kernel: Linux 2.6.14-p2-mppe
> Locale: LANG=3DC, LC_CTYPE=3Dpl_PL (charmap=3DISO-8859-2)
>=20
> When trying to setup new exchange account with ximian-connector-setup-2.2,
> get an error message: Could not configure Exchange account because=20
> an unknown error ocured.
>=20
> And on stderr:
> ** (ximian-connector-setup-2.2:3187): CRITICAL **: e2k_properties_get_pro=
p: assertion `props !=3D NULL' failed
>=20
> It's also impossible to setup an account with exchange setup plugin,
> it quits with the same error message as above.
> On stderr:
> ** (evolution:3256): CRITICAL **: e2k_properties_get_prop: assertion `pro=
ps !=3D NULL' failed
>=20
> Versions of packages evolution-exchange depends on:
> ii evolution 2.2.3-4 The groupware suite
> ii libart-2.0-2 2.3.17-1 Library of functions for 2D =
graphi
> ii libatk1.0-0 1.10.3-1 The ATK accessibility toolkit
> ii libaudiofile0 0.2.6-6 Open-source version of SGI's=
 audio
> ii libbonobo2-0 2.10.1-1 Bonobo CORBA interfaces libr=
ary
> ii libbonoboui2-0 2.10.1-1 The Bonobo UI library
> ii libc6 2.3.5-7 GNU C Library: Shared librar=
ies an
> ii libcamel1.2-0 1.2.3-2 The Evolution MIME message h=
andlin
> ii libcomerr2 1.38-2 common error description lib=
rary
> ii libdb4.1 4.1.25-18 Berkeley v4.1 Database Libra=
ries [
> ii libebook1.2-3 1.2.3-2 Client library for evolution=
 addre
> ii libecal1.2-2 1.2.3-8 Client library for evolution=
 calen
> ii libedata-book1.2-2 1.2.3-2 Backend library for evolutio=
n addr
> ii libedata-cal1.2-1 1.2.3-2 Backend library for evolutio=
n cale
> ii libedataserver1.2-4 1.2.3-8 Utily library for evolution =
data s
> ii libedataserverui1.2-4 1.2.3-2 GUI utily library for evolut=
ion da
> ii libesd0 0.2.36-1 Enlightened Sound Daemon - S=
hared=20
> ii libfontconfig1 2.3.2-1 generic font configuration l=
ibrary
> ii libfreetype6 2.1.10-1 FreeType 2 font engine, shar=
ed lib
> ii libgal2.4-0 2.4.3-1.1 G App Libs (run time library)
> ii...

Read more...

Bart?omiej Ochman [<email address hidden>] wrote:
> On Mon, Nov 07, 2005 at 02:03:01PM -0800, Lawrence Walton wrote:
> >
> > I've seen this bug a couple times and have not been able to reproduce it.
> > Is this a new evolution install? Can you try it with a brand new test users?
> Yes, and yes. It happens both with brand new test users and with users who
> did not use evolution before.
>
> I was also able to reproduce it with working evolution, just
> rm -rf ~/.evolution and evolution subtree in ~/.gconf. After this
> evolution-exchange is not usable anymore.
>
> > further than a particular point?
> With exchange account setup plugin it doesn't pass "Authenticate",
> with ximian-... it can't pass "Forward" after filling all the fields:
> OWA URL, Username and Password.
>
> Unfortunately, it's not easy to debug response from Exchange, because
> I can connect to it only using https: (and yes, there is some packet
> exchange between connector and the server).

Cool!
This gets us a little further. :)
I've see examples where the OWL is not correct. unfortunately the standards
for the naming convention can range wildly.

I'd love to see if you can try this, in a browser.

http://exchangeServer.domain.com/exchange/yourUserName/

and

https://exchangeServer.domain.com/exchange/yourUserName/

It should prompt you for a username and password.
And if successful, you should be presented with the webmail interface.

If not then usually it's because your login name and actual account name are different,
odd I know. As a example my URL ends with lawrence but my login is lawrencew.

I just want to make sure the it's not a syntactical error with the OWL first.

Cheers!

--
*--* Mail: <email address hidden>
*--* Voice: 425.739.4247
*--* Fax: 425.827.9577
*--* HTTP://the-penguin.otak.com/~lawrence
--------------------------------------
- - - - - - O t a k i n c . - - - - -

Message-ID: <email address hidden>
Date: Tue, 8 Nov 2005 09:58:22 -0800
From: Lawrence Walton <email address hidden>
To: Bart?omiej Ochman <email address hidden>
Cc: <email address hidden>
Subject: Re: Bug#337957: evolution-exchange: unable to setup exchange account

--FCuugMFkClbJLl1L
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

Bart?omiej Ochman [<email address hidden>] wrote:
> On Mon, Nov 07, 2005 at 02:03:01PM -0800, Lawrence Walton wrote:
> >=20
> > I've seen this bug a couple times and have not been able to reproduce i=
t.
> > Is this a new evolution install? Can you try it with a brand new test u=
sers?
> Yes, and yes. It happens both with brand new test users and with users who
> did not use evolution before.
>=20
> I was also able to reproduce it with working evolution, just
> rm -rf ~/.evolution and evolution subtree in ~/.gconf. After this=20
> evolution-exchange is not usable anymore.
>=20
> > further than a particular point?
> With exchange account setup plugin it doesn't pass "Authenticate",
> with ximian-... it can't pass "Forward" after filling all the fields:
> OWA URL, Username and Password.
>=20
> Unfortunately, it's not easy to debug response from Exchange, because
> I can connect to it only using https: (and yes, there is some packet
> exchange between connector and the server).

Cool!
This gets us a little further. :)
I've see examples where the OWL is not correct. unfortunately the standards=
=20
for the naming convention can range wildly.

I'd love to see if you can try this, in a browser.

http://exchangeServer.domain.com/exchange/yourUserName/

and=20

https://exchangeServer.domain.com/exchange/yourUserName/

It should prompt you for a username and password.
And if successful, you should be presented with the webmail interface.

If not then usually it's because your login name and actual account name ar=
e different,
odd I know. As a example my URL ends with lawrence but my login is lawrence=
w.

I just want to make sure the it's not a syntactical error with the OWL firs=
t.

Cheers!

--=20
*--* Mail: <email address hidden>
*--* Voice: 425.739.4247
*--* Fax: 425.827.9577
*--* HTTP://the-penguin.otak.com/~lawrence
--------------------------------------
- - - - - - O t a k i n c . - - - - -=20

--FCuugMFkClbJLl1L
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)

iD8DBQFDcOc+sgPkFxgrWYkRAiHOAJ40VOZoJJNJREEpVw5vxqH/QhG1TACdErVs
SgE9Lw/TTClgNzd8+AOci8Q=
=ptkY
-----END PGP SIGNATURE-----

--FCuugMFkClbJLl1L--

Bart?omiej Ochman [<email address hidden>] wrote:
> On Tue, Nov 08, 2005 at 09:58:22AM -0800, Lawrence Walton wrote:
>
> > I'd love to see if you can try this, in a browser.
> >
> > http://exchangeServer.domain.com/exchange/yourUserName/
> This won't work: as I mentioned, there is only secure access to OWA
> (well, in fact, http://ourExchange.server.com/.* responses with
> 301 page moved and points to https://ourExchange.server.com/exchange/)
> >
> > and
> >
> > https://exchangeServer.domain.com/exchange/yourUserName/
> >
> > It should prompt you for a username and password.
> > And if successful, you should be presented with the webmail interface.
> And it works as you described.
>
> This was actually a little surprise to me, because if I skip the username,
> it will be completed with my AD name, which differs from my login name,
> same as you describe later (Bartlomiej.Ochman vs fback).
>
> Regards,
> fb

I understood that HTTP might not work but,

I wanted to confirm and contrast by example.

OK then, we are at least getting a little somewhere.

First when prompted for the OWL in the ximian-connector-setup-2.2

Try this as a example.

https:///exchangeServer.domain.com/exchange/Bartlomiej

username: fback

password: xxxx

You *MUST* type a password to proceed.

Cheers!

--
*--* Mail: <email address hidden>
*--* Voice: 425.739.4247
*--* Fax: 425.827.9577
*--* HTTP://the-penguin.otak.com/~lawrence
--------------------------------------
- - - - - - O t a k i n c . - - - - -

Message-ID: <email address hidden>
Date: Tue, 8 Nov 2005 21:37:28 -0800
From: Lawrence Walton <email address hidden>
To: Bart?omiej Ochman <email address hidden>
Cc: <email address hidden>
Subject: Re: Bug#337957: evolution-exchange: unable to setup exchange account

--17pEHd4RhPHOinZp
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

Bart?omiej Ochman [<email address hidden>] wrote:
> On Tue, Nov 08, 2005 at 09:58:22AM -0800, Lawrence Walton wrote:
>=20
> > I'd love to see if you can try this, in a browser.
> >=20
> > http://exchangeServer.domain.com/exchange/yourUserName/
> This won't work: as I mentioned, there is only secure access to OWA
> (well, in fact, http://ourExchange.server.com/.* responses with
> 301 page moved and points to https://ourExchange.server.com/exchange/)
> >=20
> > and=20
> >=20
> > https://exchangeServer.domain.com/exchange/yourUserName/
> >=20
> > It should prompt you for a username and password.
> > And if successful, you should be presented with the webmail interface.
> And it works as you described.
>=20
> This was actually a little surprise to me, because if I skip the username,
> it will be completed with my AD name, which differs from my login name,
> same as you describe later (Bartlomiej.Ochman vs fback).
>=20
> Regards,
> fb

I understood that HTTP might not work but,

I wanted to confirm and contrast by example.

OK then, we are at least getting a little somewhere.

First when prompted for the OWL in the ximian-connector-setup-2.2

Try this as a example.

https:///exchangeServer.domain.com/exchange/Bartlomiej

username: fback

password: xxxx

You *MUST* type a password to proceed.

Cheers!

--=20
*--* Mail: <email address hidden>
*--* Voice: 425.739.4247
*--* Fax: 425.827.9577
*--* HTTP://the-penguin.otak.com/~lawrence
--------------------------------------
- - - - - - O t a k i n c . - - - - -=20

--17pEHd4RhPHOinZp
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)

iD8DBQFDcYsYsgPkFxgrWYkRAre3AKCp0KAPHqR1Cv6FiVbDWqn4DFrrVACeMtGH
esJCAXPZqlFHbWIzqmBYO50=
=1gok
-----END PGP SIGNATURE-----

--17pEHd4RhPHOinZp--

Bart?omiej Ochman [<email address hidden>] wrote:
> On Tue, Nov 08, 2005 at 09:37:28PM -0800, Lawrence Walton wrote:
>
> > First when prompted for the OWL in the ximian-connector-setup-2.2
> >
> > Try this as a example.
> >
> > https:///exchangeServer.domain.com/exchange/Bartlomiej
> > username: fback
> > password: xxxx
> >
> > You *MUST* type a password to proceed.
> Yes, before a password is supplied, Forward is grayed out.
>
> And it works with both https://exchangeServer.domain.com/exchnage/fback/
> and /exchange/Bartlomiej.Ochman/
>
> It seems you can setup an account this way, but when you start evolution,
> it doesn't work again. Somehow, this setup forgets that this account
> was setup with secure connection.
>
> When you edit OWA filed in the preferences, it seems it works again,
> despite the fact, that evolution backend dies every first run and you must
> restart evolution to use it. And when the evolution daemons die (eg. you
> quit X Window session) you have to start evolution twice again.
>
> I think now we can change severity of this bug ;)
>
> Regards,
> fb

Great!
I'll change it to normal. :)

The shame is after testing with the next rev of evolution, the connecter is even more
unstable in my opinion. :(

--
*--* Mail: <email address hidden>
*--* Voice: 425.739.4247
*--* Fax: 425.827.9577
*--* HTTP://the-penguin.otak.com/~lawrence
--------------------------------------
- - - - - - O t a k i n c . - - - - -

Message-ID: <email address hidden>
Date: Wed, 9 Nov 2005 08:56:39 -0800
From: Lawrence Walton <email address hidden>
To: Bart?omiej Ochman <email address hidden>
Cc: <email address hidden>
Subject: Re: Bug#337957: evolution-exchange: unable to setup exchange account

--qMm9M+Fa2AknHoGS
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

Bart?omiej Ochman [<email address hidden>] wrote:
> On Tue, Nov 08, 2005 at 09:37:28PM -0800, Lawrence Walton wrote:
>=20
> > First when prompted for the OWL in the ximian-connector-setup-2.2
> >=20
> > Try this as a example.
> >=20
> > https:///exchangeServer.domain.com/exchange/Bartlomiej
> > username: fback
> > password: xxxx
> >=20
> > You *MUST* type a password to proceed.
> Yes, before a password is supplied, Forward is grayed out.
>=20
> And it works with both https://exchangeServer.domain.com/exchnage/fback/
> and /exchange/Bartlomiej.Ochman/
>=20
> It seems you can setup an account this way, but when you start evolution,
> it doesn't work again. Somehow, this setup forgets that this account
> was setup with secure connection.
>=20
> When you edit OWA filed in the preferences, it seems it works again,
> despite the fact, that evolution backend dies every first run and you must
> restart evolution to use it. And when the evolution daemons die (eg. you
> quit X Window session) you have to start evolution twice again.
>=20
> I think now we can change severity of this bug ;)
>=20
> Regards,
> fb

Great!
I'll change it to normal. :)

The shame is after testing with the next rev of evolution, the connecter is=
 even more
unstable in my opinion. :(

--=20
*--* Mail: <email address hidden>
*--* Voice: 425.739.4247
*--* Fax: 425.827.9577
*--* HTTP://the-penguin.otak.com/~lawrence
--------------------------------------
- - - - - - O t a k i n c . - - - - -=20

--qMm9M+Fa2AknHoGS
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)

iD8DBQFDcipHsgPkFxgrWYkRAgOVAKCgbMnakLtEDVVvOk03Fmm5wYJc8QCeLbmv
LSmIRmKk8yiiATaesbBSFsk=
=u3Gq
-----END PGP SIGNATURE-----

--qMm9M+Fa2AknHoGS--

severity 337957 normal
--
*--* Mail: <email address hidden>
*--* Voice: 425.739.4247
*--* Fax: 425.827.9577
*--* HTTP://the-penguin.otak.com/~lawrence
--------------------------------------
- - - - - - O t a k i n c . - - - - -

severity 337957 normal
--
*--* Mail: <email address hidden>
*--* Voice: 425.739.4247
*--* Fax: 425.827.9577
*--* HTTP://the-penguin.otak.com/~lawrence
--------------------------------------
- - - - - - O t a k i n c . - - - - -

Message-ID: <email address hidden>
Date: Wed, 9 Nov 2005 10:04:56 -0800
From: Lawrence Walton <email address hidden>
To: <email address hidden>
Subject: severity 337957 normal

--fdj2RfSjLxBAspz7
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

severity 337957 normal
--=20
*--* Mail: <email address hidden>
*--* Voice: 425.739.4247
*--* Fax: 425.827.9577
*--* HTTP://the-penguin.otak.com/~lawrence
--------------------------------------
- - - - - - O t a k i n c . - - - - -=20

--fdj2RfSjLxBAspz7
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)

iD8DBQFDcjpIsgPkFxgrWYkRAmZyAKCgmod5bwAQuL/ByNf+yvVOFwZcUwCdHOwu
HPiyKRcuDGYFwAjct7UL8V0=
=7gFi
-----END PGP SIGNATURE-----

--fdj2RfSjLxBAspz7--

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Wed, 9 Nov 2005 11:54:38 -0800
From: Lawrence Walton <email address hidden>
To: <email address hidden>

--XsQoSWH+UP9D9v3l
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

severity 337957 normal
--=20
*--* Mail: <email address hidden>
*--* Voice: 425.739.4247
*--* Fax: 425.827.9577
*--* HTTP://the-penguin.otak.com/~lawrence
--------------------------------------
- - - - - - O t a k i n c . - - - - -=20

--XsQoSWH+UP9D9v3l
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)

iD8DBQFDclP+sgPkFxgrWYkRAvVXAJ0acpuROq2d57VwNb/+IVvATnT8LACffi/2
dHgp1QJt+4BULhjwkoz+soc=
=bCI+
-----END PGP SIGNATURE-----

--XsQoSWH+UP9D9v3l--

HBuzacott (hugh-buzacott) wrote :

Evolution is unable to pass 'Authetication' to complete setup.
Exchange-Connecter passes authetication with Exchange Server then the error
occurs because if wrong username/password are entered it gives out a "Check
Password or Username", If right credentials are enterd then Exchange-Connector
gives out "Could not configure Exchange account because an unknown error
occurred. Check the URL, username, and password, and try again."

Carthik Sharma (carthik) wrote :

Changing to Confirmed. Might be a duplicate, but can't find it just yet.

Changed in evolution-exchange:
status: Unconfirmed → Confirmed

There has been no new comments about
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=337957 for a long time.

Can anyone tell if the problem's still there or not?

Thanks,
Øystein Gisnås

Does this still happen to Dapper or Edgy users? If so, we should forward it upstream, else close it.

I'm running Edgy and the same error occurs if I try to connect to my exchange account. Connection via Browser (https) works fine.

Daniel Holbach (dholbach) wrote :

Can you try to get a log running
   E2K_DEBUG=2 evolution
with the Edgy version and attach it here?

Changed in evolution-exchange:
status: Confirmed → Needs Info

I run the commands as mentioned here. During setup I tried to get access with my user three times.

The first time there was an error message coming up. The second time no message appears, but forward button was also not available. The third time was like the first one - after that I ended the session.

As I interpret the log, the connection worked on the second try, but evolution does not provide me a possibility to go on in the setup process.

Is there any progess with the provided logs? If you need more detailed information, please let me know.

Daniel Holbach (dholbach) wrote :

Thanks for the logs. I forwarded the bug to the upstream developers and added it to the exchange-account tracker bug.

Changed in evolution-exchange:
status: Needs Info → Unconfirmed
Changed in evolution-exchange:
status: Unknown → Unconfirmed
Derek Buranen (eburner) wrote :

I upgraded to Edgy to find this still a bug.

I took another shot by deleting my ~/.evolution folder and starting again with the setup. It worked. I'm happily using an exchange server with evolution.

Daniel Holbach (dholbach) wrote :

Pinged back on the upstream bug.

Changed in evolution-exchange:
status: Unconfirmed → Confirmed
Daniel Holbach (dholbach) wrote :

Upstream asks if it could be that your username and mailbox are different. (401 - unauthorized)

Changed in evolution-exchange:
status: Confirmed → Needs Info

I'll check if our usernames are not identical to the mailbox names.

Changed in evolution-exchange:
status: Unconfirmed → Needs Info
Daniel Holbach (dholbach) wrote :

Any luck with that?

I confirme the bug is still present, now I'm using

evolution-exchange 2.8.1-0ubuntu1

but i have the same problem on other computers in Debian Native.

Thanks for your help

Yes, usernames and mailbox names are not identical. This is caused by the integration of exchange in the ad infrastructure.

Daniel Holbach (dholbach) wrote :

Does that mean you don't see the problem anymore?

Sorry, but I see a problem there. From my point of view it is not possible to setup exchange integration with evolution if the exchange accounts are maintained in an active directory (usernames and mailboxnames differ). I'll be thankfull for any kind of workaround that could be used to setup evolution instead of this behavior.

Steffen Torp (steffen-ubuntu) wrote :

I can confirm this on Edgy and Exchange 2003+Active Directory. I've tried inserting https://owa.server.ext/exchange/username as the OWA URL and name.surname as username, without luck. Still same error.

Steffen Torp (steffen-ubuntu) wrote :

Update: with Active Directory, I'm not able to log in to OWA in browser with firstname.lastname anymore. I have to use server\firstname.lastname or <email address hidden> where server=Active Directory authentication server.

I have tried both server\firstname.lastname and <email address hidden> as usernames, without luck.

Anonymous (patrycjusz) wrote :

I seem to be hitting the same problem here. Unfortunately, I can't tell if my AD user name is different from my mailbox name as I'm too MS Exchange ignorant. As this is quite important for me, is there any way to pay a developer to fix this bug?

Claus Frein (cfrein) wrote :

I have the same problems in dapper/edgy/feisty with the setup of an exchange-account in evolution.

Access per OWA per https://owa-server/exchange/username ist still possible.

My workaround is to directly call exchange-connector-setup-2.x, which creates the account. I enter the same information as in evolution (which doesn't work!) and it works well.

Anonymous (patrycjusz) wrote :

When I use exchange-connector-setup-2.8 (in 6.10) and provide:

owa url: https://owa.company.com/exchange/username
username: ...
password: ...

and click next, I get the "unknown error" error and the "owa url" transforms to:

https://owa.company.com/CookieAuth.dll?GetLogonWrapper?url=%2Fexchange%2F<MY_USERNAME>&reason=0/

In the same company other people use Fedora Core 3 with Evolution 2.0.X and it works fine.

Claus Frein (cfrein) wrote :

@ Anonymous:

As owa url in the exchange-connector i don't include the username. For example:

OWA url: https://owa.company.com/exchange
username: ...
password: ...

Anonymous (patrycjusz) wrote :

I tried that before... I tried many different things, like DOMAIN\USERNAME for username, my e-mail for username and it still won't work. The difference is that in exchange-connector, after clicking Next, the "OWA URL" field changes as described by my previous comment (i.e. "CookieAuth.dll" is added). In the evolution itself, no such thing happens.

Steffen Torp (steffen-ubuntu) wrote :

Is there any way of forcing Evolution/Exchange-connector to operate with a username separate from the authentication name?

I know my username is firstname2 (if I log in to OWA through the browser the internal links in the frames point to https://owa.domain.ext/exchange/firstname2/*). However, my authentication name is either domain/ad.username or <email address hidden>

Paul (paulwozney+launchpad) wrote :

I also have the same problem in that Evolution throws the "unknown error" when I try to add an exchange server.

I actually have two exchange servers that I connect to, and the first server I configured worked fine. Server two is at a different location and I suspect is configured differently.

I also attempted to run this with exchange-connector-setup-2.8 outside of Evolution, however I had no further success. I went through the various contortions of OWAURL/exchange/username, and domain\username in the authentication fields to no avail.

$ rpm -qa | grep evolution
evolution-webcal-2.7.1-6
evolution-sharp-0.11.1-10.fc6
evolution-2.8.3-1.fc6
evolution-data-server-1.8.3-3.fc6
evolution-data-server-devel-1.8.3-3.fc6
evolution-connector-2.8.3-1.fc6
beagle-evolution-0.2.13-1.fc6

$ uname -a
Linux localhost.localdomain 2.6.19-1.2911.6.5.fc6 #1 SMP Sun Mar 4 16:41:13 EST 2007 i686 athlon i386 GNU/Linux

Even so, I may be able to offer some insight. The OWA url I am having problems with is running on https, and it has an incorrect encryption certificate. It is a private site, and is self-signed but I guess they changed the server name a while ago and nobody bothered to update the cert.

The page is self-signed to https://foo.company.com/, however the current system is running on https://foo2.company.com. When visiting the site, the browser prompts you to accept the site in its incorrectly signed state. Is it possible that this is a common thread for this problem?

If this is a real problem, I can ask the administrators to update the security certificate, but I would rather not waste their time idly.

Thanks for your advice!

Paul

Paul (paulwozney+launchpad) wrote :

Hi, I gathered some data using "CAMEL_DEBUG=all evolution >& evo.log"

CamelException.setv((nil), 302, 'Could not parse URL `'')
CamelException.setv((nil), 302, 'No provider available for protocol `'')
CamelException.setv((nil), 302, 'Could not parse URL `'')
CamelException.setv((nil), 302, 'Could not parse URL `'')
CamelException.setv((nil), 302, 'Could not parse URL `'')
CamelException.setv((nil), 302, 'Could not parse URL `'')
CamelException.setv(0xbfc59854, 302, 'Could not parse URL `'')
CamelException.setv((nil), 302, 'Could not parse URL `'')
CamelException.setv((nil), 302, 'Could not parse URL `'')
CamelException.setv(0xbfc5a774, 302, 'URL 'exchange://' needs a username component')
CamelException.setv((nil), 302, 'Could not parse URL `h'')
CamelException.setv((nil), 302, 'Could not parse URL `ht'')
CamelException.setv((nil), 302, 'Could not parse URL `htt'')
CamelException.setv((nil), 302, 'Could not parse URL `http'')
CamelException.setv((nil), 302, 'Could not parse URL `https'')
CamelException.setv((nil), 302, 'Could not parse URL `'')

This stuff didn't pop up on the fly, and was only written to the log file when I exited Evolution so I'm not convinced that it is actually related to the Exchange connector, but I figured I would let you guys figure it out.

Paul

Michael Losonsky (michl) wrote :

Evolution-Exchange does not work with Microsoft
Exchange 2007. I had the same problem and it was
confirmed on the Evolution site and by one of our IT
folks who manages our Exchange 2007 server confirmed
this. He filed a bug report and apparently some folks
started working on this in the past few months.
I wish I had the links, but they are easy to find
with google.

Steffen Torp (steffen-ubuntu) wrote :

Confirmed in Feisty beta as of dist-upgrade 3 March 2007. Seems Evolution is not able to work with Active Directory.

Steffen Torp (steffen-ubuntu) wrote :

I am actually able to connect to Exchange through OWA through an SSL proxy. If I am only putting in the OWA URL in Outlook, it doesn't work. It needs the SSL Proxy

Daniel Holbach (dholbach) wrote :

Steffen: can you give more information about the configuration you change to make it work? Is there any log file you can attach to display what happens?

Steffen Torp (steffen-ubuntu) wrote :

Sorry Daniel. Haven't been able to get it to work with Evolution - I'm having it working through OWA in Outlook 2003, with the SSL proxy preference, which doesn't exist in Evolution. Any hint on where I can define this preference in Evolution is welcome.

Hello,
I stumbled upon this bug list because I too am trying to connect to an exchange server. I'm having what appears to be the same trouble as the above users. I am not using Debian, but instead using Fedora Core with the evolution exchange update installed via yum. I am posting here because I wanted to find out if there is a way to specify a domain with evolution exchange as I have not seen any reference to doing this. My company requires me to log in using

domain\username

as my user name. When I do this in evolution, it produces the error seen by others here. Even if there isn't a current fix, maybe it is a data point (well, I haven't run any logs yet. I need to find out how to do that, my next step...)

Unfortunately, I have no easy way to find out if my username and the username used for the exchange server are different. I will post a log here if someone believes it would be helpful.

Ulrik Mikaelsson (rawler) wrote :

This is a known bug in evolution. I can't seem to find the dissection of the bug now, fiddled with it roughly half a year ago. It also affects Entourage on MacOSX. Details here http://support.microsoft.com/kb/909268.

Anyways, I started working on a patch, but didn't finish. My problem was that I got past the cookie-auth, but then the connector-setup could not access the GAL server, since I'm not in the right network. I'm attaching the patch as far as I got, hoping it might be of some use to someone. There's a slight chance it actually works, if only you have access to the GAL server.

Paul (paulwozney+launchpad) wrote :

What information is required for this bug? Can I help to provide what is required?

From the link that Ulrik submitted, it looks like there was a patch submitted to another branch of the exchange connector on March 8th 2007. I am willing to help test this patch on my system, if some direction is given. I haven't been able to locate a repository for the source of the Ubuntu build of the exchange connector. Maybe I'm looking in the wrong place?

Paul

Jeff Strahl (jeff-strahl) wrote :

OS: Ubuntu 7.10 (Gutsy)

When I attempt to create the Exchange account, the "Forward" button stays grayed out even after successful authentication. The IT group uses Exchange 2000 as the email system.

I can access the OWA via https://webmail.companyname.com/exchange/Jeff.Strahl and that's how I have configured the evolution-exchange plugin. The plugin prompts me for a password, but then the "Forward" button stays grayed out.

In the debug log, I notice that there are 401 "Access Denied" errors, but it proceeds and the last entry seem to be the actual pages.

Attached is the log file.

Thanks,
-jeff

yclian (yuenchi-lian) wrote :

Hi guys,

I am getting this error while setting up Evolution to connect to an Exchange 2007, at the "Authenticate" Username/OWA URL screen:

"The server is running Exchange 5.5. Exchange Connector supports Microsoft Exchange 2000 and 2003 only."

This is what I'm running:

yclian@nemesis:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 7.10
Release: 7.10
Codename: gutsy

yclian@nemesis:~$ evolution --version
GNOME evolution 2.12.0

Some details from the server:

Outlook Web Access version: 8.0.752.0
Outlook Web Access host name: mail.yourexchange.com.au
Exchange Client Access server .NET Framework version: 2.0.50727.832

Regards,
Yuen-Chi Lian

Jason L. Froebe (jason-froebe) wrote :

It's been two years since this bug was reported. When can we expect a fix? Is there more information that is needed? Is *ANYONE* working on this issue?

Jason L. Froebe (jason-froebe) wrote :

Two year and counting. This has been confirmed many many times over.

Changed in evolution-exchange:
status: Incomplete → Confirmed
Steffen Torp (steffen-ubuntu) wrote :

This is getting embarassing for the Linux community in general. It pretty much makes it hard for any enterprise destop to be Linux based. Anyone for a bounty? I'll start with EUR 25.

Well, I don't know about embarassing, but the problem for me is complicated by the fact that I'm trying to connect to my company through an IT run web service, so I have no control over the other end to even suggest what might be going on. From what I read of the problem on the Microsoft website, the solution doesn't seem simple as a different authentication DLL is supplied, which Evolution isn't familiar with. Maybe newer updates to evolution-exchange? Since I last posted, I switched to Ubuntu and am at Gutsy. I don't know if that means an updated evolution-exchange plugin, but it did update evolution and I haven't tried. I did try it in Feisty with the same results, so presumably the plugin hadn't changed.

If Steffen Torp is willing to post 25 EUR, I'll match that in dollars at a 1.35 exchange (I don't know what todays rate it exactly), but it should come out to around $35 or $40 dollars... So that is $80 for someone. If no one takes it, then I might have to look into it myself, but as I said, I don't know how far I can actually get without access to the other side to see logs and so forth.

I did not try to suggested patch yet. No time. I just went back to the web browser (read "el-sucko") method of using exchange... There's got to be a better way. Ugh.

Roboknight.

I may have a completely different problem... as I've looked at a few more things now:

1) I have an Exchange 2003 server... I believe everything should work with a Mac (the other exchange client suggested above... Entourage. However,
as someone above posted, my exchange server is on an https website. I've tried that and gotten nothing. Maybe it is that which doesn't work in my own case.

2) when logging into the website I get the following redirection:

https://webmail.foo.com --> https://webmail.foo.com/exchweb/bin/auth/owalogon.asp?url=https://webmail.foo.com/exchange/&reason=0

which if I understand everything correctly, this is were the owalogon script should reside that provides the correct owa authentication dll. So at this point
I'm at a loss, because although the results are the same as above, it doesn't appear that I have exactly the same problem (or maybe I do and the redirection is just masking 2004 ISA in front of 2003 Exchange server...)

Anyway, I don't know if any of this helps... I am going to try and enable some logs now and post them to see if any of that helps.

I ended up with a piece in my attached log that indicates they may not support clients other than Microsoft clients. Jeez. I don't know exactly what error 500 indicates for sure, however it does seem to indicate a rejection by the HTTP filter, and unless there is a way to make evolution-exchange appear more like a Microsoft client, I'm pretty much done with this bug. Didn't mean to clutter this thread with what turns out to be an irrelevant bit, but my above offer still stands none the less. Other people appear to be waiting for someone other than their IT departments. I did learn a few things about evolution however, which may prove useful later on.

deli.ds (deli.ds) wrote :

I did have the same issue (Gutsy, Evo 2.12.1, ) as some of the people here, where i could do everything except access the GAL. I managed to get things working using the following settings;

In Account Editor -> Receiving Mail
 - Username = domain\username
 - OWA = https://foo.bar.com/exchange

In Account Editor -> Receving Options
 - Global Catalog Server Name = foo.bar.com

You should then be able to get into GAL (must search to show names).

Hope this helps some.

Steffen Torp (steffen-ubuntu) wrote :

I think that for most people on this thread, the problem is how to get past "Authenticate".

Changed in evolution-exchange:
status: Confirmed → Triaged
Steffen Torp (steffen-ubuntu) wrote :

Some guys are developing a plugin for direct MAPI access to Exchange - http://www.openchange.org/index.php?option=com_content&task=view&id=65&Itemid=74

Naran K Patel (narankpatel) wrote :

This is affecting Hardy Evo 2.22.0 too, I've just experienced this issue in Bug #209438.

ProblemType: Bug
Architecture: i386
Date: Sun Mar 30 15:00:54 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/evolution
NonfreeKernelModules: fglrx
Package: evolution 2.22.0-0ubuntu2
PackageArchitecture: i386
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: evolution
Uname: Linux 2.6.24-12-generic i686

Colin (colin-casadixon) wrote :

Just hit the same problem with the 8.04 LTS using 2.22.1 release of Evolution. It manifests in exactly the same way: you can't get by the authentication step in the account set up when specifying domain\username. I have this account setup and working in Outlook on another machine and it works fine (so, I know the OWA address and username/password I'm using are all correct.) Can I help gather info? If so, please give me explicit instructions how. (I'm still relatively new to the environment.)

Mynk (mr-mynk) wrote :

The authenticate button is always greyed for me. I am seeing this problem on both Gutsy and Hardy. In Gutsy it used to get activated if I chose some other server type and back to Microsoft Exchange. In Hardy even that doesn't work. I run into the same issues with the login name and password on Gutsy.

Moved to Thunderbird for now as it worked. Hoping this bug on Evolution is fixed soon.

Naran K Patel (narankpatel) wrote :

I did a clean install of 7.10, went to exchange account screen, it worked. Backed out of the account creation screen. Upgraded to Hardy, went to exchange account screen, I'm having the same problem - it fails with Unknown URL error. I've applied the Hardy recommended updates, tried the OWA connector - no joy, then the proposed updates, still no luck. I can't get past the Exchange account screen. I hope someone fixes this soon! Or posts a workaround that works for Hardy...

  • unnamed Edit (1.2 KiB, text/html; charset=ISO-8859-1)

my solution

backup evolution from gutsy. Fresh install hardy

restore from backup.

2008/5/9 Naran K Patel <email address hidden>:

> I did a clean install of 7.10, went to exchange account screen, it
> worked. Backed out of the account creation screen. Upgraded to Hardy,
> went to exchange account screen, I'm having the same problem - it fails
> with Unknown URL error. I've applied the Hardy recommended updates,
> tried the OWA connector - no joy, then the proposed updates, still no
> luck. I can't get past the Exchange account screen. I hope someone fixes
> this soon! Or posts a workaround that works for Hardy...
>
> --
> evolution-exchange: unable to setup exchange account
> https://bugs.launchpad.net/bugs/25106
> You received this bug notification because you are a direct subscriber
> of the bug.
>

That evolution will not work with Exchange accounts, particularly Exchange 2007
accounts has been known for some time now but for some reason this cannot be
or is not being fixed. The only workaround that I know of is to connect to your
exchange account as an IMAP account. That works. You won't be able to
use the Exchange frills, but you can manage your email.

Same issue i logged it, elsewhere cant find the bookmark. Same issue can not get past authenticate, can I write directly to a config file?

Sebastien Bacher (seb128) wrote :

could you try if that's still an issue in intrepid?

Sebastian Martinez (tychocity) wrote :

Yes, the issue still exist in intrepid after the today updates

Changed in evolution-exchange:
status: Incomplete → Invalid
Pedro Villavicencio (pedro) wrote :

upstream said the bug is fixed with evolution 2.24, could you please comment on http://bugzilla.gnome.org/show_bug.cgi?id=375727 if you still get the issue or confirm that it's fixed? thanks in advance.

Changed in evolution-exchange:
status: Triaged → Incomplete
Pedro Villavicencio (pedro) wrote :

marking this as fixed, feel free to re open if you encounter the same issue with latest evolution package, thanks.

Changed in evolution-exchange:
status: Incomplete → Fix Released
mikef187 (mikef187) wrote :

This bug has been a thorn for years. All my attempts to get it fixed have failed. I feel like I'm trying to improve an M$ product.

Anyway, I have solved this problem, but it takes some work. You have to download, edit, build, and reinstall the exchange connector.

Step 1 download source
cd to your home folder and run
apt-get source evolution-data-server

Step 2 edit source file
evolution-data-server-2.24.3/servers/exchange/lib/e2k-autoconfig.c
find line 479 it should read "} else if (strstr (location, "/owalogon.asp") ||"
Insert a new line and type
                                                           strstr (location, "/cookieauth.dll") ||

after you are done make sure lines 479 480 and 481 look like

                } else if (strstr (location, "/owalogon.asp") ||
                           strstr (location, "/cookieauth.dll") ||
                           strstr (location, "/CookieAuth.dll")) {

Step 3 build
cd to evolution-data-server-2.24.3
debchange -i "fix cookieauth case"
sudo apt-get build-dep evolution-data-server
dpkg-buildpackage

Step 4 Reinstall
cd to home folder and run
evolution --force-shutdown
dpkg -i *.deb

rerun the exchange setup and you should be good to go

This is a problem because of windows' inconsistent use of case CookieAuth.dll != cookieauth.dll

If this worked.... please let me know by running

echo "Thanks Mike" | mail -s Evolution-worked <email address hidden>

This bug is due to terminally dumb UI design.

In the OWA settings page on the wisard (or the relevant preferences
dialogue) the Mailbox should not be a writeable field.

It is obtained from a server. If a user sets it manually (which is the
case if the settings are copied from one machine to another) the Mailbox
is displayed, but internally the library _ADDS_ the setting from the
Mailbox to the one obtained from the server.

As a result instead of accessing https://mail.bt.com/exchange/IVANOVA
(where IVANOVA is the mailbox) it accesses
https://mail.bt.com/exchange/IVANOVA/IVANOVA resulting it total fubar.

None the less all settings and dialogues for both cases - obtained from
server and set manually look the same.

This field must be left as read-only/greyed out/whatever by default and
the correct setting must be displayed if it is touched manually.

The bug has been posted a number of times on Fedora, Ubuntu, etc BTSes,
however it is usually posted as a "Kerberos Error" which is just a
spurious error message and does not reflect the actual bug.

Cheers,

--
   Understanding is a three-edged sword:
            your side, their side, and the truth. --Kosh Naranek

A. R. Ivanov
E-mail: <email address hidden>
WWW: http://www.sigsegv.cx/
pub 1024D/DDE5E715 2002-03-03 Anton R. Ivanov <email address hidden>
    Fingerprint: C824 CBD7 EE4B D7F8 5331 89D5 FCDA 572E DDE5 E715

Adam Delman (flyn-flyn) wrote :

Hi Mike,

I've tried following your instructions and I'm still running into the same problem.

Any other suggestions?

Regards,
Adam

Adam,

Does your exchange url have cookieathu.dll or CokkieAuth.dll notice the
case?

On 4/3/2009, "Adam Delman" <email address hidden> wrote:

>Hi Mike,
>
>I've tried following your instructions and I'm still running into the
>same problem.
>
>Any other suggestions?
>
>Regards,
>Adam
>
>--
>evolution-exchange: unable to setup exchange account: e2k_properties_get_prop: assertion `props != NULL' failed
>https://bugs.launchpad.net/bugs/25106
>You received this bug notification because you are a direct subscriber
>of the bug.

Adam Delman (flyn-flyn) wrote :

Our exchange url uses CookieAuth.dll.

Bexifer (eaxrl4) wrote :

Has anyone managed to sort this yet?

I cant get past the authenitcation stage - using evolution 2.24, forward remains greyed out. I tried the abive fix but to no avail

Changed in evolution-exchange:
importance: Unknown → Medium
status: Invalid → Expired
hummerbliss (hummerbliss) wrote :

This still happens with evolution on 10.04 LTS.

hummerbliss (hummerbliss) wrote :

Hi Again,

What needs to be done so that the bug can be made alive again ? Opening a new bug seems silly as it would loose all the comments above.

Thanks.

Changed in evolution-exchange (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.