can't filter email from exchange account

Bug #23431 reported by Joe Barnett on 2005-10-07
8
Affects Status Importance Assigned to Milestone
evolution-exchange
Expired
Medium
evolution-exchange (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

with evolution/evolution-exchange 2.4.1, filters that I have set up no longer
work on my exchange inbox (filtering from exchange inbox to separate IMAP folder
heirarchy).

When I get a new email in my exchange account, it stays in the exchange inbox.
If i go to the exchange inbox and do 'select all', 'apply filters', I get the
following error message pop-up:

-------------------------------------------
Error while Filtering Folder.

No provider available for protocol `email'
-------------------------------------------

Sascha Brossmann (brsma) wrote :

> -------------------------------------------
> Error while Filtering Folder.
>
> No provider available for protocol `email'
> -------------------------------------------

also on ppc: i am getting the same error message with my IMAP account (w/out an
exchange account involved). unfortunately, this makes evolution practically
useless as an email client. the bug must have been introduced lately, it was not
present in the preview version of breezy.

(current version: Linux 2.6.12-9-powerpc #1 Mon Oct 10 15:26:45 BST 2005 ppc;
Gnome evolution-2.4 2.4.1)

Carthik Sharma (carthik) wrote :

Thank you for reporting this.

Is this bug still present in the latest Evolution in Dapper?

If this bug is fixed, please let us know and this bug can be closed.

Thanks again!

Changed in evolution-exchange:
status: Unconfirmed → Needs Info
Joe Barnett (thejoe) wrote :

Yup, I still get this in dapper.

Carthik Sharma (carthik) wrote :

Changing status to confirmed since one other person has confirmed this bug.

Changed in evolution-exchange:
status: Needs Info → Confirmed
Joe Barnett (thejoe) wrote :

Note that if you re-set the destination folders on all your filters, this bug should go away.

Changed in evolution-exchange:
status: Unknown → Rejected
Sebastien Bacher (seb128) wrote :

comment from the upstream bug:

"this can happen if you have just installed Evolution on a new machine and have
copied the file ~/.evolution/mail/filters.xml.
Since the filters refer to accounts directly, and accounts all have a unique ID
number, you get the above error if it cannot find the account anymore, so you
either have not copied the account settings or they have been changed in the
meantime.
Evolution stores its account settings under ~/.gconf/apps/evolution.

i'd recommend to open ~/.evolution/mail/filters.xml with a texteditor and
change/reset the offending filter rule.

setting to NEEDINFO, please reopen when answering."

Joe Barnett (thejoe) wrote :

setting to Rejected, just like upstream bug. upstream comments are accurate.

Changed in evolution-exchange:
status: Confirmed → Rejected
Changed in evolution-exchange:
importance: Unknown → Medium
status: Invalid → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.