Filters are not applied to new mail on Exchange

Bug #10669 reported by Jens Bech Madsen on 2004-11-25
92
This bug affects 5 people
Affects Status Importance Assigned to Milestone
evolution-exchange
Fix Released
Critical
evolution-exchange (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Filters are not being applied automatically to incoming mail on Exchange.
Selecting the messages and choosing 'Apply filters' works fine.

http://bugzilla.ximian.com/show_bug.cgi?id=72611: http://bugzilla.ximian.com/show_bug.cgi?id=72611

Sebastien Bacher (seb128) wrote :

which version of evolution are you using 2.0.2 (warty) or 2.1.0 (hoary) ?

anybody else with an exchange server to test this ?

Jens Bech Madsen (jbmadsen) wrote :

I'm using 2.1.0.

Sebastien Bacher (seb128) wrote :

do you still get this bug with current versions ?

Jens Bech Madsen (jbmadsen) wrote :

I cannot test this. The exchange plugin is now so broken I can't even create an
Exchange account. I had kept my old exchange account but when I activated it, it
didn't work. I then tried to edit the account and when the edit account dialog
opened, it hosed the settings completely.

The Edit Account dialog no longer has an entry for OWA url. The Create Account
dialog has this field.

If I activate the Global Catalog server name field in the receiving options tab,
the OK button is greyed out and it is impossible to save the account. Only way
out is Cancel.

I tried to construct a proper exchange:// URI through gconf-editor but either I
got it wrong or the plugin simply doesn't work at all. It claimed my mailbox
wasn't on the server. Editing the account through Evolution again resulted in
hosed account settings.

Bottom line: I can't test if this bug still persists because the exchange plugin
is even more broken than before.

Sebastien Bacher (seb128) wrote :

what's broken with the new version ?

Jens Bech Madsen (jbmadsen) wrote :

It has become less broken in the past few uploads, but it still doesn't work.
See bug 12407.

Sebastien Bacher (seb128) wrote :

is the filter issue still here with 2.1.5 ?

Jens Bech Madsen (jbmadsen) wrote :

Yes.

Sebastien Bacher (seb128) wrote :

I've opened a bug upstream about this:
http://bugzilla.ximian.com/show_bug.cgi?id=72611

Sebastien Bacher (seb128) wrote :

that's fixed in the current version according to upstream, do you still have the
issue ?

Jens Bech Madsen (jbmadsen) wrote :

No, it appears to be fixed in 2.2.0. Thanks.

Daniel Holbach (dholbach) wrote :

Seems to be broken according to bug 49097 in Dapper again.

Changed in evolution:
assignee: seb128 → desktop-bugs
status: Fix Released → Unconfirmed
Daniel Holbach (dholbach) wrote :

I followed up on http://bugzilla.gnome.org/show_bug.cgi?id=272611 with your comments from bug 49097.

Changed in evolution-exchange:
status: Unknown → Confirmed
Changed in evolution-exchange:
status: Confirmed → Needs Info
Sebastien Bacher (seb128) wrote :

upstream comment:

"it works for me even for 'Apply filters on new messages in the inbox'
Is that none of the filters are not working or one particular filter is not
working ? What is that filter condition where filtering fails for new messages
in inbox ? "

Johan Walles (walles) wrote :

I haven't seen any filter triggering automatically on incoming mail. I have five filters in place for my incoming mail. None of them seem to trigger.

When I run them manually after having received e-mail, all of them seem to work as expected.

The first filter rule out of the five non-triggering ones is:

Name: "Johans CRar"
If any of the following conditions are met:
Specific header "X-WebClarify-Owner" contains "walles"
Specific header "X-WebClarify-Owner:" contains "walles"
Specific header "X-WebClarify-Owner: " contains "walles"
Then:
Assign color [green].

I used three different queries for the e-mail header name since it's not obvious to me how I should specify a header for it to match. At least one of them is correct, since the filter works if I run it manually on the inbox.

Sebastien Bacher (seb128) wrote :

Johan, on what sort of account do you use that filtering?

Sebastien Bacher (seb128) wrote :

what version of Ubuntu do you use?

Johan Walles (walles) wrote :

I don't know if I understand your "what sort of account" question, but it's an Exchange account. Does that answer the question?

As for the Ubuntu version, I'm on Dapper.

Changed in evolution-exchange:
status: Needs Info → Confirmed
Sebastien Bacher (seb128) wrote :

That answers the question, marking as confirmed since several people reported that issue

Changed in evolution-exchange:
status: Unconfirmed → Confirmed
André Cruz (andrefcruz) wrote :

I also have this problem. I use a normal IMAP account on Dapper.

Ian Redfern (ian-redfern) wrote :

This problem has just surfaced for me with the latest evolution-exchange in gutsy: 2.11.4-0ubuntu1.

Until the last upgrade, all my filters have run happily on my Exchange inbox whenever mail arrives in it - one of them moves all unfiltered messages into my local inbox. Now, even though I still have 'Apply filters to new messages in Inbox on this server' checked, and haven't changed anything, none of the filters run. They work fine if I run them manually on the Exchange inbox.

Craig Main (cmain) wrote :

I have the same problem.

All worked in feisty, I used the backup plugin in evolution to make a backup. Did a clean and fresh install of Gutsy tribe 3. Did a restore.

All filters work as expected when selecting messages and pressing ^y. None are run however when new mail arrives.

Ian Redfern (ian-redfern) wrote :

I'm finding the filters normally work, but sometimes just stop and I need to do a killev to get them working again. Right now, they're working; I'll report if they stop again. evolution-exchange 2.11.5-0ubuntu1.

Changed in evolution-exchange:
status: Confirmed → Triaged
Kelly (kelly-hamlin) wrote :

I can confirm this is still occuring.
Feisty
Evolution 2.10.1-0ubuntu2

using exchange, and if i manually apply filters it works fine. I know for example in regular outlook, there is a checkbox to enable/disable filters, maybe something similar however hidden causing this?

Kelly (kelly-hamlin) wrote :

I can confirm this is still occurring.
Feisty
Evolution 2.10.1-0ubuntu2

using exchange, and if i manually apply filters it works fine. I know for example in regular outlook, there is a checkbox to enable/disable filters, maybe something similar however hidden causing this?

Dave Hayes (dwhayes) wrote :

I can confirm this is still occurring in Evolution 2.11.91-0ubunu1 on Gutsy.

Occasionally, filters will be run on new mail already sitting in the Inbox when starting Evolution, but not reliably. Otherwise, messages need to be selected and the filters activated with ^y.

Dianoga (dianoga7) wrote :

Also confirming.

Evolution 2.12.0
Gutsy

It does work if I apply manually with ctrl-y

gsiwakumar (shivaak) wrote :

I did have the same problem. All filters where working when i apply it manually and i did not work when a new mail comes in.

i was able to fix it when i enable "Apply filters to new messagesin inbox on this server" available in the following path "Edit-> Preferences-> Edit(Account Editor)-> Receiving options".

IMHO, this option needs to be enabled by default which is not the current case.

Iam using
Evolution 2.10.1
Ubuntu 7.04 (Feisty Fawn - released in April 2007)

Rgds,
Siva.

Ian Redfern (ian-redfern) wrote :

My problem was different. About 90% of the time, the filters run on new mail as expected. Sometimes, without any reconfiguration, I start Evolution and they just don't run. A killev and restarting Evolution seems to fix it.

It happened again last week on then current Gutsy: evolution_2.12.0-0ubuntu2_i386.

I confirmed that "Apply filters to new messages in inbox on this server" was checked and I'm still seeing this problem with Evolution 2.12.0 on Gutsy up-to-date. Everything was copacetic with Feisty, only started seeing this bug after upgrading to Gutsy. Manually applying filters with ctrl-y works as expected still.

Dean (deanjones+bugs) wrote :

I can confirm that this problem exists in Gutsy with me too. I'm fully up to date. All worked absolutely fine in Feisty. Using Evolution 2.12.0-0ubuntu3. Have tried uninstalling, reinstalling, etc... I've tried unchecking and rechecking the "Apply filters to new messages in inbox" and that didn't work either. Ctrl-Y works just fine, but as messages come in, it seems that the filters are not applied.

Seth de l'Isle (szoth) wrote :

I can confirm that this problem exists in Gutsy 2.12.0-0ubuntu5

Sebastian Martinez (tychocity) wrote :

confirmed Gusty evolution 2.12.0-0ubuntu5

Works for me after editing the preference for the account editor receiving options tab. Note you may have to restart evolution for the changes to take affect.

description: updated
description: updated
Sebastian Martinez (tychocity) wrote :

I modified the preferences an not work for me.
Gusty final release evolution 2.12.0-0ubuntu5 - Exchange 2003

James Lamb (admin-oranged) wrote :

Hi,

After a fresh install of Gutsy I am now having problems where the filters assigned to my exchange inbox will never work. I have followed all of the instructions in this thread with no success.

Regards,

James

James Lamb (admin-oranged) wrote :

Hi,

Further to my last comment, If I ctrl-a to select all inbox emails then ctrl y the message filters work. It just wont work automatically on the receiving email.

Regards,

James

Also getting this with gutsy. Noticed that this is true for not only and evolution dir brought forward but also if an account is created fresh.

Further I've noticed that it often applies, some, of the filters but not all or it will apply the filters on one checkin of mail but not the next.

Sebastian Martinez (tychocity) wrote :

after upgrate to evolution 2.12.1-0ubuntu1 today, the problem continues.

Same problem here (after upgrading to Gutsy) with evolution-exchange 2.12.0-0ubuntu1.

Combined with the other new-in-gutsy bug which prevents disabling notification of new mail, this means I get a notification balloon and a flashing mail icon appearing every 30 seconds or so throughout the day to announce the latest spam arrivals :-(

The "Check new messages for Junk contents" and "Apply filters to new messages in Inbox on this server" options are both turned on.

Martin Soto (soto255) wrote :

I'm also seeing this here, and is very annoying due to the large amount of spam I receive. In feisty, filters seemed to work most of time, even if every now and then an email or two would remain unfiltered for unknown reasons. Now in gutsy filters aren't applied at all and must be run by hand.

By the way, for those suffering with Evolution's baloon notifications, they can be stopped by dissabling the "Mail notification" plugin under Edit | Plugins. It worked for me, at least.

Murali (mshanker) wrote :

I am experiencing a similar problem after upgrading to Gutsy. My filters, including bogofilter, doesn't apply to incoming mail until I do Ctrl A, Ctrl M, J, and then it works. Also, same problem for IMAP. Everything worked as they should in Fiesty.

tog

stevecrozz (stevecrozz) wrote :

I can also confirm this bug with evlolution in latest Gutsy configured to use IMAP to an exchange server. Rules can run manually, but 'Apply filters to new messages in INBOX on this server' does not have the expected behavior. I have restarted evolution and the message rules are not applied. This becomes very annoying for those of us who receive useless emails on a minute by minute basis. The notification area in the panel grabs my attention with new email constantly.

--Stephen

stevecrozz (stevecrozz) wrote :

Also, apparently this bug was assigned to Ubuntu Desktop Bugs on 2006-01-13. I'm recommending that the bug be reassigned since its closing in on two years old at this point.

--Stephen

Basilio Kublik (sourcercito) wrote :

Hi Steve
You can check the status of this bug or comment you findings upstream at http://bugzilla.gnome.org/show_bug.cgi?id=272611, where the developers can easily find it, at this point there's no much we can do here, since this issue isn't exclusive of Ubuntu, but rather a bug in the connector itself.

Murali (mshanker) wrote :

I am not sure this is a problem with just the Exchange Connector. My filters stopped working on new mail even when connecting to an IMAP server that is not Exchange. Worked quite well with Feisty.

Tog.

cmus (craig-musburger) wrote :

I can confirm this same problem on a system recently upgraded from Feisty to Gutsy. Filters were working fine prior to the upgrade.

wirehead78 (wirehead78) wrote :

Same problem Ubuntu 7.10 Evolution 2.12.0

This might have been fixed by upstream:
http://bugzilla.gnome.org/show_bug.cgi?id=444503
http://svn.gnome.org/viewvc/evolution-exchange?view=revision&revision=1502

It's a really simple patch (move an if() clause a few lines) that should be easy to backport if this is deemed important enough.

Sebastien Bacher (seb128) wrote :

Could people having the issue try the change?

On Fri, 2007-11-16 at 09:39 +0000, Sebastien Bacher wrote:
> Could people having the issue try the change?

I recompiled evolution-exchange two hours ago with the referenced patch,
and, so far, it seems to be working. A few spam messages were already
filtered properly.

cmus (craig-musburger) wrote :

I would love to see this backported.

Aloha,
cmus

Hi all
I'd fixed it deleting de summary file in my .evolution/mail/exhange/__my_account__/personal/subfolders/Inbox/
and the filters worked fine again
Hope this help

Dave Hayes (dwhayes) wrote :

Deleting the summary file for my Exchange Inbox worked for me too.

gaax (gaax) wrote :

Deleting the summary file also works for me.

James Lamb (admin-oranged) wrote :

After deleting the summary file it worked for me also.

James Lamb (admin-oranged) wrote :

Actually after saying that its resolved the problem on my filters I come back to report its not resolved the problem on all filters. It seems that only some of the filters are being applied automatically while others need me to select the messages then filter them manually. This is after deleting the summary file.

Derek (bugs-m8y) wrote :

Same issue, deleting summary did not help.

Bhuvan Arumugam (bhuvan) wrote :

Yes, deleting summary and summary-meta files actually helped. After deleting the files, I restarted evolution. It took more than normal time to start, as it generated these files for Inbox. Now the filters are applied for all incoming emails and they are moved to appropriate folder.

Anbalagan Pugaleesan (anbu78) wrote :

Right.

In evolution, filters used to work for me in Edgy. But after upgrading to gutsy it failed to filter automatically, every time I should do it manually even the 'Apply fiilters to new messages' option is enabled in Edit->Preference.

I deleted summary and summary-meta files then restarted evolutiion, it fetched summary then it applied filter rules in Inbox and all incoming messages there-on.

Joe MacDonald (joeythesaint) wrote :

I upgraded to Hardy a few weeks ago in hopes of fixing another problem I had, but I've noticed that after the upgrade, all my filters are being applied now as new mail arrives. So I'd say it's been fixed in the upcoming Ubuntu.

Sebastien Bacher (seb128) wrote :

Can other people having the issue try using hardy and comment on wether they still get the bug there?

Changed in evolution-exchange:
status: Confirmed → Invalid
Changed in evolution-exchange:
status: Unknown → Fix Released

Apparently the bug is fixed in gnome's stable release now. When is the new stable version going to be packaged up for gutsy? I still see the problem on the current 2.12.1 release on gutsy, the most recent stable release of evolution is 2.12.3. As a work around I can delete the summary file and it works for the first session of evolution, if I quit and restart, it stops working. I am currently starting evolution with a script to delete the summary on startup. But this is not very satisfactory.

James Lamb (admin-oranged) wrote :

HI There,

This is working perfectly for me in Hardy. There are many issues I had previously which appear to now be resolved this one being the most notable.

C de-Avillez (hggdh2) wrote :

Fix has been committed upstream, and should be available on next Evolution upload for Hardy.

Changed in evolution-exchange:
status: Triaged → Fix Committed
Sebastien Bacher (seb128) wrote :

new version uploaded

Changed in evolution-exchange:
status: Fix Committed → Fix Released
oudalrich (uhkeller) wrote :

I tried deleting the summary and summary-meta files as described above hoping to get filtering to work with Gutsy. Unfortunately, not only did the filtering remain broken, but now my mails were out of sync with the server. Everything I'd received since yesterday was gone. I could not get it to re-sync. The only thing that worked was putting the old summary and summary-meta files back that I'd deleted. So the message is:

DO NOT DELETE SUMMARY AND/OR SUMMARY-META!

hagai sela (hagai-sela) wrote :

This still happens to me - I set up rules to move messages from mailing lists to a folder. When messages are received they are not moved to that folder, but if I select them and press Ctrl+Y they are moved.
I am using ubuntu 9.04, evolution 2.26.

Hagai.

Matt Keys (mk6032) wrote :

Also confirmed here. I'm using Ubuntu 9.04 amd64, Evolution 2.26.1, and connecting to Microsoft Exchange 2003.

Mathias (mathias-me) wrote :

Also confirmed here.
Automatic move of message does not work, Highlighting message and Ctrl-Y works.

Ubuntu 9.04, i386
Evolution 2.26.1,
Microsoft Exchange 2003

Adam Vinsh (adam-vinsh) on 2009-09-10
Changed in evolution-exchange (Ubuntu):
status: Fix Released → New
status: New → Incomplete
Neil Perry (nperry) wrote :

Upstream bug was fixed back in 2008-02-07. Doing some housekeeping.

Changed in evolution-exchange (Ubuntu):
status: Incomplete → Fix Released
Kristian Kißling (kkissling) wrote :

This bug is still valid for me (Ubuntu 10.04, Evolution 2.28.3).

OmegaPhil (omegaphil) wrote :

Valid for me too. Same version of Evolution.

uname -a:

Linux 2.6.32-24-server #38-Ubuntu SMP Mon Jul 5 10:29:32 UTC 2010 x86_64 GNU/Linux

Gordon Ross (gordon-w-ross) wrote :

I see this as well with Evolution 2.28 on OpenSolaris snv_138 and/or snv_139.

The mail folder hierarchy under my exchange account looks like this:
<email address hidden>
- Personal Folders
- - Inbox
- - Deleted Items
- - Drafts
...

I wonder if the "Personal Folders" level might cause Evolution to
treat "Personal Folders/Inbox" as something other than an inbox?

Changed in evolution-exchange:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.