Evolution Exchange Connector does not appear to work

Bug #105052 reported by JoshuaLutz on 2007-04-10
6
Affects Status Importance Assigned to Milestone
evolution-exchange (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: evolution

When I try to add an exchange account (with either of the two exchange servers I use) I cannot click the next button on the setup dialog.

The first system appears to authenticate but doesn't enable "next" but the second system continues to kick back my password, despite trying every combination of username/password possible.

This is Feisty, Evolution 2.10.1

ProblemType: Bug
Architecture: i386
Date: Tue Apr 10 01:34:31 2007
DistroRelease: Ubuntu 7.04
ExecutablePath: /usr/bin/evolution-2.10
Package: evolution 2.10.1-0ubuntu1
PackageArchitecture: i386
ProcCmdline: evolution --component=mail
ProcCwd: /home/taggie
ProcEnviron:
 PATH=/home/taggie/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: evolution
Uname: Linux taggie-laptop 2.6.20-14-generic #2 SMP Mon Apr 2 20:37:49 UTC 2007 i686 GNU/Linux

JoshuaLutz (josh-lutz) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug, do you have anything written to .xsession-errors when you get it?

Changed in evolution:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: Unconfirmed → Needs Info
Daniel Holbach (dholbach) wrote :

As described in the previous comments, your report lacks the information we need to investigate the problem further. We'll close this report for now - please reopen it if you can give us the missing information.

Changed in evolution-exchange:
status: Needs Info → Rejected

I ran into the same issue as the original submitter. Unfortunately, the only thing that was written to my .xsession-errors while I tried to create the account was :

(evolution-2.10:17383): e-utils-WARNING **: Cannot resolve symbol 'org_gnome_new_mail_config' in plugin '/usr/lib/evolution/2.10/plugins/liborg-gnome-new-mail-notify.so' (not exported?)
BBDB spinning up...

...which doesn't seem to be related to our problem.

In my case, the issue lies with authentication. During the Feisty development cycle (Herd4 -> release), the Exchange Connector was working correctly, e.g. the "Forward" button was enabled after Exchange confirmed your credentials with the OWA server by using the "Authenticate" button. Since a clean Feisty re-install, I keep getting the following message while trying to authenticate :

Could not authenticate to server
Make sure the username and password are correct and try again.

Note that for some reason, the button "Forward" can be enabled by selecting "IMAP" in the "Server Type" box, entering the server name, clicking "Forward", clicking "Back" then choosing "Microsoft Exchange". That said, the resulting configuration won't work.

Using Feisty with the latest updates. The server I am trying to use is "powered" by Microsoft Exchange 2003.

Reopening the bug report. I am willing to provide the information you might need, since I must use this feature for my work!

Changed in evolution-exchange:
status: Rejected → Needs Info
Pedro Villavicencio (pedro) wrote :

We are closing this bug report as it lacks the information, described in the previous comments, we need to investigate the problem further. However, please reopen it if you can give us the missing information and don't hesitate to submit bug reports in the future.

Changed in evolution-exchange:
status: Incomplete → Invalid
Bill Gjestvang (bgjestvang) wrote :

I don't have this problem on a clean install of Gutsy development releases. Haven't tested a clean install of feisty.

maxadamo (massimilianoadamo) wrote :

I have the same problem (Ubuntu Hardy).

Luckily there is a workaround:
the account shouldn't be set up within Evolution. Evolution can be either closed or open, and from the terminal you should type the command: /usr/bin/exchange-connector-setup-2.22
By doing that you'll get the "next" tab, and you can type in the name of the "catalog" server (namely it's an LDAP server).
The name of this server can be found in Outlook, by opening the address-book, then selecting "global address book", then doing right click on the drop-down menu and choosing properties: you'll get the server name.
As the bug exist, I suggest not to close it.

Changed in evolution-exchange:
status: Invalid → New
Pedro Villavicencio (pedro) wrote :

Is this still an issue with jaunty, may someone test with that version of the package? thanks in advance.

Changed in evolution-exchange:
status: New → Incomplete
maxadamo (massimilianoadamo) wrote :

latest version of Evolution (in Intrepid) seems to be work now.

Bill Gjestvang (bgjestvang) wrote :

Marking "Fix Released", since there have been no reports of this since Feisty, and reports that it does work in Gutsy devel and Intrepid. If anyone is still seeing this, please reopen.

Changed in evolution-exchange (Ubuntu):
status: Incomplete → Fix Released
emdalton (dalton-ubuntu) wrote :

I'm getting this under Jaunty with Evolution 2.26.1. I have been updating regularly. Oddly enough, it was working last week with the new 2007 Exchange servers here, but then stopped. Based on a tip in the bug related to Evolution losing connection with the Exchange server, I switched to the jaunty-proposed updates source, updated everything to do with Evolution, and rebooted. Same problem.

I think it stopped working yesterday, though I put my connection problems down to being offsite, as Outlook hadn't been able to connect to the old Exchange 2003 servers through the external network, either (though I'd been able to connect to those same servers and the new 2007 servers via Evolution from home). But today I'm on the internal network, and I still can't connect. The only hint I can offer is that when I logged into the Exchange server today via the Web version, I got an extra screen during login that asked if I wanted to use the "Accessible" version of the web client. Maybe they enabled a new feature that Evolution can't figure out?

My employer doesn't really support linux desktops, so I don't think I'm going to get much help from IT here. I'll supply whatever debugging info you need to work on this problem, but you may need to point me toward directions on how to collect some of it-- I'm pretty familiar with linux and unix, but my troubleshooting skills are more specific to Solaris, which is System V rather than BSD-based. (I don't seem to have truss or trace on my system.)

The whole reason I updated to Jaunty was to get support for connecting to Exchange 2007, so I hope we can get this figured out. It's pretty maddening that it worked fine a couple of days ago.

Changed in evolution-exchange (Ubuntu):
status: Fix Released → Confirmed
emdalton (dalton-ubuntu) wrote :

Sigh. Sorry, just realized that this bug isn't the one I meant to update. I'm having problems connecting with an existing Evolution/Exchange account, not creating a new one.

Changed in evolution-exchange (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers