Ubuntu

Google Calendar broken : Unable to create calendar object : The calendar doesn't exists

Reported by Jonathan Ernst on 2012-04-11
88
This bug affects 19 people
Affects Status Importance Assigned to Milestone
Evolution
Fix Released
High
evolution (Fedora)
Unknown
Unknown
evolution-data-server (Ubuntu)
High
Mathieu Trudel-Lapierre
Precise
Undecided
Unassigned

Bug Description

[Impact]
Affects any addition of events to Google Calendars; this is limited to calendars using the CalDAV protocol, and only for calendars hosted by Google.

[Development Fix]
Two patches to be backported from Evolution-Data-Server upstream trees 3.4/master. In other words, cherry-picking two patches from the current stable series of Evolution-Data-Server is sufficient, and those can be applied with minimal changes to the 3.2.3 packages.
The first patch supports the second in implementing a slightly different method for updating the slave states for the calendar backend;
The second patch works around the issues specific to Google in the handling of responses from event addition by looking for the added event by UID as an .ics file after receiving a "No such calendar" response.

[Stable Fix]
See "Development Fix".

[Test Case]
See below.

[Regression Potential]
Small. This changes the behavior on received responses for calendar event addition. In the event that responses from a server fail to follow standard CalDAV protocol and results in similar responses to those from Google servers, an additional code path is entered to try and locate the added event by UID.

====

Steps to reproduce :

1) add a new event to one of your google calendar
2) error message shows (translated from French) : Unable to create calendar object : The calendar doesn't exists
3) discard the new event dialog
4) check on the web : the event has been added nevertheless
5) some time after (next evolution sync) : the event appears on evolution

This affects a lot of the users I'm helping with Ubuntu related issues and is the exact same problem described here :

http://ubuntuforums.org/showthread.php?p=11834712

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: evolution 3.2.3-0ubuntu5 [modified: usr/bin/evolution usr/bin/evolution-settings]
ProcVersionSignature: Ubuntu 3.2.0-22.35-generic 3.2.14
Uname: Linux 3.2.0-22-generic x86_64
ApportVersion: 2.0-0ubuntu4
Architecture: amd64
Date: Wed Apr 11 11:13:05 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release Candidate amd64 (20100928)
ProcEnviron:
 TERM=xterm
 PATH=(custom, user)
 LANG=fr_CH.UTF-8
 SHELL=/bin/bash
SourcePackage: evolution
UpgradeStatus: Upgraded to precise on 2012-01-17 (84 days ago)

Jonathan Ernst (jonathan.ernst) wrote :
Jonathan Ernst (jonathan.ernst) wrote :
Changed in evolution:
importance: Unknown → High
status: Unknown → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in evolution (Ubuntu):
status: New → Confirmed
Terry Jones (terryjones1983) wrote :

I have just reproduced this bug

I get the following error when trying to create an event through Evolution to my Google Calender.

'Cannot create calendar object: Calendar does not exist'

Fix committed

Changed in evolution (Ubuntu):
status: Confirmed → Fix Committed
Changed in evolution:
status: New → Fix Released
Changed in evolution (Ubuntu):
status: Fix Committed → Fix Released
Amaeth (dfoxpro) wrote :

I BUMP this bug because the bug still happen in ubuntu (presice and others), the fix release is on Evolution 3.4, and evolution-presice package is the 3.2, so please upgrade the package.

its bug also affects the google Contacts if you connect form evolution (look its not affect the online-accounts system)

Amaeth (dfoxpro) wrote :
Amaeth (dfoxpro) wrote :

This bug persist until the package upgrade to 3.4

AFAIK this isn't actually fixed in the packages in Precise, setting back to Confirmed.

Changed in evolution (Ubuntu):
status: Fix Released → Confirmed
importance: Undecided → High
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
affects: evolution (Ubuntu) → evolution-data-server (Ubuntu)
Changed in evolution-data-server (Ubuntu):
status: Confirmed → In Progress
description: updated

Uploaded to -proposed, waiting for approval...

Hello Jonathan, or anyone else affected,

Accepted evolution-data-server into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in evolution-data-server (Ubuntu Precise):
status: New → Fix Committed
tags: added: verification-needed

Confirmed that this works as expected. I was able to create a new Google Calendar event in Evolution and it appeared in Google Calendar within seconds and with no error. Deleting worked as expected too.

For anyone else wanting to test, add the pin to precise-proposed as per Martin's link and the type the following:

aptitude-update
aptitude install evolution-data-server/precise-proposed evolution-data-server-common/precise-proposed libcamel-1.2-29/precise-proposed

Martin Pitt (pitti) on 2012-05-02
tags: added: verification-done
removed: verification-needed

Confirm fix works for me on precise but eveolution shows me ver.3.2.3 after fresh install. upgrade told me that is already installed last version.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evolution-data-server - 3.2.3-0ubuntu7

---------------
evolution-data-server (3.2.3-0ubuntu7) precise-proposed; urgency=low

  * debian/patches/git_caldav_backend_starve_on_dispose_cf5acf4.patch: backport
    changes to how the slave states are set in EDS from 3.4; to support the
    following patch.
  * debian/patches/lp978728_add_event_in_google_calendar_de60fed.patch: repair
    adding events to Google Calendars; because Google's CalDAV implementation
    appears to not respond with a redirect when an event is added in a
    different place than requested, nor with a Location header in the Created
    response: workaround this to avoid an error when the event really has been
    properly added to the calendar. (LP: #978728)
 -- Mathieu Trudel-Lapierre <email address hidden> Mon, 30 Apr 2012 20:40:22 -0400

Changed in evolution-data-server (Ubuntu):
status: In Progress → Fix Released
Changed in evolution-data-server (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.