'givenName' LDAP attribute not supported

Bug #558999 reported by Ro on 2010-04-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
evolution-data-server (Ubuntu)
Low
Unassigned
Nominated for Lucid by Ro

Bug Description

Binary package hint: evolution-data-server

Evolution does not support the 'givenName' LDAP attribute when using an LDAP addressbook. This renders the use of LDAP-based addressbooks somehow useless, because (1) most other LDAP-Clients support this field and (2) Evolution can't write to an already present LDAP addressbook entry that contains this attribute.

This is a real showstopper since Evolution is one of the few FOSS LDAP clients who can also write to LDAP.

The solution is, however, a simple one-liner. It has been fixed in upstream for 2.30 already, but I'd like to see this fixed for Lucid as well, since Lucid is an LTS which will be used in organiations for quite a while.

Ro (robert-markula) wrote :
Ro (robert-markula) wrote :

Use cases:

(1) John maintains the corporate-wide LDAP addressbook. He wants to use Evolution for this task, since Evolution is one of the rare FOSS LDAP clients that support writing and editing of LDAP contacts. However, he finds out that he can't use Evolution at all, because it keeps silently discarding all the givennames he tediously entered in the contacts details.

(2) In Silvie's organization, every person has his/her own personal addressbook that resides on an LDAP server, so it can be accessed from anywhere without being bound to a specific client. Silvie switches to Linux and wants to use Evolution as a groupware client for her mails, calendars and contacts. Unfortunately she can only view, not edit, her LDAP contacts - as soon as she tries to save an edited LDAP contact, she is confronted with a meaningless error message that only confuses her. Later she finds out that this is because Evolution refuses to write to LDAP contacts that contain the givenName attribute.

In both cases, the (really!) great LDAP addressbook feature of Evolution is rendered completely useless. The small patch from above fixes this issue once and for all.

Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in evolution-data-server (Ubuntu):
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

I did read the comment before the description, seems it's already upstream commited

Ro (robert-markula) wrote :

Hi Sebastien,
thanks for your feedback. I'm the author who originally commited this patch to Evolution upstream. The patch is already part of the official Evolution 2.30 release.

However, since Lucid will ship with Evolution 2.28.3, I'd like to ask if you could apply this patch to 2.28.3 before the Lucid release? I fear that it might not get integrated in time, which will cause headaches for every organisation wanting to use LDAP addressbooks, because what's an addressbook worth without the ability to store the given name? On top of that worries, Lucid is an LTS (which means this nasty little bug will be plaguing people for a looong time)...

Sebastien Bacher (seb128) wrote :

did you try this change on the current lucid version? it seems not an issue to get it before lucid but would be nice to get somebody confirming it's working as it should. You seem to also insist on the fact that ldap is not very useful without it but it seems that's nothing evolution didn't do until now and nobody complained in all those years so it other users might not have the same needs as you have there. Not to argue about whether we should get the issue fixed in lucid or not but try to rate the issues over what they are could create discussions rather than convince triagers...

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evolution-data-server - 2.28.3.1-0ubuntu2

---------------
evolution-data-server (2.28.3.1-0ubuntu2) lucid; urgency=low

  * debian/patches/91_git_change_ldap_given_name.patch:
    - upstream git change to support the ldap given name use
      (lp: #558999)
 -- Sebastien Bacher <email address hidden> Thu, 15 Apr 2010 00:26:35 +0200

Changed in evolution-data-server (Ubuntu):
status: New → Fix Released
Ro (robert-markula) wrote :

Hi Sebastien,
you're right, sorry for being over-enthusiastic about that.

<offtopic>It's just one of these things that I always get asked when talking to companies about linux adoption: "does Linux have a decent groupware"? With "decent" most of them associate not only quality, but also a FOSS character, so things are quite limited. It only gets more limited when they want to see a (FOSS) fat client à la Outlook - because the almost only "decent" solution out there is Evolution. And the most reasonable way to use central addressbooks is LDAP. That's why I was so persuading about this bug.<offtopic>

Thanks anyway for getting back to me!

Ro (robert-markula) wrote :

Confirmed to be working perfectly on Lucid RC.

Thanks Sebastien for fixing this bug!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers