Uses 100% CPU

Bug #538849 reported by Kristopher Ives on 2010-03-14
46
This bug affects 9 people
Affects Status Importance Assigned to Milestone
evolution-data-server
Fix Released
Critical
evolution-data-server (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: evolution-data-server

Sometimes I'll catch evolution-data-server taking up all the CPU. I don't use Evolution for anything, and I've never put any data into that system or have any kind of account linked with it. I think this bug is different than other bugs that are related to logging in or using evolution, since it usually happens after my session has been active for a long time.

Package version 2.28.3.1-0ubuntu1

Michael Terry (mterry) wrote :

I do use Evolution, and I get the same thing. It will just be sitting there in the background, and I'll notice one of my two cores is maxed. I can still use Evolution fine. When I do a 'top', I see that evolution-data-server is the culprit. I run 'evolution --force-shutdown', open it again, and I'm good to go for another hour or so, when it happens again.

What useful logs or information can I provide?

Changed in evolution-data-server (Ubuntu):
status: New → Confirmed
Klaus Doblmann (moviemaniac) wrote :

Same here - this is really, really annoying and basically renders evolution useless for now!

Klaus Doblmann (moviemaniac) wrote :

Also notice these bugreports - it is actually a gnome-keyring problem:

https://bugzilla.gnome.org/show_bug.cgi?id=606902
https://bugzilla.gnome.org/show_bug.cgi?id=595421

Kristopher Ives (krisives) wrote :

Just wanted to update and let everyone know that this hasn't happened to me recently. My version of evolution-data-server is the same, but I suspect my version of gnome-keyring has bumped. I'm fully updated as of today (Mar 28, 2010) on Ubuntu 10.4 upgraded from 9.10

Bram Bonné (brambonne) wrote :

This still seems to be happening to me in Lucid.

Klaus Doblmann (moviemaniac) wrote :

Same here!

Russel Winder (russel) wrote :

Please can this be made a blocking bug for releasing Lucid, it makes Evolution unusable on Lucid.

I am getting this even after a full update as at 2010-04-01T06:30+00:00

Russel Winder (russel) wrote :

Not actual data, but a tentative hypothesis based on memory of past behaviour: does the problem only happen after sending an email?

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a backtrace following the instructions at http://wiki.ubuntu.com/DebuggingProgramCrash and upload the backtrace (as an attachment) to the bug report. This will greatly help us in tracking down your problem.

Changed in evolution-data-server (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Klaus Doblmann (moviemaniac) wrote :

@Russell: No, it also happened when no mail was being sent. I'm using the past because I got rid of Evolution now (because of this bug, another one involving evolution to hang when a tiff is being previewed and the generally poor performance when handling large amounts of mails) and switched to Sylpheed - something I should've done a few years ago. It's incredible how much Sylpheed is faster - we're speaking operations taking place in the blink of an eye versus taking 10+ seconds like opening folders with tens of thousands of mails in it.

@Sebastien: As I uninstalled Evolution I can't provide backtraces but take a look at this bugreport, there's a workaround posted: https://bugzilla.gnome.org/show_bug.cgi?id=606902
and here are a few backtraces: https://bugzilla.gnome.org/show_bug.cgi?id=595421

Hiroyuki Ikezoe (ikezoe) wrote :

Klaus, Sebastien definitely knows about those upstream bugs because he has already applied the workaround patch for https://bugzilla.gnome.org/show_bug.cgi?id=606902 to libgnome-keyring package. If your problem is the same as the issue happened to me, the problem must have gone.

Please reinstall evo and confirm whether the problem is solved or not. If your problem is still there, we also have to solve it.

Klaus Doblmann (moviemaniac) wrote :

If the patch is applied then I take it for granted the bug is resolved - for now. There are others affected by it who can confirm this - I can't reinstall evolution and let it run for a few days as it would mess up my mail-archive (I'm getting several hundred a day and I want these in one database in one program - receiving them via pop would let them end up in the evolution database from where I'd have to manually copy them over to sylpheed...)

Changed in evolution-data-server:
status: Unknown → Fix Released
Changed in evolution-data-server:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.