evolution crashed with SIGSEGV in gnome-keyring code

Bug #530760 reported by Bowmore on 2010-03-02
118
This bug affects 33 people
Affects Status Importance Assigned to Milestone
evolution-data-server
Fix Released
Critical
libgnome-keyring
Fix Released
Critical
evolution-data-server (Ubuntu)
Medium
Unassigned
Lucid
Low
Sebastien Bacher
libgnome-keyring (Ubuntu)
Low
Unassigned
Lucid
Low
Sebastien Bacher

Bug Description

Binary package hint: evolution

I'm using Ubuntu 10.04 and Evolution 2.28.3

Crashes occurres contantly after some time (minutes) when running evolution.
Tested on three different Lucid installations with same behaviour.

ProblemType: Crash
Architecture: i386
CrashCounter: 1
Date: Tue Mar 2 15:05:58 2010
DistroRelease: Ubuntu 10.04
ExecutablePath: /usr/bin/evolution
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100224.1)
Package: evolution 2.28.3-0ubuntu2
ProcCmdline: evolution
ProcCwd: /home/rolf
ProcEnviron:
 PATH=(custom, user)
 LANG=sv_SE.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-14.20-generic
SegvAnalysis:
 Segfault happened at: 0x6ce39a: mov 0x4(%esi),%eax
 PC (0x006ce39a) ok
 source "0x4(%esi)" (0x00000005) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: evolution
StacktraceTop:
 ?? () from /lib/libdbus-1.so.3
 ?? () from /lib/libdbus-1.so.3
 ?? () from /lib/libdbus-1.so.3
 dbus_timeout_handle () from /lib/libdbus-1.so.3
 ?? () from /usr/lib/libgnome-keyring.so.0
Title: evolution crashed with SIGSEGV in dbus_timeout_handle()
Uname: Linux 2.6.32-14-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Bowmore (bowmore) wrote :

This crash has the same stack trace characteristics as bug #358458. However, the latter was already fixed in an earlier package version than the one in this report. This might be a regression or because the problem is in a dependent package.

tags: added: regression-retracer
tags: removed: need-i386-retrace
Bowmore (bowmore) on 2010-04-04
visibility: private → public

Thank you taking the time to report this bug and helping to make Ubuntu better. However, processing the crash report to get detailed information for the developers failed as the retracer did not generate a useful symbolic stack trace.
Please try to obtain a backtrace manually following the instructions at http://wiki.ubuntu.com/DebuggingProgramCrash and upload the backtrace (as an attachment) to the bug report. This will greatly help us in tracking down your problem.

Changed in evolution (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

Changed in evolution (Ubuntu):
status: Incomplete → Invalid
Nicolas DERIVE (kalon33) wrote :

Hello Pedro, here is a stacktrace of the problem. Reopening.

Changed in evolution (Ubuntu):
status: Invalid → Confirmed
Sebastien Bacher (seb128) wrote :

could you get one with libc6-dbg and libglib2.0-0-dbg installed?

Changed in evolution (Ubuntu):
status: Confirmed → Incomplete
Nicolas DERIVE (kalon33) wrote :

Hi seb128, here is what you asked. Reopening.

Changed in evolution (Ubuntu):
status: Incomplete → Confirmed
affects: evolution (Ubuntu) → gnome-keyring (Ubuntu)
affects: gnome-keyring (Ubuntu) → evolution-data-server (Ubuntu)
Changed in evolution-data-server (Ubuntu):
status: Confirmed → Fix Committed
Changed in evolution-data-server (Ubuntu Lucid):
assignee: nobody → Sebastien Bacher (seb128)
importance: Undecided → Low
status: New → Fix Committed
Sebastien Bacher (seb128) wrote :
summary: - evolution crashed with SIGSEGV in dbus_timeout_handle()
+ evolution crashed with SIGSEGV in gnome-keyring code
Sebastien Bacher (seb128) wrote :

let's see if http://git.gnome.org/browse/evolution-data-server/commit/?h=gnome-2-30&id=90a6ead715e47e3df9291c7fbee9bafbee10c144 is fixed the issue, I've uploaded that as a lucid stable update candidate now, it still need to be accepted though

Sebastien Bacher (seb128) wrote :

There is clearly a bug in libgnome-keyring as well there

Changed in libgnome-keyring (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Changed in libgnome-keyring (Ubuntu Lucid):
importance: Undecided → Low
status: New → Triaged
Changed in libgnome-keyring:
status: Unknown → Invalid
Jesse Raleigh (j-jraleigh) wrote :

This issue has severely impacted my ability to use Evolution for email for over a month now. I appreciate all the work folks are putting in to getting this resolved.

Sebastien Bacher (seb128) wrote :

Could those having the issue get a stacktrace and a valgrind log with libgnome-keyring0-dbgsym libdbus-1-3-dbgsym libedataserverui1.2-8-dbgsym installed?

Sebastien Bacher (seb128) wrote :

the issue is fixed in the maverick version

Changed in evolution-data-server (Ubuntu):
status: Fix Committed → Fix Released
Changed in libgnome-keyring:
status: Invalid → Unknown
Changed in libgnome-keyring (Ubuntu Lucid):
assignee: nobody → Sebastien Bacher (seb128)
status: Triaged → Fix Committed
Changed in libgnome-keyring (Ubuntu):
status: Triaged → Fix Committed
Changed in libgnome-keyring:
status: Unknown → Fix Released
Sebastien Bacher (seb128) wrote :
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libgnome-keyring - 2.30.1-1ubuntu1

---------------
libgnome-keyring (2.30.1-1ubuntu1) maverick; urgency=low

  * debian/patches/90_git_is_available_crash.patch:
    - git change to fix a crasher in gnome_keyring_is_available()
      (lp: #530760)
 -- Sebastien Bacher <email address hidden> Wed, 23 Jun 2010 12:04:43 +0200

Changed in libgnome-keyring (Ubuntu):
status: Fix Committed → Fix Released
happyisland (david-meteoric) wrote :

Nice! Hopefully this will solve all of our problems. This might be a beginnerish kind of question, but when can we expect to see the fixed package in the ubuntu repos?

Thanks for the fix!

Accepted evolution-data-server into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Martin Pitt (pitti) wrote :

Accepted libgnome-keyring into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Evolution is still crashing even after the update.
Bill Phillips

On Fri, 2010-06-25 at 11:25 +0000, Launchpad Bug Tracker wrote:

> ** Branch linked: lp:ubuntu/lucid-proposed/evolution-data-server
>

Sebastien Bacher (seb128) wrote :

which update? there has been 2 updates on the bug

Bowmore (bowmore) wrote :

Installing evolution-data-server 2.28.3.1-0ubuntu5 from lucid-proposed seems to solve my crash problems.

Before I could reduce the crash frequency by only having one or two mail accounts active.

After installing evolution-data-server 2.28.3.1-0ubuntu5 I've run Evolution 15 hours by now with five accounts active searching for new messages each and every minute with no crashes so far. That's quite an improvement ;)

Installed fixes:
libgnome-keyring0 2.30.1-0ubuntu1
evolution-data-server 2.28.3.1-0ubuntu5

Frédéric CORNU (fcornu) wrote :

Hi,

after having installed these 2 upgrades :

libgnome-keyring0 2.30.1-0ubuntu1
evolution-data-server 2.28.3.1-0ubuntu5

Evolution still crashes several times a day ...

Sebastien Bacher (seb128) wrote :

> Installing evolution-data-server 2.28.3.1-0ubuntu5 from lucid-proposed seems to solve my crash problems.

> Evolution still crashes several times a day ...

So it seems this bug is a collection of different issues, not easy to work through those. Could users still have a bug after those updates open a new bug report? Let's say this ticket is about the issue addressed with the recent updates

So Far Evolution has remained stable since my last update....Thankyou!
Bill Phillips

On Mon, 2010-06-28 at 10:12 +0000, Sebastien Bacher wrote:

> > Installing evolution-data-server 2.28.3.1-0ubuntu5 from lucid-proposed
> seems to solve my crash problems.
>
> > Evolution still crashes several times a day ...
>
>
> So it seems this bug is a collection of different issues, not easy to work through those. Could users still have a bug after those updates open a new bug report? Let's say this ticket is about the issue addressed with the recent updates
>

Frédéric CORNU (fcornu) wrote :

Le lundi 28 juin 2010 à 10:12 +0000, Sebastien Bacher a écrit :
> > Installing evolution-data-server 2.28.3.1-0ubuntu5 from lucid-proposed
> seems to solve my crash problems.
>
> > Evolution still crashes several times a day ...
>
>
> So it seems this bug is a collection of different issues, not easy to work through those. Could users still have a bug after those updates open a new bug report? Let's say this ticket is about the issue addressed with the recent updates
>

Hi,

Why not keeping on working on bug #578864 to which I attached a
stacktrace and a valgrind log ?

cheers,

--
Fred

Sebastien Bacher (seb128) wrote :

> Why not keeping on working on bug #578864 to which I attached a stacktrace and a valgrind log ?

because bug #578864 is the same issue than the one described and fixed there and that would email spam the submitter with comments discussing your issue which is a different one, it would also mix several issues on that bug and make it harder to work with, would be easier to open a new bug with updated stacktrace and valgrind logs with current updates installed

Pedro Villavicencio (pedro) wrote :

I cannot reproduce the original crash but I've been using both packages for a few days already and did not noticed any regressions so far. Marking this as verification done. Also, as Sebastien said please open new bug reports if you think you're getting a similar crash let us to determine if that's actually the same crash or not, Thanks in advance!.

tags: added: verification-done
removed: verification-needed
Michele (mikelito) wrote :

just wanted to report that I installed the updated packages, and had no crash during the past two days.
probably evolution will die on me within the next 10 minutes, but as of now, the bug seems to be gone for me.
provisional thanks for most likely having fixed this!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evolution-data-server - 2.28.3.1-0ubuntu5

---------------
evolution-data-server (2.28.3.1-0ubuntu5) lucid-proposed; urgency=low

  * debian/patches/92_git_gnomekeyring_crasher.patch:
    - git change to fix a crasher in the gnome-keyring passwords handling
      (lp: #530760)
 -- Sebastien Bacher <email address hidden> Mon, 21 Jun 2010 18:05:18 +0200

Changed in evolution-data-server (Ubuntu Lucid):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libgnome-keyring - 2.30.1-0ubuntu1

---------------
libgnome-keyring (2.30.1-0ubuntu1) lucid-proposed; urgency=low

  * New upstream version
  * debian/patches/90_git_is_available_crash.patch:
    - git change to fix a crasher in gnome_keyring_is_available()
      (lp: #530760)
  * debian/patches/02_workaround_cpu_use.patch:
    - dropped, the change is in the new version
 -- Sebastien Bacher <email address hidden> Tue, 22 Jun 2010 19:35:06 +0200

Changed in libgnome-keyring (Ubuntu Lucid):
status: Fix Committed → Fix Released
Changed in evolution-data-server:
importance: Unknown → Critical
status: Unknown → Fix Released
Changed in libgnome-keyring:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.