evolution assert failure: camel:ERROR:camel-net-utils.c:516:cs_waitinfo: assertion failed: (reply == msg)

Bug #475147 reported by Georg Jung on 2009-11-05
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Evolution
Fix Released
Critical
evolution-data-server (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: evolution

While working with other programs, evolution ended itself and a crash report was issued. The crash was completely spontaneous, no action could be linked with it. I'm running karmic (9.10), and evolution-2.28.1-0ubuntu1 on a lenovo thinkpad x200s

ProblemType: Crash
Architecture: amd64
AssertionMessage: camel:ERROR:camel-net-utils.c:516:cs_waitinfo: assertion failed: (reply == msg)
CheckboxSubmission: e1bddd0bf477467b54484fb296936441
CheckboxSystem: 3f0d9172400f9b58c0b8c3b4ea0cc35b
CrashCounter: 1
Date: Thu Nov 5 08:03:48 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/evolution
Package: evolution 2.28.1-0ubuntu1
ProcCmdline: evolution --component=mail
ProcEnviron:
 LANGUAGE=de_DE.UTF-8
 PATH=(custom, user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
Signal: 6
SourcePackage: evolution
StacktraceTop:
 raise () from /lib/libc.so.6
 abort () from /lib/libc.so.6
 g_assertion_message () from /lib/libglib-2.0.so.0
 g_assertion_message_expr ()
 ?? () from /usr/lib/libcamel-1.2.so.14
Title: evolution assert failure: camel:ERROR:camel-net-utils.c:516:cs_waitinfo: assertion failed: (reply == msg)
Uname: Linux 2.6.31-14-generic x86_64
UserGroups: adm admin audio cdrom dialout dip fax floppy fuse lpadmin netdev plugdev sambashare tape vboxusers video

Georg Jung (georgjung) wrote :

StacktraceTop:*__GI_raise (sig=<value optimized out>)
*__GI_abort () at abort.c:92
g_assertion_message () from /lib/libglib-2.0.so.0
g_assertion_message_expr ()
cs_waitinfo (

Changed in evolution (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Pedro Villavicencio (pedro) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at:
 https://bugzilla.gnome.org/show_bug.cgi?id=601252

summary: - evolution crashes spontaneously
+ evolution assert failure: camel:ERROR:camel-net-utils.c:516:cs_waitinfo:
+ assertion failed: (reply == msg)
Changed in evolution (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
status: New → Triaged
visibility: private → public
Daniel Harvey (daniel.harvey) wrote :

Note that the Gnome bug report suggests this bug might be a duplicate of bug #455020 (and its upstrem gnome-bugs #600322).

affects: evolution (Ubuntu) → evolution-data-server (Ubuntu)
Changed in evolution-data-server (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evolution-data-server - 2.28.3-0ubuntu1

---------------
evolution-data-server (2.28.3-0ubuntu1) lucid; urgency=low

  * New upstream version:
    Bug Fixes:
    - #602723 - Contact list name doesn't get displayed in 'To' dialog
    - #600322 - assertion failed: (reply == msg) in cs_waitinfo()
                (lp: #455020, #475147)
    - #564727 - Few memory leaks (lp: #305428)
    - #574940 - Always ref returned info from message_info_from_uid
                (lp: #341909)
    - #429317 - Use the relative URI returned if the server
                re-directs a request
    - #602820 - Test validity of a book_view before using it in LDAP
    - #590762 - Recurring google calendar items are not changeable
    - #604236 - Slow GPG processing
    - #597816 - Do not crash on incorrect parameters used in sexp to SQL
                (lp: #444177)
    - #604544 - Try Exchange fallback authentication only once
    - #600778 - Fix --enable-e2k-debug configure option resolution
    - #260407 - 'endswith' address book search doesn't work
    - #549221 - (bnc) delete, sync flags immediately
  * debian/patches/99_reconfigure.patch:
    - new version update
 -- Sebastien Bacher <email address hidden> Mon, 01 Mar 2010 22:47:15 +0100

Changed in evolution-data-server (Ubuntu):
status: Fix Committed → Fix Released
Changed in evolution:
status: Unknown → Fix Released
Changed in evolution:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.