evolution crashed with SIGSEGV in vfprintf()

Bug #444177 reported by Shaji N V on 2009-10-06
48
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Evolution
Fix Released
Critical
evolution-data-server (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: evolution

Evolution crashes after a minute of start up. I have two imap accounts configured.

ProblemType: Crash
Architecture: i386
Date: Tue Oct 6 06:58:31 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/evolution
NonfreeKernelModules: nvidia
Package: evolution 2.28.0-0ubuntu3
ProcCmdline: evolution --component=mail
ProcEnviron:
 LANG=en_IN
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-11.36-generic
SegvAnalysis:
 Segfault happened at: 0x51074b1 <vfprintf+14705>: repnz scas %es:(%edi),%al
 PC (0x051074b1) ok
 source "%es:(%edi)" (0x20736ce0) not located in a known VMA region (needed readable region)!
 destination "%al" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: evolution
StacktraceTop:
 vfprintf () from /lib/tls/i686/cmov/libc.so.6
 __vasprintf_chk () from /lib/tls/i686/cmov/libc.so.6
 g_vasprintf () from /lib/libglib-2.0.so.0
 g_strdup_vprintf () from /lib/libglib-2.0.so.0
 g_strdup_printf () from /lib/libglib-2.0.so.0
Title: evolution crashed with SIGSEGV in vfprintf()
Uname: Linux 2.6.31-11-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Shaji N V (nvshaji) wrote :
Pedro Villavicencio (pedro) wrote :

Thanks for your bug report. Please try to obtain a backtrace http://wiki.ubuntu.com/DebuggingProgramCrash and attach the file to the bug report. This will greatly help us in tracking down your problem.

Changed in evolution (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete
Shaji N V (nvshaji) wrote :

Attached the backtrace with debug symbols for libcamel. please let me know if you need more debug symbols to be turned on.

Shaji N V (nvshaji) wrote :

Added again removing the email ids in the log

Shaji N V (nvshaji) on 2009-10-07
Changed in evolution (Ubuntu):
status: Incomplete → New
Pedro Villavicencio (pedro) wrote :

Thanks Shaji, any chance to install the evolution-data-server, libglib2, libgtk2, evolution dbgsym packages and get a new backtrace? the one you submitted previously is missing some symbols there, thanks.

Changed in evolution (Ubuntu):
status: New → Incomplete
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
Shaji N V (nvshaji) wrote :

Attached with all the symbols.

Changed in evolution (Ubuntu):
status: Incomplete → New
Pedro Villavicencio (pedro) wrote :

Thank Shaji, I've sent this upstream at: https://bugzilla.gnome.org/show_bug.cgi?id=597816

Changed in evolution (Ubuntu):
status: New → Triaged
Rick (rickledford) wrote :

I have one imap account configured and am running AMD64 x 4.
I have been running Ubuntu 9.10 for abou t1 week without getting this crash...

Please answer the comment from upstream:
>>>
It is trying to build a search folder, which seems to be broken for some
reason. Was this only an accidental crash of is it reproducible on the machine?
<<<

Changed in evolution (Ubuntu):
status: Triaged → Incomplete

I'm unable to reproduce any errors as i've nuked my upgraded 9.10
install in favour of a clean install off the CD.

Sorry i can't help anymore; but this is a work machine and i coudn't
afford the downtime.

Jules

2009/11/22 Martin Mai <email address hidden>:
> Please answer the comment from upstream:
>>>>
> It is trying to build a search folder, which seems to be broken for some
> reason. Was this only an accidental crash of is it reproducible on the machine?
> <<<
>
> ** Changed in: evolution (Ubuntu)
>       Status: Triaged => Incomplete
>
> --
> evolution crashed with SIGSEGV in vfprintf()
> https://bugs.launchpad.net/bugs/444177
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in The Evolution Mail & Calendaring Tool: Unknown
> Status in “evolution” package in Ubuntu: Incomplete
>
> Bug description:
> Binary package hint: evolution
>
> Evolution crashes after a minute of start up. I have two imap accounts configured.
>
> ProblemType: Crash
> Architecture: i386
> Date: Tue Oct  6 06:58:31 2009
> DistroRelease: Ubuntu 9.10
> ExecutablePath: /usr/bin/evolution
> NonfreeKernelModules: nvidia
> Package: evolution 2.28.0-0ubuntu3
> ProcCmdline: evolution --component=mail
> ProcEnviron:
>  LANG=en_IN
>  SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.31-11.36-generic
> SegvAnalysis:
>  Segfault happened at: 0x51074b1 <vfprintf+14705>:      repnz scas %es:(%edi),%al
>  PC (0x051074b1) ok
>  source "%es:(%edi)" (0x20736ce0) not located in a known VMA region (needed readable region)!
>  destination "%al" ok
> SegvReason: reading unknown VMA
> Signal: 11
> SourcePackage: evolution
> StacktraceTop:
>  vfprintf () from /lib/tls/i686/cmov/libc.so.6
>  __vasprintf_chk () from /lib/tls/i686/cmov/libc.so.6
>  g_vasprintf () from /lib/libglib-2.0.so.0
>  g_strdup_vprintf () from /lib/libglib-2.0.so.0
>  g_strdup_printf () from /lib/libglib-2.0.so.0
> Title: evolution crashed with SIGSEGV in vfprintf()
> Uname: Linux 2.6.31-11-generic i686
> UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
>

--
Kind regards, Jules

Zen left me, then I remembered, nothing to forget.

Shaji N V (nvshaji) wrote :

It was not an accidental one, I could reproduce the problem everytime. As mentioned by upstream, I figured out that it was due to my search folders and managed to delete them (pressed delete immediately upon start). After deleting the search folders I could not reproduce the problem. Evolution was upgraded from Jaunty - I guess this could be reproducible if you try to upgrade from Jaunty to Karmic with search folders - but I have not verified it as this is the only system that I have. If no one has the problem, I guess this can be closed - but I would be great if evolution can add checks to prevent crashes like this though.

Changed in evolution (Ubuntu):
status: Incomplete → New

Thanks. I put copied your comment to the upstream bug. Setting back to triaged.

Changed in evolution (Ubuntu):
status: New → Triaged

That's fixed upstream now.

Changed in evolution (Ubuntu):
status: Triaged → Fix Committed
affects: evolution (Ubuntu) → evolution-data-server (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evolution-data-server - 2.28.3-0ubuntu1

---------------
evolution-data-server (2.28.3-0ubuntu1) lucid; urgency=low

  * New upstream version:
    Bug Fixes:
    - #602723 - Contact list name doesn't get displayed in 'To' dialog
    - #600322 - assertion failed: (reply == msg) in cs_waitinfo()
                (lp: #455020, #475147)
    - #564727 - Few memory leaks (lp: #305428)
    - #574940 - Always ref returned info from message_info_from_uid
                (lp: #341909)
    - #429317 - Use the relative URI returned if the server
                re-directs a request
    - #602820 - Test validity of a book_view before using it in LDAP
    - #590762 - Recurring google calendar items are not changeable
    - #604236 - Slow GPG processing
    - #597816 - Do not crash on incorrect parameters used in sexp to SQL
                (lp: #444177)
    - #604544 - Try Exchange fallback authentication only once
    - #600778 - Fix --enable-e2k-debug configure option resolution
    - #260407 - 'endswith' address book search doesn't work
    - #549221 - (bnc) delete, sync flags immediately
  * debian/patches/99_reconfigure.patch:
    - new version update
 -- Sebastien Bacher <email address hidden> Mon, 01 Mar 2010 22:47:15 +0100

Changed in evolution-data-server (Ubuntu):
status: Fix Committed → Fix Released
Changed in evolution:
importance: Unknown → Critical
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.