Ekiga destroys Evolution address book

Bug #366470 reported by Pete Torgenrud on 2009-04-25
4
Affects Status Importance Assigned to Milestone
Ekiga
Expired
Critical
evolution-data-server
Expired
Critical
evolution-data-server (Ubuntu)
High
Ubuntu Desktop Bugs

Bug Description

Binary package hint: ekiga

Jaunty, Ekiga 3.2.0.

I decided to import contacts from Thunderbird to Evolution because Ekiga can use supposedly use these addresses. So I spent some time getting things organized, no problem. Then I configure Ekiga and take a look at the addressbook. Didn't change anything using Ekiga, just took a look. Then I closed Ekiga, did some other stuff and then I needed an Evolution contacts. Nothing there. Ekiga messed them up. addressbook.db and addressbook.db.summary are still there, but Evolution can't read them properly.

Yes, it's reproducible. I stupidly went through the process of importing my contacts twice before realizing that Ekiga was the problem.

Wow.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/ekiga
Package: ekiga 3.2.0-0ubuntu1
ProcEnviron:
 PATH=(custom, user)
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
SourcePackage: ekiga
Uname: Linux 2.6.28-11-generic i686

Andreas Moog (ampelbein) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at: http://bugzilla.gnome.org/show_bug.cgi?id=580531

Changed in ekiga (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → High
status: New → Triaged
Changed in ekiga:
status: Unknown → New
Changed in ekiga (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
Yannick Defais (sevmek) on 2009-08-06
Changed in ekiga:
status: New → Invalid
Pedro Villavicencio (pedro) wrote :

comment from upstream:

"Ekiga doesn't *write* in the addressbook unless asked to ; it merely reads from
it, using evolution-data-server.

Pushing to e-d-s, since the problem is certainly there."

affects: ekiga (Ubuntu) → evolution-data-server (Ubuntu)
Changed in evolution-data-server (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
Changed in ekiga:
importance: Unknown → Critical
status: Invalid → New
Changed in evolution-data-server:
importance: Unknown → Critical
status: Unknown → New
Debra Virden (teddydlv) on 2013-02-04
description: updated
Changed in ekiga:
status: New → Expired
Changed in evolution-data-server:
status: New → Expired
Sebastien Bacher (seb128) wrote :

Upstream tested with a recent version and said it seems to be fixed there

Changed in evolution-data-server (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.