evolution-data-server eats memory like crazy

Bug #305428 reported by Andreas Schultz on 2008-12-05
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
evolution-data-server
Fix Released
Critical
evolution-data-server (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: evolution-data-server

e-d-s grows to 1.5G memory use after about 1day:

top - 11:38:46 up 4 days, 0 min, 12 users, load average: 1.35, 0.78, 0.66
Tasks: 200 total, 2 running, 197 sleeping, 0 stopped, 1 zombie
Cpu(s): 9.0%us, 5.1%sy, 0.0%ni, 85.7%id, 0.2%wa, 0.0%hi, 0.0%si, 0.0%st
Mem: 3987720k total, 3835328k used, 152392k free, 80600k buffers
Swap: 7992296k total, 13144k used, 7979152k free, 766836k cached

  PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
 8229 aschultz 20 0 1530m 1.1g 7912 S 0 29.5 0:49.86 evolution-data-
 7716 root 20 0 385m 228m 97m S 3 5.9 28:52.24 Xorg

i'll try to get a valgrind report...

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/lib/evolution/evolution-data-server-2.24
NonfreeKernelModules: nvidia
Package: evolution-data-server 2.24.2-0ubuntu1
ProcEnviron:
 LANG=en_US.UTF-8
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 SHELL=/bin/bash
SourcePackage: evolution-data-server
Uname: Linux 2.6.27-10-generic x86_64

Andreas Schultz (aschultz) wrote :
Andreas Schultz (aschultz) wrote :

1st try at a valgrind log. did run for about 20min.

some debug packages are missing, i'll install some more and try again

Any other hints?

Chris Coulson (chrisccoulson) wrote :

Thank you for your bug report. your valgrind log is showing some minor leaks, but nothing on the scale that you mentioned in the original bug description.

Could you please try with a new user profile to see if that exhibits the same behaviour?

Thanks

Changed in evolution-data-server:
status: New → Incomplete
Andreas Schultz (aschultz) wrote :

The profile i'm using is about 20 days old, does this still count as new?

Of course, the two IMAP accounts contain about 5 year worth of email, all sub-folder together are more than 50k messages.

In the meantime, i have a new valgrind log, definitely lost: 331kByte, indirectly lost: 25MByte. valgrind actually terminated e-d-s with Address 0xaaaaaaaaaaaaaaaa is not stack'd, malloc'd or (recently) free'd.

This log still lacks the symbols for the orbit lib, but i could not find any -dbg packet for them, any hints?

I can confirm this bug. It seems that evolution-data-server process gets bigger and bigger as you close and start again Evolution. Doing this several times in the day will make evolution-data-server eat more than 2 GB of memory, which will also make the system have an error during the hibernation, with some more serious consequences like data losses.

Andreas Schultz (aschultz) wrote :

after 2 days running evolution with no restart or actuin (over the weekend), e-d-s is eating 3G of memory now. It did run under valgrind, but valgrind itself crached when e-d-s terminated, so no traces :-(

The only output i got from it was:
==14646== malloc/free: in use at exit: 991,235,589 bytes in 15,872,136 blocks.
==14646== malloc/free: 61,028,991 allocs, 45,156,855 frees, 5,557,700,510 bytes allocated.
==14646==
==14646== searching for pointers to 15,872,136 not-freed blocks.
==14646== checked 97,791,304 bytes.

right before exit:

$ cat /proc/14646/status
Name: memcheck
State: S (sleeping)
Tgid: 14646
Pid: 14646
PPid: 32068
TracerPid: 0
Uid: 1003 1003 1003 1003
Gid: 2000 2000 2000 2000
FDSize: 1024
Groups: 4 20 24 25 29 30 40 44 46 60 102 105 108 115 118 121 128 129 133 1000 1001 1002 1003 2000 2001 8645 50935 61719
VmPeak: 3940232 kB
VmSize: 3940232 kB
VmLck: 0 kB
VmHWM: 2625868 kB
VmRSS: 2625868 kB
VmData: 3735460 kB
VmStk: 84 kB
VmExe: 1632 kB
VmLib: 18544 kB
VmPTE: 7524 kB
Threads: 11

I noticed that moving a message (and especially moving several messages at once) from one IMAP folder to another (on the same IMAP-server) causes evolution often to eat up all memory available in a very short time (about 30 seconds). I also think that if you are connected to an IMAP server already an moving meanwhile a message inside the IMAP server result in the same problem.

The only solution I have found so far is killing evolution as fast as possible and restarting it. This behavior is not deterministic but very good reproduceable. (Moving the same message from a particular folder to another one result sometimes in this memory hog and sometimes not.) Therefore it looks like a race condition somehow.

I have the evolution-data-server 2.22.3-0ubuntu2 however. (evolution is 2.22.3.1-0ubuntu1)

Sebastien Bacher (seb128) wrote :

could somebody having the issue open the bug to bugzilla.gnome.org where the people writting the software will read it?

Changed in evolution-data-server:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: Incomplete → New
Chris Coulson (chrisccoulson) wrote :

I've sent this upstream. Could those experiencing the bug please subscribe to the upstream report, as it will almost certainly require more information from you.

Changed in evolution-data-server:
status: New → Triaged
Chris Coulson (chrisccoulson) wrote :

Please see response from Matthew Barnes - he would like to know if the people experiencing this are only using IMAP?:

"IMAP only or does the reporter have other types of accounts? In particular, NNTP is known to chew up mass quantities of RAM with large newsgroup lists."

Changed in evolution-data-server:
status: Unknown → New

I am not using NNTP in evolution since I did not manage to set it up for our NNTP server so far. Therefore it is IMAP only for me.

Izzy (izzy-qumran) wrote :

Suffering from the same bug here on one machine (office), while not on the other (home). Both machines are running Hardy, both use the same repositories - so it's the same versions. The office machine has one more "large" IMAP account configured, plus a couple of CalDav calendars. Looking back, to me it seems the problem did not exist (at least not in these dimensions) before I added the CalDav stuff. Unfortunately, I cannot turn them off, since they are urgently needed for team coordination.

As for Daniels comment concerning the message moving: I do not need to do that. If I just start evo now (uses about 100M initially), leave the machine alone, come back 12h later, e-d-s is already using ~1G virtual plus 0.5G resident memory. Give it one more day, and it reaches the already mentioned 3G here as well (2G virtual + 1G resident). The only work-around I found is to run "killev" at least every second day, and then restart Evolution. Acceptable if that would be once a month at maximum - but "eight days a week", this is simply annoying.

As far as I can see, this issue may be fixed by #350143 (Novell Bugzilla; see also https://launchpad.net/ubuntu/intrepid/+source/evolution-data-server/2.23.3-0ubuntu1) for intrepid. Wouldn't it be possible to backport that fix to hardy?

Sebastien Bacher (seb128) wrote :

the intrepid version has its storage backend rewrite to use sqlite, the code changed a lot and backport changes is not really an option, updating wouldn't be better since the new code has still lot of issues that need to be worked

Jan Pfeifer (pfjan) wrote :

I also used to have the problem -- see upstream report.

Since the update in intrepid, a couple of days ago, to evolution (et al) 2.24.3) the problem mysteriously disappeared -- or at least Evolution memory stays stable after a few hours of use.

Sergey Moskovkin (lvlo) wrote :

I have this issue with Ubuntu 9.04 and proposed updates installed - after 24 hours evolution data server eats about 200 Mb of memory.

Ubuntu Jaunty 9.04 i386
Nvidia 173.14.16
Kernel version 2.6.28-12-generic (jaunty-proposed)
Evolution data server version 2.26.1-0ubuntu2 (jaunty-proposed)

Please tell me if you need more info.

Izzy (izzy-qumran) wrote :

@Ivlo: 200Mb you can almost count as "normal behavior" (though I agree this is already far to much, and to me indicates some memory leak). Guess you don't have any WebCal resource in use for (one of) your calendar(s)? If you want a zero more at the end, try that :(

I'm quite disappointed it takes that long for a fix. The initial report is already 6 months old. Well, at least the bugs status has been risen to "Triaged" - other bugs I'm following did not even manage that after 2 years, so I still live with the work-arounds...

Never abandon hope - wasn't there a saying "hope dies last"?

Changed in evolution-data-server:
status: New → Incomplete
Radu Cristescu (radu.c) wrote :

I'm not sure if this helps anyone, but I landed here after running out of RAM and swap space. I'm not using Evolution at all, but I am using Pidgin. The gang of three, made up by Pidgin, Notify-OSD, and Evolution-Data-Server, were eating all my RAM. Now, I see that Notify-OSD has been fixed in Karmic. I can blame myself for Pidgin's memory, since I use it for IRC without closing the windows for weeks in a row. The only thing left is explain EDS's memory usage without me using any Evolution.

When I boot the computer, and start Pidgin, EDS uses a bit less than 10 MB of RAM. When I ran out of memory, it was using 169 MB. I've been running my system for two weeks to a month (didn't check the uptime) without rebooting (just putting it to sleep) to get this.

Distro: Ubuntu 9.04 (i386)
Memory: 1.25 GB
Swap: 1 GB
System type: laptop

Vincent Vinet (vince-vinet) wrote :

This affects me as well.
After crashing my laptop this morning, I let evolution, pidging and evolution-data-server run all day at by 5pm, evolution-data-server was using a total of 1.9GB of memory (swap + resident combined)
evolution was using about 600MB too if I recall correctly, with very light usage.

Add in a few other apps and virtual servers, and you have an unresponsive (crashed) laptop.

evolution + data server 2.26.1-0ubuntu2
using jaunty
2 GB Ram, 2 GB swap

This is a showstopper for me :S

I notice that this bug has been triaged (and closed on gnome-bugs) but as of Karmic and Evolution 2.28.1, I am still having this issue.

evolution-data-server-2.28 slowly begins consuming more and more memory as time goes on (even if I leave my machine untouched, as many others here have noted). I too have multiple IMAP accounts, but no NNTP accounts.

If I kill the evolution-data-server-2.28 process and reopen Evolution, the data-server loads back up with a usage of 2 MB, which is fine. Slowly it climbs, however, and it's currently sitting at 78.9 MB after about five minutes. After an hour it'll be in the 700 MB range, as others have noted.

I'd like to see this bug reopened but I am fairly new to the process...how can we get this fixed?

Thanks!

Varun

Distributor ID: Ubuntu
Description: Ubuntu 9.10
Release: 9.10
Codename: karmic

Changed in evolution-data-server (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evolution-data-server - 2.28.3-0ubuntu1

---------------
evolution-data-server (2.28.3-0ubuntu1) lucid; urgency=low

  * New upstream version:
    Bug Fixes:
    - #602723 - Contact list name doesn't get displayed in 'To' dialog
    - #600322 - assertion failed: (reply == msg) in cs_waitinfo()
                (lp: #455020, #475147)
    - #564727 - Few memory leaks (lp: #305428)
    - #574940 - Always ref returned info from message_info_from_uid
                (lp: #341909)
    - #429317 - Use the relative URI returned if the server
                re-directs a request
    - #602820 - Test validity of a book_view before using it in LDAP
    - #590762 - Recurring google calendar items are not changeable
    - #604236 - Slow GPG processing
    - #597816 - Do not crash on incorrect parameters used in sexp to SQL
                (lp: #444177)
    - #604544 - Try Exchange fallback authentication only once
    - #600778 - Fix --enable-e2k-debug configure option resolution
    - #260407 - 'endswith' address book search doesn't work
    - #549221 - (bnc) delete, sync flags immediately
  * debian/patches/99_reconfigure.patch:
    - new version update
 -- Sebastien Bacher <email address hidden> Mon, 01 Mar 2010 22:47:15 +0100

Changed in evolution-data-server (Ubuntu):
status: Fix Committed → Fix Released

I have a situation where I have a few pop accounts and calendars.
The calendars are a local calendar, Google Calendar and webdav Calendar.
The moment I go to view my calendars the resident memory usage on evolution-data-server starts climbing from about 30MB up to all available memory.

Forgot to add, I am running on latest Karmic with all updates applied. Did not have similar problems on Jaunty.

Changed in evolution-data-server:
status: Incomplete → Fix Released
eric (obrowny06) wrote :

I still have the memory leak problem with an ubuntu 10.04 lucid lynx.
The file version is 2.28.3.1-0ubuntu5.
After an hour of work, it raises 2gb of ram and after 2 hours it freezes my computer with 2.8 gb of ram unless I kill the process once.
It seems that after I kill the process, it never happens again.

This is very annoying to kill a process every time you start your computer.
I must say that I have never had this problem before with karmic, jaunty or hardy...

Changed in evolution-data-server:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.