Evolution is blocked when password for keyring is being asked for

Bug #292730 reported by Marc Nieper-Wißkirchen on 2008-11-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evolution
Invalid
Low
evolution-data-server (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: evolution

Package: evolution
Releases: 8.10
Version: 2.24.1-0ubuntu2

When Evolution starts, it needs the keyring so I am being asked for the corresponding passphrase. During this time, however, the Evolution thread is blocked. This means, for example, that Evolution turns gray when I have Compiz effects enabled.

The desired behaviour should be that Evolution waits patiently with the UI thread still running during the time I enter the passphrase.

Marc

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/bin/evolution
Package: evolution 2.24.1-0ubuntu2
ProcEnviron:
 PATH=~/.local/opt/gwt:~/.local/opt/google_appengine:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/Eiffel62/studio/spec/linux-x86/bin
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: evolution
Uname: Linux 2.6.27-7-generic i686

Sebastien Bacher (seb128) wrote :

thank you for your bug report, not sure that's a bug though, the passwords are often required to use the accounts and not having the authentification validated would lead to a weird behaviour, could you open the request on bugzilla.gnome.org too where the people writting the software will read it?

Changed in evolution:
assignee: nobody → desktop-bugs
importance: Undecided → Low

Thanks for your reply, Sebastien.

Maybe you have misunderstood my point. That the password is asked for wasn't my issue. My issue was that Evolution's UI thread is blocked (not responding) while the password dialog is open - and this is certainly unwanted behaviour (e.g. it makes the window system think, Evolution has crashed).

And thanks for pointing out bugzilla.gnome.org.

Changed in evolution:
status: New → Triaged
Changed in evolution:
status: Unknown → Confirmed
Changed in evolution:
importance: Unknown → Low
Changed in evolution:
status: Confirmed → Invalid
Sebastien Bacher (seb128) wrote :

upstream says it's fixed in 3.5.3

Changed in evolution-data-server (Ubuntu):
status: Triaged → Fix Committed
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.