evolution uses wrong date to switch to daylight saving timezone in timezone Europe/Brussels

Bug #281956 reported by Steven Van Acker on 2008-10-11
54
This bug affects 3 people
Affects Status Importance Assigned to Milestone
evolution-data-server (Ubuntu)
Low
Ubuntu Desktop Bugs
Hardy
Low
Ubuntu Desktop Bugs
tzdata (Ubuntu)
Undecided
Unassigned
Hardy
Low
Unassigned

Bug Description

Binary package hint: evolution

Belgium switches to "Winter time" on October 26th this year, while evolution thinks the switch happens on October 19th. The consequence of this is that all times on the shown calendar, are wrong for a week.

I'm using evolution 2.22.3.1-0ubuntu1 on Ubuntu Hardy.
An example iCal file is attached. All events in this iCal file are in October 2008. In this month, we are at UTC+0200.
The events are schedules on 0835Z every day and should appear to start on 1035 untill October 25th. From then on, it should appear to start from 0935.

Instead, the daylight saving "timezone switch" happens on October 19th, which is 1 week too early.

kind regards,
-- Steven

Sebastien Bacher (seb128) wrote :

not confirmed on an intrepid installation and the hardy tzdata should be similar, can you run "zdump -v Europe/Brussels" and attach the log to the bug?

Changed in evolution:
assignee: nobody → desktop-bugs
importance: Undecided → Low
Martin Pitt (pitti) wrote :

tzdata is fine:

$ zdump -v Europe/Brussels | grep 2008
Europe/Brussels Sun Mar 30 00:59:59 2008 UTC = Sun Mar 30 01:59:59 2008 CET isdst=0 gmtoff=3600
Europe/Brussels Sun Mar 30 01:00:00 2008 UTC = Sun Mar 30 03:00:00 2008 CEST isdst=1 gmtoff=7200
Europe/Brussels Sun Oct 26 00:59:59 2008 UTC = Sun Oct 26 02:59:59 2008 CEST isdst=1 gmtoff=7200
Europe/Brussels Sun Oct 26 01:00:00 2008 UTC = Sun Oct 26 02:00:00 2008 CET isdst=0 gmtoff=3600

(tested on hardy and intrepid). Basically, European DST rules haven't changed in years.

Changed in tzdata:
status: New → Invalid
Martin Pitt (pitti) wrote :

I also imported your test.ics into evolution, and it displays the correct dates (switch on October 26) for both Europe/Berlin and Europe/Brussels on Intrepid.

Earlier versions of Evolution had severe problems with time zones, maybe this is yet another bug that was fixed in the Intrepid version?

Changed in evolution:
status: New → Incomplete
Biörn (bioern) wrote :

I can confirm this bug on Hardy. The appointments in test.ics switch time on October 19th.

I also can conirm this issue in Hardy. System time is no 09:28, Evolution time line in calendar view is 08:28. I did not observe this some time ago, so I think it is related to a wrong switch date.
Also an invitation I received for 18:00h was inserted in the calendar at 17:00h.
Timezone: Europe/Berlin.

Adrian Grzebyk (adrian-grzebyk) wrote :

I'm also confirming that my evolution timeline is one hour behind. The timezone is Europe/Warsaw and the data from

zdump -v Europe Warsaw

seems to be correct:

Europe/Warsaw Sun Mar 30 00:59:59 2008 UTC = Sun Mar 30 01:59:59 2008 CET isdst=0 gmtoff=3600
Europe/Warsaw Sun Mar 30 01:00:00 2008 UTC = Sun Mar 30 03:00:00 2008 CEST isdst=1 gmtoff=7200
Europe/Warsaw Sun Oct 26 00:59:59 2008 UTC = Sun Oct 26 02:59:59 2008 CEST isdst=1 gmtoff=7200
Europe/Warsaw Sun Oct 26 01:00:00 2008 UTC = Sun Oct 26 02:00:00 2008 CET isdst=0 gmtoff=3600

I think it might be due to that update I installed a few days ago (it had something to do with timezones, maybe it messed things up).

Changed in evolution:
status: Incomplete → Confirmed
georgz (georgz) wrote :

I also see this bug on Hardy.

$ zdump -v Europe/Berlin
Europe/Berlin Sun Mar 30 00:59:59 2008 UTC = Sun Mar 30 01:59:59 2008 CET isdst=0 gmtoff=3600
Europe/Berlin Sun Mar 30 01:00:00 2008 UTC = Sun Mar 30 03:00:00 2008 CEST isdst=1 gmtoff=7200
Europe/Berlin Sun Oct 26 00:59:59 2008 UTC = Sun Oct 26 02:59:59 2008 CEST isdst=1 gmtoff=7200
Europe/Berlin Sun Oct 26 01:00:00 2008 UTC = Sun Oct 26 02:00:00 2008 CET isdst=0 gmtoff=3600

Interesting is that the timezone selector in Evolution thinks that Europe/Berlin is UTC+1 which is correct but when you include Summer Time it's in fact UTC+2.

My workaround for now is that I changed my timezone in Evolution to Europe/Vilinius (UTC+2).

Maybe this is gone after 26th October?

Adrian Grzebyk (adrian-grzebyk) wrote :

georgz and what happens to your periodic/repeating appointments. Mine change if I change Evolution to Vilnius, as they were set up in Warsaw timezone.

jolay (jo-lay) wrote :

I confirm this bug in evolution 2.22.3.1 on Hardy (KDE 3.5.10 or KDE 4), with timezone Europe/Paris.

$ zdump -v Europe/Paris | grep 2008
Europe/Paris Sun Mar 30 00:59:59 2008 UTC = Sun Mar 30 01:59:59 2008 CET isdst=0 gmtoff=3600
Europe/Paris Sun Mar 30 01:00:00 2008 UTC = Sun Mar 30 03:00:00 2008 CEST isdst=1 gmtoff=7200
Europe/Paris Sun Oct 26 00:59:59 2008 UTC = Sun Oct 26 02:59:59 2008 CEST isdst=1 gmtoff=7200
Europe/Paris Sun Oct 26 01:00:00 2008 UTC = Sun Oct 26 02:00:00 2008 CET isdst=0 gmtoff=3600

See attached screenshot. Evolution timeline seems to switch to DST at the beginning of week (Monday Oct.20) instead of next sunday (Oct.26). Events in red on the screenshot are script-generated from an external timetable. They are correctly aligned with the corresponding manually edited events except this week.

Periodic appointements (in November and later) are displayed one hour earlier.

Sebastien Bacher (seb128) wrote :

the issue is fixed in intrepid

Changed in evolution:
status: Confirmed → Fix Released
Sebastien Bacher (seb128) wrote :

the issue is not a tzdata bug

Changed in tzdata:
importance: Undecided → Low
status: New → Invalid
Changed in evolution-data-server:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Confirmed
Sebastien Bacher (seb128) wrote :
Martin Pitt (pitti) wrote :

Accepted into hardy-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in evolution-data-server:
status: Confirmed → Fix Committed
Sebastien Bacher (seb128) wrote :

could somebody confirm that the fix is working correctly?

fre, 21.11.2008 kl. 10.19 +0000, skrev Sebastien Bacher:
> could somebody confirm that the fix is working correctly?

My calendar for the affected week looks good now (using Evolution 2.24.1
from Ubuntu 8.10), but I guess we may not know for sure until the same
time next year...

I've put an appointment in my calender to check this then. ;-)

-- Arvid

georgz (georgz) wrote :

Works for me also now after the move from CEST to CET...

Bye,
Georg

2008/11/21 Arvid Grøtting <email address hidden>:
> fre, 21.11.2008 kl. 10.19 +0000, skrev Sebastien Bacher:
>> could somebody confirm that the fix is working correctly?
>
> My calendar for the affected week looks good now (using Evolution 2.24.1
> from Ubuntu 8.10), but I guess we may not know for sure until the same
> time next year...
>
> I've put an appointment in my calender to check this then. ;-)
>
> -- Arvid
>
> --
> evolution uses wrong date to switch to daylight saving timezone in timezone Europe/Brussels
> https://bugs.launchpad.net/bugs/281956
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Pedro Villavicencio (pedro) wrote :

Steve, does the update works fine for you? since you're the reporter would be good to have your feedback on the proposed package, thanks.

Steve Langasek (vorlon) wrote :

With two successful reports and no reports of regressions after 90 days, I'm marking this as verified - let's not wait until the next DST change for users to run into the problem again before publishing this fix!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evolution-data-server - 2.22.3-0ubuntu3

---------------
evolution-data-server (2.22.3-0ubuntu3) hardy-proposed; urgency=low

  * debian/patches/92_svn_change_correct_dst_calculation.patch:
    - upstream change to fix the dst change not being correct for some locations
      (lp: #281956)

 -- Sebastien Bacher <email address hidden> Wed, 29 Oct 2008 12:16:09 +0100

Changed in evolution-data-server:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers