gnome-keyring-daemon and Evolution cause 100% CPU usage

Bug #236171 reported by Mike Vitale on 2008-05-30
52
Affects Status Importance Assigned to Milestone
evolution-exchange
Fix Released
Medium
evolution-data-server (Debian)
Fix Released
Unknown
evolution-data-server (Kairos Linux)
Fix Committed
Medium
Kairos Maintainers
evolution-data-server (Ubuntu)
Medium
Ubuntu Desktop Bugs
Hardy
Medium
Unassigned

Bug Description

Binary package hint: gnome-keyring

When I use Evolution to create an email message, it interacts with the gnome-keyring-daemon, and they both conspire to peg my CPU usage at 100%. Eventually, I need to run the "evolution --force-shutdown" command. My messages get sent, but having to restart Evolution for every message I want to send is untenable.

Background: this laptop (HP zd8080us) was initally installed with Dapper. I have upgraded through edgy to feisty, ran feisty for a year, and then yesterday upgraded to gutsy, and then to hardy.

[mike@oftheother ~]$ dpkg -l | grep evolution
ii evolution 2.22.1.1-0ubuntu3 groupware suite with mail client and organiz
ii evolution-common 2.22.1.1-0ubuntu3 architecture independent files for Evolution
ii evolution-data-server 2.22.1.1-0ubuntu3 evolution database backend server
ii evolution-data-server-common 2.22.1.1-0ubuntu3 architecture independent files for Evolution
ii evolution-data-server-dbg 2.22.1.1-0ubuntu3 evolution database backend server with debug
ii evolution-dbg 2.22.1.1-0ubuntu3 debugging symbols for Evolution
ii evolution-exchange 2.22.1-0ubuntu1 Exchange plugin for the Evolution groupware
ii evolution-webcal 2.21.92-0ubuntu1 webcal: URL handler for GNOME and Evolution
ii libebook1.2-9 2.22.1.1-0ubuntu3 Client library for evolution address books
ii libecal1.2-7 2.22.1.1-0ubuntu3 Client library for evolution calendars
ii libedata-book1.2-2 2.22.1.1-0ubuntu3 Backend library for evolution address books
ii libedata-cal1.2-6 2.22.1.1-0ubuntu3 Backend library for evolution calendars
ii libedataserver1.2-9 2.22.1.1-0ubuntu3 Utility library for evolution data servers
ii libedataserverui1.2-8 2.22.1.1-0ubuntu3 GUI utility library for evolution data serve
ii libexchange-storage1.2-3 2.22.1.1-0ubuntu3 Backend library for evolution calendars
ii openoffice.org-evolution 1:2.4.0-3ubuntu6 Evolution Addressbook support for OpenOffice
[mike@oftheother ~]$ dpkg -l | grep gnome-keyring
ii gnome-keyring 2.22.1-1ubuntu1 GNOME keyring services (daemon and tools)
ii libgnome-keyring0 2.22.1-1ubuntu1 GNOME keyring services library
[mike@oftheother ~]$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu 8.04"
[mike@oftheother ~]$ apt-cache policy gnome-keyring
gnome-keyring:
  Installed: 2.22.1-1ubuntu1
  Candidate: 2.22.1-1ubuntu1
  Version table:
 *** 2.22.1-1ubuntu1 0
        500 http://archive.ubuntu.com hardy-updates/main Packages
        100 /var/lib/dpkg/status
     2.22.1-1 0
        500 http://archive.ubuntu.com hardy/main Packages
[mike@oftheother ~]$ apt-cache policy evolution
evolution:
  Installed: 2.22.1.1-0ubuntu3
  Candidate: 2.22.1.1-0ubuntu3
  Version table:
 *** 2.22.1.1-0ubuntu3 0
        500 http://archive.ubuntu.com hardy-updates/main Packages
        100 /var/lib/dpkg/status
     2.22.1-0ubuntu3 0
        500 http://archive.ubuntu.com hardy/main Packages

Let me know what other information is needed to assist with this.

Matej Kenda (matejken) wrote :

I (and my colleagues) have the same problem with these versions of gnome-keyring-daemon and Evolution when using the Evolution's Exchange plugin.

It can be observed on i386 and amd64 platforms.

$ apt-cache policy evolution-exchange
evolution-exchange:
  Installed: 2.22.1-0ubuntu1
  Candidate: 2.22.1-0ubuntu1
  Version table:
 *** 2.22.1-0ubuntu1 0
        500 http://si.archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status

Sebastien Bacher (seb128) wrote :

is the issue specific to exchange servers? could you get a stracktrace while it's using cpu?

David Watson (davidthewatson) wrote :

I am including stack trace from my system, a Dell Latitude D630 with dual core, 2GB RAM, and 120 GB disk. I am running evolution on hardy against Microsoft Exchange. The 100% CPU occurs when composing a new message. Simply click the new message button and the CPU spikes at 100% and never returns to normal until evolution is closed. I don't have a non-exchange connected evolution to test the exchange-only theory. I only use evolution to solve the exchange client problem on linux. Exchange-storage may also be implicated, as I saw it consuming significant amounts of CPU along with the aforementioned gnome-keyring-daemon and evoluation itself. This bug renders evolution effectively useless when talking to exchange servers.

Matej Kenda (matejken) wrote :

I have also noticed that gnome-keyring-daemon starts to use large amount of RAM (1.0 - 1.3 GiB). The time, when this is happening, correlates with high CPU usage.

Evolution and gnome-keyring-daemon work fine if Exchange plugin is not used.

Evolution-exchange has also crashed two times during high resource usage. I have reported separate bug for that.

https://bugs.launchpad.net/ubuntu/+source/evolution-exchange/+bug/236025

Download full text (3.7 KiB)

I can confirm this issue as well - During my daily duties I keep an email open that outlines what I performed during my shift at work, unfortunately, doing this under Ubuntu pegs my CPU use at 100% between Evolution and the gnome-keyring-daemon - (mostly the keyring daemon).

I must close Evolution to drop my CPU use back down to normal.

I'm fairly fresh to Ubuntu so I am unsure how to obtain a stacktrace, but I just wanted to add an additional confirmation that this is effecting me as well.

-----

ryana@ryana-linux:~$ dpkg -l | grep evolution
ii evolution 2.22.1.1-0ubuntu3 groupware suite with mail client and organizer
ii evolution-common 2.22.1.1-0ubuntu3 architecture independent files for Evolution
ii evolution-data-server 2.22.1.1-0ubuntu3 evolution database backend server
ii evolution-data-server-common 2.22.1.1-0ubuntu3 architecture independent files for Evolution Data Server
ii evolution-exchange 2.22.1-0ubuntu1 Exchange plugin for the Evolution groupware suite
ii evolution-plugins 2.22.1.1-0ubuntu3 standard plugins for Evolution
ii evolution-webcal 2.21.92-0ubuntu1 webcal: URL handler for GNOME and Evolution
ii libebook1.2-9 2.22.1.1-0ubuntu3 Client library for evolution address books
ii libecal1.2-7 2.22.1.1-0ubuntu3 Client library for evolution calendars
ii libedata-book1.2-2 2.22.1.1-0ubuntu3 Backend library for evolution address books
ii libedata-cal1.2-6 2.22.1.1-0ubuntu3 Backend library for evolution calendars
ii libedataserver1.2-9 2.22.1.1-0ubuntu3 Utility library for evolution data servers
ii libedataserverui1.2-8 2.22.1.1-0ubuntu3 GUI utility library for evolution data servers
ii libexchange-storage1.2-3 2.22.1.1-0ubuntu3 Backend library for evolution calendars
ryana@ryana-linux:~$ dpkg -l | grep gnome-keyring
ii gnome-keyring 2.22.2-0ubuntu1 GNOME keyring services (daemon and tools)
ii libgnome-keyring0 2.22.2-0ubuntu1 GNOME keyring services library
ii libpam-gnome-keyring 2.22.2-0ubuntu1 PAM module to unlock the GNOME keyring upon login
ryana@ryana-linux:~$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu 8.04"
ryana@ryana-linux:~$ apt-cache policy gnome-keyring
gnome-keyring:...

Read more...

Sebastien Bacher (seb128) wrote :

could you get a gdb stacktace as described on https://wiki.ubuntu.com/DebuggingProgramCrash rather than a strace log?

Chris Trawick (ctrawick) wrote :

I get the same behavior with Exchange when sending messages. It also happens when I attempt to load an Exchange address list on the Contacts screen. Perhaps it has to do with address resolution?

Chris Trawick (ctrawick) wrote :

Here's a workaround that calmed it down for me. In Edit > Preferences > Autocompletion, I deselected everything under my Exchange accounts, restarted Evolution, and now it doesn't go thrashing every time I send an email. It still goes ballistic when I switch to the Contacts tab, but at least email's working right again.

Another workaround that seems to calm it down is to write your email, send it, and then click the "Work Offline" button in the lower left hand corner. Then click it again to Work Online, and your CPU usage should be back to normal. Obviously this will be untenable if you keep an email open all day long..

Anyway, I tried to install the evolution-dbgsym package. However, I got the following message:

[root@oftheother ~]$ apt-get install evolution-dbgsym
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  evolution-dbgsym: Depends: evolution (= 2.22.2-0ubuntu1) but 2.22.1.1-0ubuntu3 is to be installed
E: Broken packages

Bah. Never mind about the dbgsym not installable. I needed to remove hardy-proposed from sources.list, and now it's installed.

....However, in attempting to recreate the problem to get you a stacktrace, I have found that I cannot reproduce it. In the interim since I created this bug, I have run an "apt-get upgrade" once, and got a new version of gnome-keyring:

[root@oftheother ~]$ dpkg -l | grep gnome-keyring
ii gnome-keyring 2.22.2-0ubuntu1 GNOME keyring services (daemon and tools)
ii libgnome-keyring0 2.22.2-0ubuntu1 GNOME keyring services library

*sigh*

I'm afraid I'm making a mess of this report, and I apologize for that. Anyway, it turns out that I had already followed the advice of Chris Trawick above, and turned off the Exchange Global Address List. After turning that back on, I was able to reproduce the issue.

Evolution-running gdb inormation attached.

MattHocker (mhocker) wrote :

I have the same issue, evolution always crashes if I try to type an e-mail.

Sebastien Bacher (seb128) wrote :

the issue seems to be an evolution-exchange one rather, could anybody getting the issue open a bug on bugzilla.gnome.org directly? the current ubuntu bug triagers don't have access to an exchange server to work on the issue

Changed in gnome-keyring:
importance: Undecided → Medium
Sebastien Bacher (seb128) wrote :

the gdb log contains no stracktrace, did you do ctrl-C while it was using cpu to get the stacktrace?

Is this an improved version of the stacktrace?

Also note that I had to downgrade my Evolution packages to produce this report with debugging symbols, as I had upgraded to 2.22.2 last week, and the problem is still occurring with 2.22.2.

Bug reported on bugzilla at http://bugzilla.gnome.org/show_bug.cgi?id=537415 .

C de-Avillez (hggdh2) wrote :

I added the upstream link as "also affects"; I have seen it also, but could never get enough data. I will try again, this evening, with both 2.22 and SVN images. I dimly remember, in my case, that it seemed that e-e was trying to open a session to the e-e LDAP server, and failing (and trying again... so loop!).

Nevertheless, I am still not marking it confirmed -- we still do not have enough data to give upstream.

Changed in evolution-exchange:
status: New → Triaged
C de-Avillez (hggdh2) wrote :

Please disregard the piece talking about LDAP above... different issue :-(

Changed in evolution-exchange:
status: Unknown → New
Ed McDonagh (ed-mcdonagh) wrote :

I've been redirected here as my bug has been marked as a duplicate of this one (bug #236171).

My experience is more that the memory usage of gnome-keyring-daemon keeps growing until the system keels over. Simply killing the daemon makes evolution nice and sprightly again, and it instantly restarts the daemon.

Which then starts growing again!

Changed in evolution-exchange:
status: New → Confirmed
karlbowden (karlbowden) wrote :

I have been noticing the same issue since I shifted to a fresh install of Hardy.
I notice the issue ONLY if:
I have not set a Global Address List server name in the Exchange preferences AND
Autocomplete is ticked for Global Address List.

It seems it is trying to frantically to contact a GAL server, but not told it what server to contact.

Once I either turn off Autocomplete for GAL or tell it what GAL it seems happy. I still have ramdom crashes on starting to compose a new email, but very infrequently now.

I have noticed that the Autocomplete for GAL turns itself on automatically if I change the Exchange server preferences, and must check it when I restart Evolution to ensure it does not over consume.

I am not sure if the bug should be with Autocomplete, evolution-exchange or gnome-keyring though.

I'll confirm that I do not have a setting in the "Global Catalog server name" for my Exchange server, Receiving Options tab. Problem is, I don't know what I *should* put there, either. Will mention this upstream.

Changed in evolution-exchange:
status: Confirmed → In Progress
Changed in evolution-exchange:
importance: Undecided → Medium
status: New → Confirmed
Changed in evolution-exchange:
status: In Progress → Fix Released
Sebastien Bacher (seb128) wrote :

the fix has been commited upstream now

Changed in evolution-data-server:
assignee: nobody → desktop-bugs
status: Triaged → Fix Committed
Sebastien Bacher (seb128) wrote :
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in evolution-data-server:
status: Confirmed → Fix Committed
Sebastien Bacher (seb128) wrote :

there is a newer version in intrepid now

Changed in evolution-data-server:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in evolution-data-server:
status: Fix Committed → Fix Released
Philipp Kaluza (pixelpapst) wrote :

I think this might be the same problem as described in debbugs #480201. Need to check if the fix for this (Upstream: http://bugzilla.gnome.org/attachment.cgi?id=113481&action=view ) can help in an LDAP situation also.

Changed in evolution-data-server:
assignee: nobody → kairos-dev
importance: Undecided → Medium
status: New → Confirmed
Changed in evolution-data-server:
status: Unknown → New
Changed in evolution-data-server (Kairos Linux):
status: Confirmed → Fix Committed
Changed in evolution-data-server (Debian):
status: New → Fix Released
Changed in evolution-exchange:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.