spins after signing message

Bug #182317 reported by Brian J. Murrell on 2008-01-12
2
Affects Status Importance Assigned to Milestone
Evolution
Fix Released
Critical
evolution-data-server (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: evolution

Occasionally evolution on Hardy (up to date) seems to spin after (trying to) sign a message with gpg. The UI stops painting so it's stuck in a tight loop somewhere.

The stack trace looks like:

#0 0xffffe410 in __kernel_vsyscall ()
#1 0xb6e25697 in poll () from /lib/tls/i686/cmov/libc.so.6
#2 0xb7d7d3e8 in gpg_ctx_op_step (gpg=0xb13d8b80, ex=0xbfea0d20) at camel-gpg-context.c:1055
#3 0xb7d7f80d in gpg_sign (context=0xb131afb0, userid=0x8103208 "62F2B970", hash=CAMEL_CIPHER_HASH_SHA1, ipart=0xb1240650, opart=0xb129df30, ex=0xbfea0d20)
    at camel-gpg-context.c:1335
#4 0xb7d66dbe in camel_cipher_sign (context=0xb131afb0, userid=0x8103208 "62F2B970", hash=CAMEL_CIPHER_HASH_SHA1, ipart=0xb1240650, opart=0xb129df30,
    ex=0xbfea0d20) at camel-cipher-context.c:132
#5 0xb55164e1 in build_message (composer=0x8297f30, save_html_object_data=0) at e-msg-composer.c:762
#6 0xb54ac91a in em_utils_composer_send_cb (composer=0x8297f30, user_data=0xb1218d18) at em-composer-utils.c:382
#7 0xb6f701ef in IA__g_cclosure_marshal_VOID__VOID (closure=0xb13cde70, return_value=0x0, n_param_values=1, param_values=0xbfea10a4,
    invocation_hint=0xbfea0fac, marshal_data=0xb54ac480) at /build/buildd/glib2.0-2.15.1/gobject/gmarshal.c:77
#8 0xb6f626f9 in IA__g_closure_invoke (closure=0xb13cde70, return_value=0x0, n_param_values=1, param_values=0xbfea10a4, invocation_hint=0xbfea0fac)
    at /build/buildd/glib2.0-2.15.1/gobject/gclosure.c:490
#9 0xb6f784dd in signal_emit_unlocked_R (node=0x879ca38, detail=0, instance=0x8297f30, emission_return=0x0, instance_and_params=0xbfea10a4)
    at /build/buildd/glib2.0-2.15.1/gobject/gsignal.c:2440
#10 0xb6f7a098 in IA__g_signal_emit_valist (instance=0x6, signal_id=460, detail=0, var_args=0xbfea12dc "")
    at /build/buildd/glib2.0-2.15.1/gobject/gsignal.c:2199
#11 0xb6f7a4d9 in IA__g_signal_emit (instance=0x8297f30, signal_id=460, detail=0) at /build/buildd/glib2.0-2.15.1/gobject/gsignal.c:2243
#12 0xb55150f5 in menu_file_send_cb (uic=0xaf5d1e90, data=0x8297f30, path=0xb13cb508 "FileSend") at e-msg-composer.c:1895
#13 0xb79c26c5 in marshal_VOID__USER_DATA_STRING (closure=0xb12508c0, return_value=0xbfea1524, n_param_values=2, param_values=0xb13cf2c0, invocation_hint=0x0,
    marshal_data=0xb55150b0) at bonobo-ui-component.c:221
#14 0xb6f626f9 in IA__g_closure_invoke (closure=0xb12508c0, return_value=0xbfea1524, n_param_values=2, param_values=0xb13cf2c0, invocation_hint=0x0)
    at /build/buildd/glib2.0-2.15.1/gobject/gclosure.c:490
#15 0xb78c20d0 in bonobo_closure_invoke_va_list () from /usr/lib/libbonobo-2.so.0
#16 0xb78c2315 in bonobo_closure_invoke () from /usr/lib/libbonobo-2.so.0
#17 0xb79c28aa in impl_Bonobo_UIComponent_execVerb (servant=0xaf5d1ea4, cname=0xb12f61e0 "FileSend", ev=0xbfea1678) at bonobo-ui-component.c:158
#18 0xb78c4441 in _ORBIT_skel_small_Bonobo_UIComponent_execVerb () from /usr/lib/libbonobo-2.so.0
#19 0xb780e0c0 in ORBit_c_stub_invoke () from /usr/lib/libORBit-2.so.0
#20 0xb78cbd24 in Bonobo_UIComponent_execVerb () from /usr/lib/libbonobo-2.so.0
#21 0xb79c92b4 in impl_emit_verb_on (engine=0xb13c5870, node=0xb12e9010) at bonobo-ui-engine.c:1533
#22 0xb6f702a5 in IA__g_cclosure_marshal_VOID__POINTER (closure=0x857c658, return_value=0x0, n_param_values=2, param_values=0xbfea19e4,
    invocation_hint=0xbfea18ec, marshal_data=0xb79c90b0) at /build/buildd/glib2.0-2.15.1/gobject/gmarshal.c:601
#23 0xb6f61019 in g_type_class_meta_marshal (closure=0x857c658, return_value=0x0, n_param_values=2, param_values=0xbfea19e4, invocation_hint=0xbfea18ec,
    marshal_data=0x4c) at /build/buildd/glib2.0-2.15.1/gobject/gclosure.c:567
#24 0xb6f626f9 in IA__g_closure_invoke (closure=0x857c658, return_value=0x0, n_param_values=2, param_values=0xbfea19e4, invocation_hint=0xbfea18ec)
    at /build/buildd/glib2.0-2.15.1/gobject/gclosure.c:490
#25 0xb6f78669 in signal_emit_unlocked_R (node=0x822c228, detail=0, instance=0xb13c5870, emission_return=0x0, instance_and_params=0xbfea19e4)
    at /build/buildd/glib2.0-2.15.1/gobject/gsignal.c:2478
#26 0xb6f7a098 in IA__g_signal_emit_valist (instance=0x6, signal_id=184, detail=0,
    var_args=0xbfea1c20 "d\037��\200�D\b�b\f\bl�\236��\017\235�\030\231c\tX\034���\017\235�pX<�\030\231c\tx\034��\005\021��\200F��\200F��x\034���\001��\030\231c\tpX<�`Zl�\200F���\001��H\2240�\b\035���&��H\2240�") at /build/buildd/glib2.0-2.15.1/gobject/gsignal.c:2199
#27 0xb6f7a4d9 in IA__g_signal_emit (instance=0xb13c5870, signal_id=184, detail=0) at /build/buildd/glib2.0-2.15.1/gobject/gsignal.c:2243
#28 0xb79c4e58 in bonobo_ui_engine_emit_verb_on_w (engine=0xb13c5870, widget=0x9639918) at bonobo-ui-engine.c:3040
#29 0xb79d0fc4 in exec_verb_cb (item=0x9639918, engine=0xb13c5870) at bonobo-ui-sync-toolbar.c:197
#30 0xb6f701ef in IA__g_cclosure_marshal_VOID__VOID (closure=0xb1309448, return_value=0x0, n_param_values=1, param_values=0xbfea1f64,
    invocation_hint=0xbfea1e6c, marshal_data=0xb79d0fa0) at /build/buildd/glib2.0-2.15.1/gobject/gmarshal.c:77
#31 0xb6f626f9 in IA__g_closure_invoke (closure=0xb1309448, return_value=0x0, n_param_values=1, param_values=0xbfea1f64, invocation_hint=0xbfea1e6c)
    at /build/buildd/glib2.0-2.15.1/gobject/gclosure.c:490
#32 0xb6f784dd in signal_emit_unlocked_R (node=0x844d398, detail=0, instance=0x9639918, emission_return=0x0, instance_and_params=0xbfea1f64)
    at /build/buildd/glib2.0-2.15.1/gobject/gsignal.c:2440
#33 0xb6f7a098 in IA__g_signal_emit_valist (instance=0x6, signal_id=219, detail=0, var_args=0xbfea21a8 "�!��\200F��)�g�\200F���!���\001��`��\b\030\231c\t\006")
    at /build/buildd/glib2.0-2.15.1/gobject/gsignal.c:2199
#34 0xb6f7a450 in IA__g_signal_emit_by_name (instance=0x9639918, detailed_signal=0xb7717631 "clicked") at /build/buildd/glib2.0-2.15.1/gobject/gsignal.c:2267
#35 0xb767ab47 in button_clicked (widget=0x8dde960, button=0x9639918) at /build/buildd/gtk+2.0-2.12.3/gtk/gtktoolbutton.c:667
#36 0xb6f701ef in IA__g_cclosure_marshal_VOID__VOID (closure=0xb130b2e8, return_value=0x0, n_param_values=1, param_values=0xbfea24c4,
    invocation_hint=0xbfea23cc, marshal_data=0xb767ab20) at /build/buildd/glib2.0-2.15.1/gobject/gmarshal.c:77
#37 0xb6f626f9 in IA__g_closure_invoke (closure=0xb130b2e8, return_value=0x0, n_param_values=1, param_values=0xbfea24c4, invocation_hint=0xbfea23cc)
    at /build/buildd/glib2.0-2.15.1/gobject/gclosure.c:490
#38 0xb6f784dd in signal_emit_unlocked_R (node=0x80b72c0, detail=0, instance=0x8dde960, emission_return=0x0, instance_and_params=0xbfea24c4)
    at /build/buildd/glib2.0-2.15.1/gobject/gsignal.c:2440
#39 0xb6f7a098 in IA__g_signal_emit_valist (instance=0x6, signal_id=96, detail=0,
    var_args=0xbfea26fc "�a��\200F��`��\b\030'��\236�L�`��\b`�L�8'���\001��`��\bP�\n\bH'��\200F��T*��p\202\v\bh'��\031\020��p\202\v\b")
    at /build/buildd/glib2.0-2.15.1/gobject/gsignal.c:2199
#40 0xb6f7a4d9 in IA__g_signal_emit (instance=0x8dde960, signal_id=96, detail=0) at /build/buildd/glib2.0-2.15.1/gobject/gsignal.c:2243
#41 0xb74cce3a in IA__gtk_button_clicked (button=0x8dde960) at /build/buildd/gtk+2.0-2.12.3/gtk/gtkbutton.c:889
#42 0xb74ce99e in gtk_real_button_released (button=0x8dde960) at /build/buildd/gtk+2.0-2.12.3/gtk/gtkbutton.c:1484
#43 0xb6f701ef in IA__g_cclosure_marshal_VOID__VOID (closure=0x80b8270, return_value=0x0, n_param_values=1, param_values=0xbfea2a54,
    invocation_hint=0xbfea295c, marshal_data=0xb74ce960) at /build/buildd/glib2.0-2.15.1/gobject/gmarshal.c:77
#44 0xb6f61019 in g_type_class_meta_marshal (closure=0x80b8270, return_value=0x0, n_param_values=1, param_values=0xbfea2a54, invocation_hint=0xbfea295c,
    marshal_data=0x1a4) at /build/buildd/glib2.0-2.15.1/gobject/gclosure.c:567
#45 0xb6f626f9 in IA__g_closure_invoke (closure=0x80b8270, return_value=0x0, n_param_values=1, param_values=0xbfea2a54, invocation_hint=0xbfea295c)
    at /build/buildd/glib2.0-2.15.1/gobject/gclosure.c:490
#46 0xb6f78133 in signal_emit_unlocked_R (node=0x80b8298, detail=0, instance=0x8dde960, emission_return=0x0, instance_and_params=0xbfea2a54)
    at /build/buildd/glib2.0-2.15.1/gobject/gsignal.c:2370
#47 0xb6f7a098 in IA__g_signal_emit_valist (instance=0x6, signal_id=95, detail=0,
    var_args=0xbfea2c8c "�a��|�|���L��,����L�`��\b��L��,��D_Z�`��\b\b\001$��\211\n\b\200F���/��h$\v\b�,��\031\020��h$\v\b")
    at /build/buildd/glib2.0-2.15.1/gobject/gsignal.c:2199
#48 0xb6f7a4d9 in IA__g_signal_emit (instance=0x8dde960, signal_id=95, detail=0) at /build/buildd/glib2.0-2.15.1/gobject/gsignal.c:2243
#49 0xb74cceca in IA__gtk_button_released (button=0x8dde960) at /build/buildd/gtk+2.0-2.12.3/gtk/gtkbutton.c:881
#50 0xb74ccef1 in gtk_button_button_release (widget=0x8dde960, event=0xb1240108) at /build/buildd/gtk+2.0-2.12.3/gtk/gtkbutton.c:1377
#51 0xb75a5f44 in _gtk_marshal_BOOLEAN__BOXED (closure=0x80b2468, return_value=0xbfea2f00, n_param_values=2, param_values=0xbfea2fe4,
    invocation_hint=0xbfea2eec, marshal_data=0xb74cced0) at /build/buildd/gtk+2.0-2.12.3/gtk/gtkmarshalers.c:84
#52 0xb6f61019 in g_type_class_meta_marshal (closure=0x80b2468, return_value=0xbfea2f00, n_param_values=2, param_values=0xbfea2fe4,
    invocation_hint=0xbfea2eec, marshal_data=0xb4) at /build/buildd/glib2.0-2.15.1/gobject/gclosure.c:567
#53 0xb6f626f9 in IA__g_closure_invoke (closure=0x80b2468, return_value=0xbfea2f00, n_param_values=2, param_values=0xbfea2fe4, invocation_hint=0xbfea2eec)
    at /build/buildd/glib2.0-2.15.1/gobject/gclosure.c:490
#54 0xb6f78669 in signal_emit_unlocked_R (node=0x80b28d8, detail=0, instance=0x8dde960, emission_return=0xbfea31a4, instance_and_params=0xbfea2fe4)
    at /build/buildd/glib2.0-2.15.1/gobject/gsignal.c:2478
#55 0xb6f79e79 in IA__g_signal_emit_valist (instance=0x8dde960, signal_id=45, detail=0, var_args=0xbfea3220 "82��\b\001$�`��\bO\223l�`��\b�\211\n\b")
    at /build/buildd/glib2.0-2.15.1/gobject/gsignal.c:2209
#56 0xb6f7a4d9 in IA__g_signal_emit (instance=0x8dde960, signal_id=45, detail=0) at /build/buildd/glib2.0-2.15.1/gobject/gsignal.c:2243
#57 0xb76c4507 in gtk_widget_event_internal (widget=0x8dde960, event=0xb1240108) at /build/buildd/gtk+2.0-2.12.3/gtk/gtkwidget.c:4675
#58 0xb759f191 in IA__gtk_propagate_event (widget=0x8dde960, event=0xb1240108) at /build/buildd/gtk+2.0-2.12.3/gtk/gtkmain.c:2336
#59 0xb75a03f8 in IA__gtk_main_do_event (event=0xb1240108) at /build/buildd/gtk+2.0-2.12.3/gtk/gtkmain.c:1556
#60 0xb72faa9a in gdk_event_dispatch (source=0x809cfe8, callback=0, user_data=0x0) at /build/buildd/gtk+2.0-2.12.3/gdk/x11/gdkevents-x11.c:2351
#61 0xb6ee0d96 in IA__g_main_context_dispatch (context=0x809d030) at /build/buildd/glib2.0-2.15.1/glib/gmain.c:2064
#62 0xb6ee4153 in g_main_context_iterate (context=0x809d030, block=1, dispatch=1, self=0x80676b0) at /build/buildd/glib2.0-2.15.1/glib/gmain.c:2697
#63 0xb6ee4537 in IA__g_main_loop_run (loop=0x80e3430) at /build/buildd/glib2.0-2.15.1/glib/gmain.c:2905
#64 0xb78afd53 in bonobo_main () from /usr/lib/libbonobo-2.so.0
#65 0x0805f661 in main (argc=5, argv=0xbfea3634) at main.c:700
#66 0xb6d6f450 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#67 0x080503e1 in _start ()

The process list from evolution looks like:

 8095 ? Tl 2:51 \_ evolution --sm-client-id 110a4b1601000120007605900000271910021 --screen 1
11781 ? Zs 0:00 | \_ [gpg] <defunct>

So evolution is not even reaping the child process.

Pedro Villavicencio (pedro) wrote :

Thanks for your report, that's known upstream you can track it here: http://bugzilla.gnome.org/show_bug.cgi?id=350007

Changed in evolution:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Triaged
Changed in evolution:
status: Unknown → Confirmed
Changed in evolution:
status: Confirmed → Fix Released
Sebastien Bacher (seb128) wrote :

The bug has been fixed upstream now

Changed in evolution (Ubuntu):
status: Triaged → Fix Committed
affects: evolution (Ubuntu) → evolution-data-server (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evolution-data-server - 2.27.91-0ubuntu1

---------------
evolution-data-server (2.27.91-0ubuntu1) karmic; urgency=low

  * New upstream version:
    Bug Fixes:
    Mailer:
    - #350007 - evolution busy-waits on GPG signing operations (lp: #182317)
    - #571206 - Index files on Maildir accounts are not updated on move
    - #590044 - Drop index on all columns of sqlite database
    - #592310 - Deadlock in maildir provider after doing expunge
    Miscellaneous:
    - #591324 - Cosmetic changes and fixes in configure.ac
    - #591326 - Keep m4 macros in their own folder
    - #591377 - Fails to detect krb5 in configure with -as-needed

 -- Sebastien Bacher <email address hidden> Mon, 31 Aug 2009 17:47:33 +0200

Changed in evolution-data-server (Ubuntu):
status: Fix Committed → Fix Released
Changed in evolution:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.