gnome-shell-calendar-server assert failure: *** Error in `/usr/lib/gnome-shell/gnome-shell-calendar-server': free(): invalid pointer: 0x0000559ef762f960 ***

Bug #1731910 reported by Jean-Baptiste Lallement on 2017-11-13
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
evolution-data-server
Fix Released
High
evolution-data-server (Ubuntu)
Medium
Unassigned

Bug Description

no idea how to reproduce.

ProblemType: Crash
DistroRelease: Ubuntu 18.04
Package: gnome-shell 3.26.1-0ubuntu6
ProcVersionSignature: Ubuntu 4.13.0-16.19-generic 4.13.4
Uname: Linux 4.13.0-16-generic x86_64
ApportVersion: 2.20.7-0ubuntu4
Architecture: amd64
AssertionMessage: *** Error in `/usr/lib/gnome-shell/gnome-shell-calendar-server': free(): invalid pointer: 0x0000559ef762f960 ***
CrashCounter: 1
CurrentDesktop: ubuntu:GNOME
Date: Wed Nov 8 10:13:10 2017
DisplayManager: gdm3
ExecutablePath: /usr/lib/gnome-shell/gnome-shell-calendar-server
InstallationDate: Installed on 2013-09-03 (1531 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130902)
ProcCmdline: /usr/lib/gnome-shell/gnome-shell-calendar-server
ProcEnviron:
 XDG_RUNTIME_DIR=<set>
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=fr_FR.UTF-8
Signal: 6
SourcePackage: gnome-shell
StacktraceTop:
 __libc_message (action=action@entry=do_abort, fmt=fmt@entry=0x7f6c814714e8 "*** Error in `%s': %s: 0x%s ***\n") at ../sysdeps/posix/libc_fatal.c:181
 malloc_printerr (action=<optimized out>, str=0x7f6c8146de6e "free(): invalid pointer", ptr=<optimized out>, ar_ptr=<optimized out>) at malloc.c:5425
 _int_free (av=0x7f6c816a3c20 <main_arena>, p=<optimized out>, have_lock=0) at malloc.c:4174
 __GI___libc_free (mem=<optimized out>) at malloc.c:3144
 e_cal_component_free_datetime () at /usr/lib/x86_64-linux-gnu/libecal-1.2.so.19
Title: gnome-shell-calendar-server assert failure: *** Error in `/usr/lib/gnome-shell/gnome-shell-calendar-server': free(): invalid pointer: 0x0000559ef762f960 ***
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip docker libvirt libvirtd lpadmin lxd plugdev sambashare sudo

Jean-Baptiste Lallement (jibel) wrote :
information type: Private → Public

StacktraceTop:
 __libc_message (action=action@entry=do_abort, fmt=fmt@entry=0x7f6c814714e8 "*** Error in `%s': %s: 0x%s ***\n") at ../sysdeps/posix/libc_fatal.c:181
 malloc_printerr (action=<optimized out>, str=0x7f6c8146de6e "free(): invalid pointer", ptr=<optimized out>, ar_ptr=<optimized out>) at malloc.c:5425
 _int_free (av=0x7f6c816a3c20 <main_arena>, p=<optimized out>, have_lock=0) at malloc.c:4174
 __GI___libc_free (mem=<optimized out>) at malloc.c:3144
 g_free (mem=<optimized out>) at ../../../../glib/gmem.c:189

Changed in gnome-shell (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) on 2017-11-14
affects: gnome-shell (Ubuntu) → evolution-data-server (Ubuntu)
Changed in evolution-data-server (Ubuntu):
status: Confirmed → Fix Committed
Changed in evolution-data-server:
importance: Unknown → High
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evolution-data-server - 3.26.2.1-1ubuntu1

---------------
evolution-data-server (3.26.2.1-1ubuntu1) bionic; urgency=medium

  * Sync with Debian (LP: #1731910). Remaining change:
    - Add transitional evolution-data-server-online-accounts package.
      This can be dropped after Ubuntu 18.04 LTS.

evolution-data-server (3.26.2.1-1) unstable; urgency=medium

  * New upstream release
  * Add new symbol

 -- Jeremy Bicha <email address hidden> Tue, 14 Nov 2017 10:38:45 -0500

Changed in evolution-data-server (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.