Update evolution stack to 3.22

Bug #1613291 reported by Jeremy Bicha
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
evolution (Ubuntu)
Wishlist
Jeremy Bicha
evolution-data-server (Ubuntu)
Wishlist
Jeremy Bicha

Bug Description

Ubuntu yakkety currently has the evolution 3.20 stack. I'd like to use 3.22 for yakkety though because it switches to webkit2 (see bug 1588150 ). The webkit2 switch is too big to easily backport. (The very large commit is at https://git.gnome.org/browse/evolution/commit/?id=332789 but there are other fix-up commits).

evolution is in universe now so its current dependency on webkit1 is allowed since it's in universe.
evolution-data-server 3.20 introduced a new optional dependency on webkit1 with improved support for Google authentication, but this feature was disabled in Ubuntu since webkit1 is in universe.

evolution is seeded in Ubuntu GNOME's image only.

https://git.gnome.org/browse/evolution-data-server/tree/NEWS
https://git.gnome.org/browse/evolution/tree/NEWS
https://git.gnome.org/browse/evolution-ews/tree/NEWS

Two libraries get bumped versions, libcamel-1.2-57 > libcamel-1.2-59 and libedataserver-1.2-21 > libedataserver-1.2.22.

I tested all the below packages that need to be rebuilt. syncevolution was FTBFS because of GCC6 but I identified the fix (LP: #1613405) for it. The only package that still fails to build is evolution-rss which will need to be ported to WebKit2.

How about removing evolution-rss from Ubuntu for now and we can add it back in later once it's been ported? evolution-rss is under-maintained (it's configure.ac still mentions bonobo)

https://launchpad.net/~jbicha/+archive/ubuntu/arch/+packages
(Ignore mongodb)

$ reverse-depends libcamel-1.2-57 (all of these are in universe)
Reverse-Depends
===============
* evolution
* evolution-data-server
* evolution-data-server-online-accounts
* evolution-ews
* evolution-indicator
* evolution-plugins
* evolution-plugins-experimental
* evolution-rss
* gnome-todo
* libcamel1.2-dev
* libebook-1.2-16
* libedataserver-1.2-21
* libedataserverui-1.2-1
* libevolution
* mail-notification-evolution

$ reverse-depends libedataserver-1.2-21
Reverse-Depends
===============
* address-book-service [amd64 arm64 armhf i386 powerpc ppc64el]
* almanah
* bijiben
* bluez-obexd
* california
* ekiga-plugin-evolution
* evolution
* evolution-data-server
* evolution-data-server-online-accounts
* evolution-data-server-utouch [amd64 arm64 armhf i386 powerpc ppc64el]
* evolution-ews
* evolution-indicator
* evolution-plugins
* evolution-rss
* eweouz
* gir1.2-edataserver-1.2
* glabels
* gnome-calendar
* gnome-contacts
* gnome-panel
* gnome-phone-manager
* gnome-shell
* gnome-todo
* indicator-datetime
* libebackend-1.2-10
* libebook-1.2-16
* libebook-contacts-1.2-2
* libecal-1.2-19
* libedata-book-1.2-25
* libedata-cal-1.2-28
* libedataserver1.2-dev
* libedataserverui-1.2-1
* libevolution
* libfolks-eds25
* libjana-ecal0
* qtorganizer5-eds
* ring
* roger-router
* syncevolution-libs-gnome

Jeremy Bicha (jbicha)
Changed in evolution (Ubuntu):
importance: Undecided → Wishlist
status: New → In Progress
assignee: nobody → Jeremy Bicha (jbicha)
Jeremy Bicha (jbicha)
description: updated
Revision history for this message
Sebastien Bacher (seb128) wrote :

Doing without evolution-rss seems fine to me so feel free to not block on that one

Jeremy Bicha (jbicha)
Changed in evolution-data-server (Ubuntu):
status: In Progress → Fix Committed
Changed in evolution (Ubuntu):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evolution - 3.21.90-0ubuntu1

---------------
evolution (3.21.90-0ubuntu1) yakkety; urgency=medium

  * New upstream release (LP: #1613291, LP: #1588150)
  * debian/control:
    - Build-depend on libwebkit2gtk-4.0-dev instead of libwebkitgtk-3.0-dev
    - Bump e-d-s dependencies and build-dependencies to 3.21.90
  * debian/rules:
    - Fix evolution-dbg migration rule
  * Bump dh compat to 10
  * debian/libevolution.install:
    - csv2vcard and addressbook-export have moved to e-d-s
  * debian/patches/lower-webkit-dependency.patch:
    - Don't require webkit2gtk 2.13 yet

 -- Jeremy Bicha <email address hidden> Fri, 19 Aug 2016 13:24:42 -0400

Changed in evolution (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evolution-data-server - 3.21.90-0ubuntu2

---------------
evolution-data-server (3.21.90-0ubuntu2) yakkety; urgency=medium

  * Revert accidentally pushed changes to autopkgtests

evolution-data-server (3.21.90-0ubuntu1) yakkety; urgency=medium

  * New upstream release (LP: #1613291)
  * Rename libcamel-1.2-57 -> libcamel-1.2-59
  * Rename libedataserver-1.2-21 -> libedataserver-1.2-22
  * Update symbols
  * Build-depend on libwebkit2gtk-4.0-dev instead of libwebkitgtk-3.0-dev
  * debian/rules:
    - Drop --disable-google-auth

 -- Jeremy Bicha <email address hidden> Fri, 19 Aug 2016 13:17:17 -0400

Changed in evolution-data-server (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers