evolution-source-registry crashed with SIGABRT in g_assertion_message()

Bug #1494804 reported by Neil Padgett on 2015-09-11
126
This bug affects 21 people
Affects Status Importance Assigned to Milestone
evolution-data-server
Incomplete
Critical
evolution-data-server (Ubuntu)
Medium
Unassigned

Bug Description

Random crash.

ProblemType: Crash
DistroRelease: Ubuntu 15.10
Package: evolution-data-server 3.16.5-1ubuntu1
ProcVersionSignature: Ubuntu 4.2.0-7.7-generic 4.2.0
Uname: Linux 4.2.0-7-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.18.1-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity
Date: Fri Sep 11 16:29:44 2015
ExecutablePath: /usr/lib/evolution/evolution-source-registry
InstallationDate: Installed on 2015-09-11 (0 days ago)
InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Alpha amd64 (20150911)
ProcCmdline: /usr/lib/evolution/evolution-source-registry
ProcEnviron:
 XDG_RUNTIME_DIR=<set>
 SHELL=/bin/bash
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
Signal: 6
SourcePackage: evolution-data-server
StacktraceTop:
 g_assertion_message () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_assertion_message_expr () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_hash_table_lookup () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 e_source_get_extension () from /usr/lib/libedataserver-1.2.so.20
 ?? () from /usr/lib/libebackend-1.2.so.10
Title: evolution-source-registry crashed with SIGABRT in g_assertion_message()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo vboxusers

Neil Padgett (sackwort) wrote :
Changed in evolution-data-server (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in evolution-data-server (Ubuntu):
status: New → Confirmed
Iain Lane (laney) on 2015-09-21
information type: Private → Public
Iain Lane (laney) wrote :

Hi Neil, thanks for the bug. Do you have any more information on what was going on when it happened? It'd be helpful if we knew how to trigger it.

Changed in evolution-data-server:
importance: Unknown → Medium
status: Unknown → Confirmed
Iain Lane (laney) wrote :

The upstream developer (on the linked bug) asked if you could provide the following information if you can reproduce the crash.

"* what accounts he/she has configured, whether any are from Ubuntu Online
  Accounts or GNOME Online Accounts
* whether it crashes also when he/she runs the evolution-source-registry
  from a terminal manually
* whether running the source registry under valgrind will also reproduce the
  crash (it can happen that other timing, due to all slowness caused by the
  memory checking, will not trigger the crash, but also that the valgrind will
  log about the issue and will keep the application running). The command
  might look like (I do not know exact location of the executable, thus
  it can differ in your distribution):
  $ G_SLICE=always-malloc valgrind /usr/libexec/evolution-source-registry &>log"

For the last point you'll need to `apt get install valgrind' and then please attach "log" afterwards.

Neil Padgett (sackwort) wrote :

Sorry, I'm unable to do this; 15.10 was too unstable for me keep it on my laptop, so I've removed it now.

Changed in evolution-data-server:
importance: Medium → Critical
status: Confirmed → Incomplete

I just got this crash, right when I started the computer.

dazza5000 (darran-kelinske) wrote :

Does anyone know how to fix this?

Download full text (7.4 KiB)

I seem to be seeing this now. The other suggested possibilities when reporting were bugz #1200934, #1200819 & #1383852. I can see on this bug that some questions were posed.

> what accounts he/she has configured, whether any are from Ubuntu Online Accounts or GNOME Online Accounts?
I have a personal GoogleMail imapx account created though the Online Accounts Service and an ews OWA account linked to my work exchange server.

> whether it crashes also when he/she runs the evolution-source-registry from a terminal manually?
It seems to have worked OK when I ran /usr/lib/evolution/evolution-source-registry. The output I can see is as follow (with my addresses changed manually to <email address hidden> & <email address hidden>):
$ /usr/lib/evolution/evolution-source-registry
Migrating mail accounts from GConf...
Migrating addressbook sources from GConf...
Migrating calendar sources from GConf...
Migrating task list sources from GConf...
Migrating memo list sources from GConf...
Registering EGoogleBackendFactory ('google')
Registering EOutlookBackendFactory ('outlook')
Registering EYahooBackendFactory ('yahoo')
Registering EOwncloudBackendFactory ('owncloud')
Registering EEwsBackendFactory ('ews')
Registering EMapiBackendFactory ('mapi')
Registering ECollectionBackendFactory ('none')
Adding 1433155791.2289.1@thorne-ul-dt ('Source')
Adding vfolder ('Source_1')
Adding 1433325395.16396.0@thorne-ul-dt ('Source_2')
OWA <email address hidden>: Pairing 1434544712.3155.0@thorne-ul-dt with resource e82c1433-e2e3-4cbf-a933-0f1e68930f98:Global Address List
Adding 1434544712.3155.0@thorne-ul-dt ('Source_3')
Adding 1434381690.5760.2@thorne-ul-dt ('Source_4')
Adding 1434381690.5760.17@thorne-ul-dt ('Source_5')
Adding 1437989181.5803.1@thorne-ul-dt ('Source_6')
Adding 1434381690.5760.0@thorne-ul-dt ('Source_7')
Adding 1432804779.11643.0@thorne-ul-dt ('Source_8')
Adding 1434381690.5760.5@thorne-ul-dt ('Source_9')
Adding 1432718461.14988.73@thorne-ul-dt ('Source_10')
Adding 1432718462.14988.82@thorne-ul-dt ('Source_11')
Adding 1432718461.14988.68@thorne-ul-dt ('Source_12')
Adding 1432889488.2725.0@thorne-ul-dt ('Source_13')
Adding 1432889488.2725.2@thorne-ul-dt ('Source_14')
Adding 1432889488.2725.3@thorne-ul-dt ('Source_15')
Adding 1432640797.18834.16@thorne-ul-dt ('Source_16')
Adding 1432640797.18834.14@thorne-ul-dt ('Source_17')
Adding 1432640791.18834.0@thorne-ul-dt ('Source_18')
Adding local ('Source_19')
Adding 1432889488.2725.1@thorne-ul-dt ('Source_20')
Adding 1432640791.18834.4@thorne-ul-dt ('Source_21')
Adding 1433155649.2289.0@thorne-ul-dt ('Source_22')
Adding caldav-stub ('Source_23')
Adding contacts-stub ('Source_24')
Adding birthdays ('Source_25')
Adding google-stub ('Source_26')
Adding ldap-stub ('Source_27')
Adding local-stub ('Source_28')
Adding system-calendar ('Source_29')
Adding system-address-book ('Source_30')
Adding weather-stub ('Source_31')
Adding webcal-stub ('Source_32')
Adding webdav-stub ('Source_33')
Adding sendmail ('Source_34')
Adding system-memo-list ('Source_35')
Adding system-task-list ('Source_36')
module-cache-reaper-Message: Scanning data directories
module-cache-reaper-Message: Scanning cache directories
Server is up and running....

Read more...

I had evolution-source-registry running for a while without noticing the error reproducing itself.

The only output that looks suspect is:
Adding system-memo-list ('Source_35')
Adding system-task-list ('Source_36')
module-cache-reaper-Message: Scanning data directories
module-cache-reaper-Message: Scanning cache directories
Server is up and running...
AUTH (1434381690.5760.2@thorne-ul-dt): Initiated
==11889== Conditional jump or move depends on uninitialised value(s)
==11889== at 0xC7FF0DD: ag_auth_data_unref (in /usr/lib/x86_64-linux-gnu/libaccounts-glib.so.0.1.3)
==11889== by 0xC5EC83E: ??? (in /usr/lib/evolution-data-server/registry-modules/module-ubuntu-online-accounts.so)
==11889== by 0xC5ECB72: ??? (in /usr/lib/evolution-data-server/registry-modules/module-ubuntu-online-accounts.so)
==11889== by 0xC5ED31C: ??? (in /usr/lib/evolution-data-server/registry-modules/module-ubuntu-online-accounts.so)
==11889== by 0x5F403B7: g_closure_invoke (in /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0.4002.0)
==11889== by 0x5F51FD0: ??? (in /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0.4002.0)
==11889== by 0x5F59A28: g_signal_emit_valist (in /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0.4002.0)
==11889== by 0x5F59CE1: g_signal_emit (in /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0.4002.0)
==11889== by 0x5C8EA63: ??? (in /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0.4002.0)
==11889== by 0x5C2E3B6: g_simple_async_result_complete (in /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0.4002.0)
==11889== by 0x5C2E418: ??? (in /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0.4002.0)
==11889== by 0x61C9CE4: g_main_context_dispatch (in /lib/x86_64-linux-gnu/libglib-2.0.so.0.4002.0)
==11889==
==11889== Conditional jump or move depends on uninitialised value(s)

As I know jumping to memory based on what could be uninitialised variables is a bad thing. It seems possible that the tool is mistaken about the initialisation though.

Sebastien Bacher (seb128) wrote :

could you install libaccounts-glib0-dbgsym evolution-data-server-online-accounts-dbgsym libglib2.0-0-dbgsym and get a new log with debug info?

Not so easily it seems.

$ sudo aptitude install libaccounts-glib0-dbgsym evolution-data-server-online-accounts-dbgsym libglib2.0-0-dbgsym
The following NEW packages will be installed:
  evolution-data-server-online-accounts-dbgsym{b} libaccounts-glib0-dbgsym libglib2.0-0-dbgsym{b}
0 packages upgraded, 3 newly installed, 0 to remove and 8 not upgraded.
Need to get 96.7 kB of archives. After unpacking 414 kB will be used.
The following packages have unmet dependencies:
 evolution-data-server-online-accounts-dbgsym : Depends: evolution-data-server-dbg (= 3.10.4-0ubuntu1) but it is not going to be installed.
 libglib2.0-0-dbgsym : Depends: libglib2.0-0-dbg (= 2.40.0-2) but it is not going to be installed.
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1) evolution-data-server-online-accounts-dbgsym [Not Installed]
2) libglib2.0-0-dbgsym [Not Installed]

Accept this solution? [Y/n/q/?] n
The following actions will resolve these dependencies:

      Remove the following packages:
1) libelfg0
2) libglib2.0-bin

      Install the following packages:
3) evolution-data-server-dbg [3.10.4-0ubuntu1 (trusty)]
4) libelfg0:i386 [0.8.13-4~1 (raring)]
5) libglib2.0-0-dbg [2.40.0-2 (trusty)]
6) libglib2.0-bin:i386 [2.40.0-2 (trusty)]

      Downgrade the following packages:
7) evolution-data-server [3.10.4-0ubuntu1.5 (now, trusty-updates) -> 3.10.4-0ubuntu1 (trusty)]
8) evolution-data-server-common [3.10.4-0ubuntu1.5 (now, trusty-updates) -> 3.10.4-0ubuntu1 (trus
9) evolution-data-server-online-accounts [3.10.4-0ubuntu1.5 (now, trusty-updates) -> 3.10.4-0ubun
10) libcamel-1.2-45 [3.10.4-0ubuntu1.5 (now, trusty-updates) -> 3.10.4-0ubuntu1 (trusty)]
11) libglib2.0-0 [2.40.2-0ubuntu1 (now, trusty-updates) -> 2.40.0-2 (trusty)]
12) libglib2.0-0:i386 [2.40.2-0ubuntu1 (now, trusty-updates) -> 2.40.0-2 (trusty)]

Accept this solution? [Y/n/q/?]

Would something like the suggested set of downgrades be acceptable or would it change too much that possibly relates to the issue.

Sebastien Bacher (seb128) wrote :

it seems like you didn't active ddeb for trusty-updates, only trusty? also your issue might be a different one if you use trusty, that bug started on 15.10...

I don't quite understand that part about "seems like you didn't active ddeb for trusty-updates". Do you mean that there are some steps I need to take to enable the installation of debug symbols for packages that come from trusty-updates?

If it is likely that this is a different issue, I can raise a new bug report. I seem to still have the /var/crash/_usr_lib_evolution_evolution-source-registry.1000.crash file from the 19th so I will try and file a report from that.

I raised Bug #1509269 which apport marked as a duplicate of Bug #1200819.

This crash is happening now at bionic devel... well, the message is the same.

Sebastien Bacher (seb128) wrote :

What are you doing in bionic to trigger the issue?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.