Alarms not shown in indicator datetime after upgrade to ota4

Bug #1465806 reported by Dave Morley on 2015-06-16
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Unassigned
evolution-data-server (Ubuntu)
Undecided
Charles Kerr
indicator-datetime (Ubuntu)
Undecided
Charles Kerr
Vivid
Undecided
Unassigned

Bug Description

STEPS:
1. Flash image 22 from stable
2. Set a one time alarm and a recurring alarm
3. Update to 23

EXPECTED:
Alarms should be up and running as expected

ACTUAL:
Alarms are not shown in the datetime indicator but show up as active in and available in the clock. Because the indicator is in control of the alarm trigger the alarm never goes off.

TEMPORARY WORK AROUND:
Disable and enable all your alarms and then they work as expected.

Related branches

Dave Morley (davmor2) on 2015-06-16
tags: added: qa-manual-testing
Changed in canonical-devices-system-image:
milestone: none → ww28-2015
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in evolution-data-server (Ubuntu):
status: New → Confirmed
Zsombor Egri (zsombi) wrote :

I thunk this and the Clock crasher bug are two different bugs! The alarm not kicking is not the Clock or backend's problem, please break the duplication!

John McAleely (john.mcaleely) wrote :

I agree they are different.

Charles Kerr (charlesk) on 2015-06-17
Changed in canonical-devices-system-image:
assignee: nobody → Charles Kerr (charlesk)
assignee: Charles Kerr (charlesk) → nobody
Changed in evolution-data-server (Ubuntu):
assignee: nobody → Charles Kerr (charlesk)
status: Confirmed → In Progress
Charles Kerr (charlesk) wrote :

I see what the problem is -- the alarms created by ubuntu-clock-app in image 22 have valarms that are missing the required 'trigger' property. This works for alarms created by qtorganizer5-eds after the fix for bug #1440878 landed -- which is why disabling and then re-enabling the alarms as davmor2 works as a workaround -- but that still leaves the question of how to handle these triggerless alarms without requiring a workaround.

Until 13.10.0+15.04.20150521-0ubuntu1, indicator-datetime /pretended/ that x-canonical-alarm entries had a trigger even if they didn't. That's no longer possible because we're now querying EDS for alarms based on the trigger, which was necessary to fix bug #1456281.

Probably the safest fix here is for indicator-datetime to ask EDS on startup for all the x-canonical-alarm components, then walk through them looking for valarms missing a trigger, insert the missing trigger, and save the corrected entry back to EDS.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-datetime - 13.10.0+15.10.20150622-0ubuntu1

---------------
indicator-datetime (13.10.0+15.10.20150622-0ubuntu1) wily; urgency=medium

  [ Charles Kerr ]
  * Fix bugs relating to timezones and triggers from clock-app alarms.
    (LP: #1456281, #1465806)

 -- CI Train Bot <email address hidden> Mon, 22 Jun 2015 18:03:38 +0000

Changed in indicator-datetime (Ubuntu):
status: New → Fix Released
Charles Kerr (charlesk) on 2015-06-23
Changed in indicator-datetime (Ubuntu):
assignee: nobody → Charles Kerr (charlesk)
Changed in evolution-data-server (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: New → Fix Released
importance: Undecided → High
John McAleely (john.mcaleely) wrote :

@pmcgowan, is this in vivid-overlay? It's hard to tell from the bug text

Pat McGowan (pat-mcgowan) wrote :

@john yes this is fixed in rtm

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers