evolution-calendar-factory severely leaking memory

Bug #1210864 reported by Kelly Hyde on 2013-08-10
68
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Indicator Date and Time
Fix Released
High
Charles Kerr
evolution-data-server (Ubuntu)
High
Unassigned
indicator-datetime (Ubuntu)
High
Unassigned

Bug Description

On Ubuntu 13.10 running Unity, the processes unity-panel-service, evolution-calendar-factory, and indicator-datetime-service are leaking memory simultaneously. The leak appears to happen randomly. Over a 24 hour period, the three processes combined take up 1 GB or more of RAM. Killing and reinstating all three returns them to normal memory usage cleanly until the leak happens again.

I'm running Evolution with the accounts configured locally (not with Ubuntu Online Accounts). I have two Google Calendar accounts configured. I'm not sure how to track down the cause of this bug because nothing is in any system logs and it appears I can't start evolution-calendar-factory from the terminal.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: evolution-data-server 3.8.4-0ubuntu1
ProcVersionSignature: Ubuntu 3.10.0-6.17-generic 3.10.3
Uname: Linux 3.10.0-6-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.12-0ubuntu3
Architecture: amd64
Date: Sat Aug 10 16:47:31 2013
InstallationDate: Installed on 2013-08-02 (8 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130801)
MarkForUpload: True
ProcEnviron:
 LANGUAGE=en_US
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: evolution-data-server
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Kelly Hyde (polarimetric) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in evolution-data-server (Ubuntu):
status: New → Confirmed
Changed in indicator-datetime (Ubuntu):
status: New → Confirmed
Matteo Pagliazzi (paglia) wrote :

Here it takes more than 250mb of ram and continues to increase as time pass

stoneageman (stoneageman404) wrote :

Ubuntu 3.11.0-4 x64
evolution-calendar-factory was using over 4Gb ram before I noticed it. However evolution is not installed?
indicator-datetime-service also crashes randomly

Charles Kerr (charlesk) on 2013-09-06
Changed in indicator-datetime:
status: New → In Progress
assignee: nobody → Charles Kerr (charlesk)
importance: Undecided → High
Charles Kerr (charlesk) wrote :

I believe https://code.launchpad.net/~charlesk/indicator-datetime/lp-1204532/+merge/184155 will also affect this ticket.

That patch instantiates the relevant EDS sources & clients once and keeps references to them, instead of churning through a high volume of them on-demand.

I've run the lp-1204532 branch under valgrind for ~18 hours and don't see any significant leakage.

Charles Kerr (charlesk) on 2013-10-03
Changed in indicator-datetime:
status: In Progress → Fix Committed
Charles Kerr (charlesk) on 2013-10-04
Changed in indicator-datetime:
status: Fix Committed → Fix Released
Sebastien Bacher (seb128) wrote :

Is anyone still having issues there or can we consider the bug to be fixed with the indicator changes?

Changed in indicator-datetime (Ubuntu):
status: Confirmed → Fix Released
importance: Undecided → High
Changed in evolution-data-server (Ubuntu):
importance: Undecided → High
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers