evolution-calendar-factory crashed with SIGFPE in g_hash_table_lookup_node()

Bug #1062068 reported by Barry Edge on 2012-10-05
578
This bug affects 108 people
Affects Status Importance Assigned to Milestone
evolution-data-server
Fix Released
Critical
evolution-data-server (Ubuntu)
High
Mathieu Trudel-Lapierre
Quantal
High
Mathieu Trudel-Lapierre

Bug Description

I logged into my desktop (in Gnome) and the bug was reported to me. My calendar in Gnome doesn't sync with my Google Calendar, not sure if that is what the problem is.

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: evolution-data-server 3.6.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-17.27-generic 3.5.5
Uname: Linux 3.5.0-17-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 2.6.1-0ubuntu1
Architecture: i386
Date: Fri Oct 5 08:13:56 2012
ExecutablePath: /usr/lib/evolution/evolution-calendar-factory
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release i386 (20120423)
ProcCmdline: /usr/lib/evolution/evolution-calendar-factory
ProcEnviron:
 SHELL=/bin/false
 XDG_RUNTIME_DIR=<set>
 PATH=(custom, no user)
 LANGUAGE=en_GB:en
 LANG=en_GB.UTF-8
Signal: 8
SourcePackage: evolution-data-server
StacktraceTop:
 ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
 ?? () from /usr/lib/evolution-data-server/calendar-backends/libecalbackendcontacts.so
 g_cclosure_marshal_VOID__OBJECTv () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
 g_signal_emit_valist () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
Title: evolution-calendar-factory crashed with SIGFPE in g_cclosure_marshal_VOID__OBJECTv()
UpgradeStatus: Upgraded to quantal on 2012-10-02 (2 days ago)
UserGroups:

Barry Edge (bedge-g) wrote :
Changed in evolution-data-server (Ubuntu):
importance: Undecided → Medium
summary: evolution-calendar-factory crashed with SIGFPE in
- g_cclosure_marshal_VOID__OBJECTv()
+ g_hash_table_lookup_node()
tags: removed: need-i386-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in evolution-data-server (Ubuntu):
status: New → Confirmed
tags: added: bugpattern-needed
Paul Larson (pwlars) on 2012-10-11
tags: added: rls-q-incoming
visibility: private → public
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1062068

tags: added: iso-testing
tags: removed: rls-q-incoming
Changed in evolution-data-server (Ubuntu Quantal):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
importance: Medium → High

The bug happens almost every time I boot my computer, and this has been happing for months despite multiple re-installations of Ubuntu 12.10. Each time I reinstall, I still maintain my previous "/home" directory (which is on a separate partition). Could it be that I have a configuration file that is cause this bug to persist into new installations?

I don't notice any issues from this crash, but the crash report pops up and tells me that evolution-calendar-factory has crashed again.

Also, since I've sent the info of this crash numerous times, I now select the "ignore in the future" option, but it has no effect. I always get prompted that the crash has happened again.

AnAkIn (anakin-cs) wrote :

I am too getting the issue on all 3 of my computers, every time I boot, since the upgrade to 12.10.
If you aren't using Evolution though, you can prevent this crash from happening easily, just remove the evolution-data-server package.

@anakin-cs: it is not so simple, I have the same problem, trying to uninstalling evolution-data-server now indicator-datetime-service crashes, trying to uninstall indicator-datetime solve the crash problem but I have no more date-time indicator on my gnome panel.

If I try to reinstall indicator-datetime I must reinstall evolution-data-server, uh oh seems a weird loop...

What I've done:

1) removed evolution-data-server

now indicator-datetime-service crashes at startup so:

2) removed indicator-datetime
3) reinstalled indicator-datetime (+ evolution-data-server)

now unity-scope-gdocs crashes at startup so:

4) forced reinstall of unity-scope-gdocs

Now seems that all is working good (tried poweroff and restart 2 times and no crashes at all), good luck !

AnAkIn (anakin-cs) wrote :

I've never had any indicator-datetime-service crashes, maybe because I am not using Unity.

Sorry for everyone here

I dont know why this thread will post to me?

I have not joined this bug discussion !

Felix Handler (snowborn) wrote :

With me it does not simply crash but seem to keep the login about 30 seconds delayed as well!

Sebastien Bacher (seb128) wrote :

seems like https://bugzilla.gnome.org/show_bug.cgi?id=687100

the issue has been fixed in that commit (which is included in 3.6.2 and in raring):
http://git.gnome.org/browse/evolution-data-server/commit/?h=gnome-3-6&id=5323e33d2986e049f78c985c9b028870c0993748

Mathieu, can you SRU the fix to quantal? we might want to SRU 3.6.2 seeing the number of fixes in it

Changed in evolution-data-server (Ubuntu):
status: Confirmed → Fix Released
Changed in evolution-data-server:
importance: Unknown → Critical
status: Unknown → Fix Released
Guy Kroizman (kroizguy) wrote :

I see that the bug status is "Fix Released", what should I do so it will be fixed on my machine? wait for 13.04? or take some action?
Thanks.

Antony Nicholas (anicholas) wrote :

Yes I am also wondering how I can fix ubuntu with this patch?

brentsim (bsimon1) wrote :

Thank you Gianluca. I have also found that the 1-step equivalent:
sudo apt-get --reinstall install evolution-data-server indicator-datetime unity-scope-gdocs
fixes the problem.

Raphael Wagner (raeffz) wrote :

Thanks brentsim and gianluca,

sudo apt-get --reinstall install evolution-data-server indicator-datetime unity-scope-gdocs

works fine!

Rolf Leggewie (r0lf) wrote :

quantal has seen the end of its life and is no longer receiving any updates. Marking the quantal task for this ticket as "Won't Fix".

Changed in evolution-data-server (Ubuntu Quantal):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.