Ubuntu

evolution-calendar-factory crashed with SIGSEGV in g_rec_mutex_get_impl()

Reported by Rainer Rohde on 2012-08-21
316
This bug affects 61 people
Affects Status Importance Assigned to Milestone
evolution-data-server
Fix Released
Critical
evolution-data-server (Ubuntu)
High
Mathieu Trudel-Lapierre
Quantal
High
Unassigned

Bug Description

I am unable to add my Google calendar to Evolution; something along the line of "method not supported".

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: evolution-data-server 3.5.5-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-11.11-generic 3.5.2
Uname: Linux 3.5.0-11-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.4-0ubuntu8
Architecture: amd64
Date: Tue Aug 21 10:26:19 2012
ExecutablePath: /usr/lib/evolution/evolution-calendar-factory
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120820)
ProcCmdline: /usr/lib/evolution/evolution-calendar-factory
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
SegvAnalysis:
 Segfault happened at: 0x7f105f5ec2c0 <g_rec_mutex_lock>: mov (%rdi),%rax
 PC (0x7f105f5ec2c0) ok
 source "(%rdi)" (0xaaaaaaaaaaaaaaaa) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: evolution-data-server
StacktraceTop:
 g_rec_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /usr/lib/evolution-data-server/calendar-backends/libecalbackendcontacts.so
 g_cclosure_marshal_VOID__OBJECTv () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_emit_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: evolution-calendar-factory crashed with SIGSEGV in g_rec_mutex_lock()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Rainer Rohde (rainer-rohde) wrote :
visibility: private → public

StacktraceTop:
 g_rec_mutex_get_impl (rec_mutex=0xaaaaaaaaaaaaaaaa) at /build/buildd/glib2.0-2.33.8/./glib/gthread-posix.c:376
 g_rec_mutex_lock (mutex=0xaaaaaaaaaaaaaaaa) at /build/buildd/glib2.0-2.33.8/./glib/gthread-posix.c:377
 cal_backend_contacts_remove_book_record (cbc=0x1e84050, source=0x7f1048064980) at e-cal-backend-contacts.c:229
 g_cclosure_marshal_VOID__OBJECTv (closure=0x1e85020, return_value=<optimized out>, instance=0x1e4d070, args=<optimized out>, marshal_data=<optimized out>, n_params=<optimized out>, param_types=0x1e3f630) at /build/buildd/glib2.0-2.33.8/./gobject/gmarshal.c:1312
 _g_closure_invoke_va (closure=0x1e85020, return_value=0x0, instance=0x1e4d070, args=0x7fffe7ccfb28, n_params=1, param_types=0x1e3f630) at /build/buildd/glib2.0-2.33.8/./gobject/gclosure.c:840

Changed in evolution-data-server (Ubuntu):
importance: Undecided → Medium
summary: - evolution-calendar-factory crashed with SIGSEGV in g_rec_mutex_lock()
+ evolution-calendar-factory crashed with SIGSEGV in
+ g_rec_mutex_get_impl()
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in evolution-data-server (Ubuntu):
status: New → Confirmed
tags: added: running-unity
meanpt (meanpt) wrote :

I just opened the dash and the error was reported, byt didn't do anything evolution related

Susan Cragin (susancragin) wrote :

evolution-calendar-factory crashed with SIGFPE in g_cclosure_marshal_VOID__OBJECTv()
I got a slightly different error message. I also did not do anything evolution related.

twipley (smt-infp) wrote :

Same than the above poster: evolution-calendar-factory crashed with SIGFPE in g_cclosure_marshal_VOID__OBJECTv()

Roland S. (kaiser-ger) wrote :

Got this crash and never even installed evolution.

vedavata (vedavrata) wrote :

Almost even every boot I receive
"Evolution 12.10 has evperienced an internal error:"
"evolution-calendar-factory crashed with SIGSEGV"
although i have neither evolution-calendar-factory nor evolution-data-server...

Sebastien Bacher (seb128) wrote :
Changed in evolution-data-server (Ubuntu):
importance: Medium → High
status: Confirmed → Fix Committed
Changed in evolution-data-server (Ubuntu Quantal):
importance: Undecided → High
status: New → Triaged
Changed in evolution-data-server (Ubuntu):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Changed in evolution-data-server:
importance: Unknown → Critical
status: Unknown → Fix Released
Changed in evolution-data-server (Ubuntu):
status: Fix Committed → Fix Released

Sorry, but this isn't fixed in Raring yet -- setting back to fix committed. It only gets fixed in 3.6.3; we'll upload 3.6.4 to raring shortly.

Changed in evolution-data-server (Ubuntu):
status: Fix Released → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evolution-data-server - 3.6.4-0ubuntu1

---------------
evolution-data-server (3.6.4-0ubuntu1) raring; urgency=low

  * New upstream release.
    - Crash in Contacts calendar backend (LP: #1039594)
    - Empty name selector dialog on open (LP: #1072442)
 -- Mathieu Trudel-Lapierre <email address hidden> Thu, 21 Mar 2013 11:01:22 -0400

Changed in evolution-data-server (Ubuntu):
status: Fix Committed → Fix Released

Hello Rainer, or anyone else affected,

Accepted evolution-data-server into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/evolution-data-server/3.6.4-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in evolution-data-server (Ubuntu Quantal):
status: Triaged → Fix Committed
tags: added: verification-needed

The fix for this bug has been awaiting testing feedback in the -proposed repository for quantal for more than 90 days. Please test this fix and update the bug appropriately with the results. In the event that the fix for this bug is still not verified 15 days from now, the package will be removed from the -proposed repository.

tags: added: removal-candidate
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.