evince needs access to /run/udev/data

Bug #883045 reported by Konrad Hofer on 2011-10-28
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
evince (Ubuntu)
Low
Jamie Strandboge

Bug Description

Ubuntu Oneiric 32bit

when launching a pdf file with evince, syslog complains:

type=1400 audit(1319803010.106:155): apparmor="DENIED" operation="open" parent=1 profile="/usr/bin/evince-previewer" name="/run/udev/data/b8:1" pid=5835 comm="evince-previewe" requested_mask="r" denied_mask="r" fsuid=1000 ouid=0

Need to add this to usr.bin.evince
/run/udev/data/* r,

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in evince (Ubuntu):
status: New → Confirmed
Konrad Hofer (konrad.hofer) wrote :

problem package: evince-common (3.2.0-0ubuntu1)

Changed in evince (Ubuntu):
status: Confirmed → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in evince (Ubuntu):
status: New → Confirmed
Changed in evince (Ubuntu):
assignee: nobody → Ubuntu Security Team (ubuntu-security)
Changed in evince (Ubuntu):
assignee: Ubuntu Security Team (ubuntu-security) → Jamie Strandboge (jdstrand)
importance: Undecided → Low
status: Confirmed → Triaged
Changed in evince (Ubuntu):
milestone: none → precise-alpha-2
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evince - 3.2.1-1ubuntu5

---------------
evince (3.2.1-1ubuntu5) precise; urgency=low

  * debian/apparmor-profile*:
    - allow owner read of @{PROC}/[0-9]*/auxv
    - use PUx for yelp instead of Ux
    - explicitly deny reads to /run/udev/data/** (LP: #883045)
    - allow PUx for nautilus for evince (LP: #864992)
    - allow ixr of gedit for text attachments (LP: #837549)
 -- Jamie Strandboge <email address hidden> Wed, 04 Jan 2012 11:01:38 -0600

Changed in evince (Ubuntu):
status: In Progress → Fix Released
alfredo (software-zas) wrote :

Fix Released ?? I have this bug in Oneiric 64Bit today. The evince version is 3.2.1-0ubuntu2.2

The last comment is from 2012-01-04, never seen this update on my upgrades....

What is wrong?

Regards, Alfredo

Vadim Rutkovsky (roignac) wrote :

This is fixed in Precise evince 3.2.1-1ubuntu5. Please upgrade to the Precise as soon as it will be released
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers