Ubuntu

--disable-gestures does not work

Reported by tisep on 2011-10-14
72
This bug affects 13 people
Affects Status Importance Assigned to Milestone
evince (Ubuntu)
Medium
Chase Douglas
Oneiric
Medium
Unassigned

Bug Description

SRU Justification:
==================
[Impact]
Gesture support in applications currently requires a tradeoff when dealing with two touch scrolling on trackpads. There may be users who would prefer to operate evince without gesture support. Currently, --disable-gestures/-g does not work.

[Development Fix]
The bug has been fixed in the development branch by modifying the libgrip gestures distro patch. Version 3.2.1-0ubuntu2 released in precise has the fix.

[Stable Fix]
See http://bazaar.launchpad.net/~ubuntu-desktop/evince/ubuntu/revision/133.

[Test Case]
Run evince at the console. The warning about the "enable-gestures" property will show. Run with --disable-gestures and the warning will still appear, and gestures will still be enabled. The list of evince gestures are: two touch pinch to zoom and rotate on touchpads and touchscreens, and two touch drag to scroll on touchscreens. Note this only works with multitouch gesture capable hardware, such as Macbook trackpads and Magic Trackpads

[Regression Potential]
Minimal. The patch is extremely straightforward. The enable-gestures property is now checked before registering for gestures, and the unnecessary G_PARAM_CONSTRUCTION_ONLY flag on the property has been removed.

Original bug report:
====================
The --disable-gestures flag does not work due to two issues:

1. The enable-gestures gobject class property of the EvView object is created with the G_PARAM_CONSTRUCT_ONLY flag.
2. The property value is not checked before registering for gestures.

The first issue causes the following warning in the console:

(evince:23456): GLib-GObject-WARNING **: g_object_set_valist: construct property "enable-gestures" for object `EvView' can't be set after construction

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: evince 3.2.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
Date: Fri Oct 14 02:10:49 2011
ExecutablePath: /usr/bin/evince
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_CA.UTF-8
 LANGUAGE=en_CA:en
SourcePackage: evince
UpgradeStatus: Upgraded to oneiric on 2011-10-13 (0 days ago)

tisep (chu-pang) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in evince (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Chase, could you look at this bug? The "g_object_set_valist: construct property "enable-gestures" for object `EvView' can't be set after construction" seems a bug from the patch your team added to evince?

Changed in evince (Ubuntu):
assignee: nobody → Chase Douglas (chasedouglas)
summary: - Evince Warning
+ --disable-gestures does not work
Changed in evince (Ubuntu):
importance: Undecided → Medium
milestone: none → oneiric-updates
status: Confirmed → Fix Committed
milestone: oneiric-updates → none
Chase Douglas (chasedouglas) wrote :

I have committed a fix to the evince branch for the current development release (precise). It should be uploaded sometime in the next week.

description: updated
Changed in evince (Ubuntu Oneiric):
status: New → Triaged
importance: Undecided → Medium
milestone: none → oneiric-updates
description: updated

Hello tisep, or anyone else affected,

Accepted evince into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in evince (Ubuntu Oneiric):
status: Triaged → Fix Committed
tags: added: verification-needed
melchiorre (melchiorre) on 2011-10-19
Changed in evince (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Changed in evince (Ubuntu Oneiric):
status: Fix Released → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evince - 3.2.1-0ubuntu2

---------------
evince (3.2.1-0ubuntu2) oneiric-proposed; urgency=low

  * Fix --disable-gestures/-g option (LP: #873866)

evince (3.2.1-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release
    - Make sure page labels are valid utf-8 strings in PostScript
      backend (LP: #677971, Carlos Garcia Campos)
    - Update and extend man page, Added documentation for the
      --page-index command line switch, and improved wording a bit at
      various places (Wouter Bolsterlee)
    - Small fixes to markup in help pages (Tiffany Antopolski)
    - Updated transations
 -- Chase Douglas <email address hidden> Mon, 17 Oct 2011 11:57:56 -0700

Changed in evince (Ubuntu):
status: Fix Committed → Fix Released
Pedro Villavicencio (pedro) wrote :

I've followed the test case and the package in proposed is not exhibit the warning anymore, can't tell though if the gestures are working (don't have a capable hw) but at least from the normal evince behavior it seems to work fine. Marking it as verification-done. Thanks all.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evince - 3.2.1-0ubuntu2

---------------
evince (3.2.1-0ubuntu2) oneiric-proposed; urgency=low

  * Fix --disable-gestures/-g option (LP: #873866)

evince (3.2.1-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release
    - Make sure page labels are valid utf-8 strings in PostScript
      backend (LP: #677971, Carlos Garcia Campos)
    - Update and extend man page, Added documentation for the
      --page-index command line switch, and improved wording a bit at
      various places (Wouter Bolsterlee)
    - Small fixes to markup in help pages (Tiffany Antopolski)
    - Updated transations
 -- Chase Douglas <email address hidden> Mon, 17 Oct 2011 11:57:56 -0700

Changed in evince (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers