Evince title should be adaptable

Bug #78584 reported by Michael B. Trausch on 2007-01-09
46
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Evince
Fix Released
Wishlist
evince (Ubuntu)
Wishlist
Ubuntu Desktop Bugs

Bug Description

Binary package hint: evince

This is a feature request bug.

Under Evince, when a PDF is loaded, the title of the PDF is displayed in the Window title of the Evince window. However, it would appear that some of the PDFs that I read lack a title, or are named “untitled” or something. These are PDFs that I read as eBooks through a distance learning program.

It seems that Evince should be able to detect PDFs without a title or with the title “untitled” and be able to change to another means of identifying the window (such as the file name of the currently opened PDF). Even better, there should probably be an option that allows users to choose their Window title behavior:

 * Always display the PDF’s title in the window title,
 * Attempt to display the PDF’s title in the Window title with exceptions (a list, perhaps, which defaults to including “untitled”?),
 * Always display the document’s file name in the window title.

This seems like it would be reasonable, anyway. I generally want to see the file name, myself, and not the document title as it was put into the document. It would help me to better keep track of everything, especially when working with many PDFs at once.

description: updated
Sebastien Bacher (seb128) wrote :

Thank you for your bug. What version of Ubuntu do you use? Do you have an example to attach to the bug?

Changed in evince:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: Unconfirmed → Needs Info

On Tue, 2007-01-09 at 19:58 +0000, Sebastien Bacher wrote:

> Thank you for your bug. What version of Ubuntu do you use? Do you have
> an example to attach to the bug?

Sorry, I suppose I should have thought to include that information. I
am currently using Ubuntu Edgy with Evince 0.6.1, Using poppler 0.5.4
(splash).

I will need to try to find an unencumbered example, because at this time
the only example files that I know that have this issue are files that I
cannot (under agreement, due to copyright) redistribute. I might be
able to try to see if I can trim it to just the first page, which should
qualify as fair use to provide an example.

    — Mike

--
Michael B. Trausch
                    <email address hidden>
Phone: (404) 592-5746
                          Jabber IM:
                    <email address hidden>
              <email address hidden>
Demand Freedom! Use open and free protocols, standards, and software!

Michael B. Trausch (mtrausch) wrote :

In the meantime (since I don't know how to trim PDFs without actually re-printing or modifying them or something similar), here is some additional information the one of the PDFs in question. The output from this command leads me to believe that the thing was actually saved with a title of “untitled”, which is really annoying, because that is something that the diligence of someone in the chain of creation should be able to fix. Nonetheless, here’s the info:

mbt@pepper:~$ pdfinfo phi101_week4_reading2.pdf
Title: untitled
Producer: Acrobat Distiller 6.0.1 (Windows)
CreationDate: Thu May 12 15:32:35 2005
ModDate: Thu May 12 15:32:35 2005
Tagged: no
Pages: 48
Encrypted: no
Page size: 612 x 792 pts (letter)
File size: 1113613 bytes
Optimized: yes
PDF version: 1.2
mbt@pepper:~$

For things like this, it would still be nice to be able to have a preferences selection that permits the window title of Evince to choose between “display the file name” or “display the PDF title” or even some mixture of the two.

Sebastien Bacher (seb128) wrote :

evince seems to display the PDF title if there is one or the filename otherwise. Having an option only to workaround documents shipping with a buggy title doesn't look like a good idea, especially that upstream already has a lot to do and that would be really low priority on the list. I would rather close that bug and blame the PDF, does that seem reasonable to you?

Michael B. Trausch (mtrausch) wrote :

On Wed, 2007-01-10 at 15:58 +0000, Sebastien Bacher wrote:

> evince seems to display the PDF title if there is one or the filename
> otherwise. Having an option only to workaround documents shipping with a
> buggy title doesn't look like a good idea, especially that upstream
> already has a lot to do and that would be really low priority on the
> list. I would rather close that bug and blame the PDF, does that seem
> reasonable to you?

Is it unreasonable to give users the option to choose to see a PDF title
vs. the file name of the PDF? It is just a feature request. I suppose
it can be closed and if I ever manage to gain the ability to implement
it myself, I can do that…

Sebastien Bacher (seb128) wrote :

it's not "unreasonable", GNOME applications just try to not get hundred of configuration options and rather adopt the right behaviour. There is already http://bugzilla.gnome.org/show_bug.cgi?id=386292 upstream about a similar topic

Changed in evince:
status: Needs Info → Confirmed
Changed in evince:
status: Unknown → Confirmed
Changed in evince:
status: Confirmed → Triaged
Changed in evince:
importance: Low → Wishlist
Michael B. Trausch (mtrausch) wrote :

As it turns out, this bug is a violation of the GNOME HIG.

In light of that, and in the interest of Evince doing the right thing and being less confusing to users, here is a debdiff to fix the window title for Evince. Diffstats:

For the evince source package:
mbt@sage:~/programming/ubuntu/evince$ debdiff evince_2.22.0-0ubuntu2.dsc evince_2.22.0-0ubuntu3.dsc|diffstat
 debian/patches/02_follow_gnome_hig.patch | 106 +++++++++++++++++++++++++++++++
 evince-2.22.0/debian/changelog | 7 ++
 2 files changed, 113 insertions(+)

For the upstream source:
mbt@sage:~/programming/ubuntu/evince$ diffstat evince-2.22.0/debian/patches/02_follow_gnome_hig.patch
 ev-window-title.c | 70 +++---------------------------------------------------
 1 file changed, 5 insertions(+), 65 deletions(-)

Michael B. Trausch (mtrausch) wrote :

Patch has been submitted upstream, also.

This patch is somewhat trivial, and is not a feature patch but a bugfix, can this be included in Hardy? The description on this bug states it is a feature request, but this was before I was aware that the confusing behavior went against the GNOME HIG... makes sense that the HIG state that the filename should be in the title, since that avoids confusing issues like this one. :-)

Michael B. Trausch (mtrausch) wrote :

A build is available in my PPA for Hardy, if someone wants to see the effect of the patch: https://edge.launchpad.net/~mtrausch/+archive

Nigel Babu (nigelbabu) on 2010-07-25
tags: added: patch-forwarded-upstream
Changed in evince:
importance: Unknown → Wishlist
Changed in evince:
status: Confirmed → Fix Released
Sebastien Bacher (seb128) wrote :

The issue is fixed in Oneiric

Changed in evince (Ubuntu):
status: Triaged → Fix Released
jack (jackderosis) wrote :

The issue seems to be reappeared (at least to me) in Bionic, with Evince 3.28.2

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.