evince fails to print PS file to PDF file

Bug #784228 reported by OC on 2011-05-17
72
This bug affects 14 people
Affects Status Importance Assigned to Milestone
evince (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: evince

Askubuntu user sdaau reports the following [1]:

"This is my problem:

    Open a document in Evince, choose Print
    Choose "Printer": "Print to file"
    Choose "Output Format": "PDF"
    (add a filename output.pdf in the box if not there)
    Click on "Print"
    Experience the following message:

< Failed to print document.
< Printing is not supported on this printer.

By the way, printing to an "Output Format" .ps file works fine. "

I can reproduce this bug trying to print a PS file to PDF.
Sample file is attached, created with LibreOffice 3.3 on Natty.

evince 2.32.0-0ubuntu12.1
libreoffice-calc 1:3.3.2-1ubuntu4
Ubuntu 11.04 fresh install with all ~/.* user settings copied from 10.10 installation.

[1] http://askubuntu.com/questions/37066/evince-print-to-pdf-file-fails-to-print

OC (olivier-c) wrote :

Yes, I can confirm this too. This does not seem to be Ubuntu-specific, could you report the problem upstream: http://live.gnome.org/Evince/ReportingBugs
Then post the link here or directly link the upstream bug report. Thanks in advance!

Changed in evince (Ubuntu):
status: New → Confirmed
sdaau (sd-imi) wrote :

Hi @Marcel,

Just copied this to gnome.org bugzilla:

https://bugzilla.gnome.org/show_bug.cgi?id=650461

madbiologist (me-again) on 2011-05-21
tags: added: natty
mshaik (munafhussain) wrote :

hey...if you do need to print .ps files as .pdf and are affected by this bug, the command "ps2pdf" works fine for me...I'm currently using that instead of the print option in evince...
hope this bug gets resolved soon!!

Changed in evince:
importance: Unknown → Medium
status: Unknown → New
description: updated
Moshe Kaplan (moshekaplan) wrote :

Here is another sample file.
This PS file was created by Graphviz. It is also unable to be printed to pdf, with the same message as before.

Ubuntu 11.04 x86_64
Evince 2.32.0-0ubuntu12.3
libspectre 0.2.6-1build1
graphviz 2.26.3-5ubuntu1

I did not have this bug in Ubuntu 11.04 but I upgraded to 12.04 a few hours ago and it bit me. I cannot reliably print web pages as PDF files; it occasionally works but typically produces displayable but garbled PDF files. I can save web pages as postscript files, but when I open these files in evince (the document viewer) evince behaves as described in this bug.

So I repeat, this bug is not specific to 11.04; it happends in 12.04 (in a raw upgrade with no new package installs) as well.

Still broken in 13.10

Still broken in 14.04

no longer affects: evince (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

OC, et. al, thank you for taking the time to report this bug and helping to make Ubuntu better. However, I am closing it because the bug has been fixed in the latest development version of Ubuntu - Vivid Vervet.

This is a significant bug in Ubuntu. If you need a fix for the bug in previous versions of Ubuntu, please perform as much as possible of the SRU Procedure [1] to bring the need to a developer's attention.

[1]: https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

Changed in evince (Ubuntu):
status: New → Confirmed
affects: evince (Fedora) → evince (Ubuntu)
Changed in evince (Ubuntu):
status: New → Fix Released
importance: Undecided → Low
tags: added: trusty
removed: pdf postscript print-to-file print-to-pdf
Changed in evince:
status: New → Confirmed
Changed in evince:
status: Confirmed → Expired
no longer affects: evince (Ubuntu)
affects: evince → evince (Ubuntu)
Changed in evince (Ubuntu):
importance: Medium → Undecided
status: Expired → New
importance: Undecided → Low
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.