cannot open a document with hash tag in the filename

Bug #578996 reported by Marijn van den Oetelaar on 2010-05-11
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
evince (Ubuntu)
Low
Didier Roche
Lucid
Undecided
Unassigned
Maverick
Low
Didier Roche

Bug Description

Binary package hint: evince

package pushed in -proposed:

evince (2.30.1-0ubuntu3) UNRELEASED; urgency=low

  [ Jamie Strandboge ]
  * debian/apparmor-profile.abstraction: allow writes to removable media
    (LP: #490230)

  [ Didier Roche ]
  * debian/patches/03_fix_opening_hash_filename.patch:
    Fix opening files with '#' in its name (LP: #578996)

evince (2.30.1-0ubuntu2) UNRELEASED; urgency=low

  * add debian/patches/02_fix_dot_dir_creation.patch:
    fix dot dir creation when launching evince directly (LP: #571725)

evince (2.30.1-0ubuntu1) UNRELEASED; urgency=low

  * New upstream release:
    Bug fixes:
    - Make inverted colors mode work in presentation mode too
      (#614693, Carlos Garcia Campos)
    - Respect GNOME22_USER_DIR env variable (#613637, Ray Strode)
    - Fix loading of local documents when uri contains a page
      destination (#616515, Carlos Garcia Campos)
    - Take default settings from last document opened. Fixes
      regression caused by migration to gio metadata (#606090, Carlos
      Garcia Campos) (LP: #544639, #503372)
    - Update icons to match gnome-icon-theme appearance (#614747,
      Hylke Bons, Carlos Garcia Campos)
    - Make sure there's a new valid page range before updating caches
      (fdo#27599, Carlos Garcia Campos)
    - Update FSF address everywhere (#514607, Arun Persaud)
    - Fix loading of compressed password-protected documents (#613959,
      Carlos Garcia Campos)
    - Close previewer window with control + w (#612972, Carlos Garcia
      Campos)
    - Fix keybindings in previewer window (#612972, Carlos Garcia
      Campos)
    Translation updates

Test case: try to open a PDF document with in #
-------
Bug description:
   1. If there is a Hash tag (#) in a PDF document filename OR directory name then the following
      is happening.
   2. Double clicking on a pdf document (through Nautilus) with a hash tag in the filename (for
      example /home/tester/desktop/test/test_#hashtag.pdf) while produce the following error in
      Evince:
3. Double clicking on a pdf document (through Nautilus) with a hash tag in the directory name
   (for example /home/tester/Desktop/#test/test_hashtag.pdf) while produce the following error
   in Evince:
4. But if you open the PDF document from within Evince (already activated) then there is no
   problem . The file is opened and displayed correctly.
5. But when you try to open a PDF document via Nautilus and Evince is already activated then
   Evince doesn't responds and you cannot open the PDF document.
6. With other document viewers (adobe, gv) I have no problem viewing the document.

This appears to be similar to, but different than, bug #571293 and bug #572722

I'm running Ubuntu 10.04, evince is version 2.30.1-0ubuntu2. This is a regression from karmic.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: evince 2.30.1-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic i686
Architecture: i386
Date: Tue May 11 23:17:50 2010
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
ProcEnviron:
 LC_TIME=nl_NL.UTF-8
 LANGUAGE=en
 PATH=(custom, no user)
 LANG=nl_NL.UTF-8
 SHELL=/bin/bash
SourcePackage: evince

Kamus (kamus) wrote :

I can confirm this issue is reproducible under Lucid with evince 2.30.1-0ubuntu2

Changed in evince (Ubuntu):
importance: Undecided → Low
description: updated
Pedro Villavicencio (pedro) wrote :

this is a regression caused by the proposed package of evince, the package shipped with lucid doesn't show the issue.

tags: added: regression-proposed
summary: - Problem opening PDF in Evince 2.30.1 when opening a PDF document with a
- hashtag in filename or in the directory name
+ cannot open a document with hash tag in the filename
Changed in evince (Ubuntu):
status: New → Triaged
assignee: nobody → Didier Roche (didrocks)
Pedro Villavicencio (pedro) wrote :

I'm assigning this to Didier since he's working on the evince update.

Didier Roche (didrocks) wrote :

pushed 2.30.1-0ubuntu3 in -proposed, here is the debdiff with 2.30.1-0ubuntu2 (which is also in proposed, and introduced this regression) and the latest one.

description: updated
tags: added: patch
Martin Pitt (pitti) wrote :

2.30.1-0ubuntu3 got accepted into lucid-proposed now which fixes this regression.

Changed in evince (Ubuntu Lucid):
status: New → Fix Released
skorasaurus (skoraw) wrote :

I applied the update from lucid-proposed and I am unable to reproduce the bug after following to the reporter's steps. I experienced no regressions.

Kamus (kamus) wrote :

patch works fine here too :), Thanks!

Pedro Villavicencio (pedro) wrote :

the update is indeed working fine, marking this as verification done, thanks all.

tags: added: verification-done
Martin Pitt (pitti) wrote :

maverick has a newer version.

Changed in evince (Ubuntu Maverick):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers