After last updates evince become very slow to open PDF documents

Bug #567219 reported by Marcos José Setim on 2010-04-20
44
This bug affects 9 people
Affects Status Importance Assigned to Milestone
evince (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: evince

I've been update my ubuntu every day. After last updates evince pdf reader becomes very slow to open and maximize. It works but very slow.

I attached a example document.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: evince 2.30.0-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic x86_64
Architecture: amd64
Date: Tue Apr 20 09:13:50 2010
ExecutablePath: /usr/bin/evince
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100318)
ProcEnviron:
 LANGUAGE=pt_BR:pt:en
 LANG=pt_BR.utf8
 SHELL=/bin/bash
SourcePackage: evince

Marcos José Setim (mjs-ops) wrote :
Pedro Villavicencio (pedro) wrote :

the pdf works fine here, which video driver and card are you using there? that might be a video issue rather than an evince one.

Changed in evince (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Marcos José Setim (mjs-ops) wrote :

Hello Pedro,

Well I've restarted my laptop and it come back to work fine. I know that this kind of problem (random) it's very difficult to solve but I use a lot of pdf documents to college and sometimes I got the problem... what can I do to help?

setim@discovery [~]$ lspci
00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 0c)
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 02)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 02)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 02)
00:1c.4 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 5 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f2)
00:1f.0 ISA bridge: Intel Corporation 82801HEM (ICH8M) LPC Interface Controller (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA AHCI Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 02)
02:09.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 05)
02:09.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 22)
02:09.2 System peripheral: Ricoh Co Ltd R5C843 MMC Host Controller (rev 12)
02:09.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 12)
02:09.4 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev ff)
09:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8040 PCI-E Fast Ethernet Controller (rev 12)
0b:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)

Johannes Schmitz (johschmitz) wrote :

I have the same problem with evince being very slow in ubuntu 10.04.
But this only occurs if there are pictures or drafts in the document. For a document with only text it seems to be as fast as in the previous version.
I am using radeon driver, but I do not think, that it is a driver problem.

Johannes Schmitz (johschmitz) wrote :

I have the same problem since installing ubuntu 10.04.
The problem only occurs if pictures or drafts are in the document. For a text only document it seems to be as fast as before.

Johannes Schmitz (johschmitz) wrote :

Sorry for the double posting, Internet connection here in India has a high latency.

Pedro Villavicencio (pedro) wrote :

cannot reproduce here, setting this back to New.

Changed in evince (Ubuntu):
status: Incomplete → New
Changed in evince (Ubuntu):
status: New → Confirmed
Andreas Jonsson (sonofjon) wrote :

I've had this same problem for at least several weeks. In addition, evince is very slow to close. If I click the "close" window button it takes a good several seconds, sometimes more than 10s, for the window to close. Often that meas that a warning pop-up appears saying that evince is "unresponsive. However, if I just wait a few more seconds evince always tend close eventually.

As mentioned above, the startup and close slowness seems intermittent. It sometimes occurs, sometimes not, even on the same document.

CPU usage seems unaffected during these mini-freezes.

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a valgrind log following the instructions at https://wiki.ubuntu.com/Valgrind and attach the file to the bug report. This will greatly help us in tracking down your problem.

Changed in evince (Ubuntu):
status: Confirmed → Incomplete
Sebastian Scherer (sebsch) wrote :

I can confirm this problem: Starting evince even without loading any document takes up to several minutes. The same is true for any other action like loading a document or closing evince again.

I have attached a valgrind log of evince being started and closed obtained using the following command:

G_SLICE=always-malloc G_DEBUG=gc-friendly valgrind -v --tool=memcheck --leak-check=full --num-callers=40 --log-file=valgrind.log /usr/bin/evince

I am also running the 64 bit version of Ubuntu 10.04 on a machine with an Intel integrated graphics chip:

00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)

Changed in evince (Ubuntu):
status: Incomplete → New
Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the development release - Oneiric Ocelot. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/ . Thanks again and we appreciate your help.

Changed in evince (Ubuntu):
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for evince (Ubuntu) because there has been no activity for 60 days.]

Changed in evince (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers