Repeated form fields are not propagated

Bug #565967 reported by manuel on 2010-04-18
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
evince (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: evince

I've a form which has repeated fields, a business card template, fields values aren't propagated

Steps:

1.- Select 1st field, it has "First Name" as default value like all it's instances
2.- Enter a new value
3.- Select the same field but in another position
4.- The value of the 1st instance now appear as default value
5.- Keep this default value selecting the 3nd instance
6.- The 2nd instance get back to the previous default value
7.- Go to all instance, just Copy & Paste because the correct value is the new default value and is selected
8.- Go to any instance and change the value, all instances get the new value and get synchronized

What expected
The step 8 is the expected behavior at step 2

Later
Manuel

ProblemType: Bug
Architecture: i386
Date: Sun Apr 18 09:10:19 2010
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/evince
Package: evince 2.28.1-0ubuntu1.2
ProcEnviron:
 PATH=(custom, no user)
 LANG=es_VE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-21.59-generic
SourcePackage: evince
Uname: Linux 2.6.31-21-generic i686

manuel (manuel-soto) wrote :
Pedro Villavicencio (pedro) wrote :

Thanks for the report, could you attach that pdf to the report ? Thanks.

Changed in evince (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
manuel (manuel-soto) wrote :

Hello,
   Incomplete means that I've to post additional information?

Later
Manuel

madbiologist (me-again) wrote :

Sí, por favor incluya el pdf problema a este informe de error.

PDF con campos repetitivos

madbiologist (me-again) wrote :

I can reproduce this bug on Ubuntu 10.04 "Lucid Lynx", although at step 8 I have to interact with the window (scroll or switch to another window and then switch back to Evince) to get the newly changed value to propagate to all instances. I confirm that changing the value at step 2 does not propagate.

Uname: Linux 2.6.32-22-generic i686
Package: evince 2.30.0-0ubuntu1

Changed in evince (Ubuntu):
status: Incomplete → New
status: New → Confirmed
madbiologist (me-again) wrote :

This is still occurring on Ubuntu 12.04 "Precise Pangolin" beta 1.

Packages: evince 3.3.90-0ubuntu2
          libpoppler19 0.18.4-1ubuntu1
          libcairo2 1.10.2-6.1ubuntu2

In fact the previous limited auto-replication is now non-existent - step 4 does not occur and when changing the value in step 8 the newly changed value does not propagate to all instances, even after scrolling or switching to another window and then back to Evince.

tags: added: karmic lucid precise

manuel, thank you for taking the time to report this bug and helping to make Ubuntu better. However, regarding steps 1-7 (not 8), I am closing it because the bug has been fixed in the latest development version of Ubuntu - Vivid Vervet.

This is a significant bug in Ubuntu. If you need a fix for the bug in previous versions of Ubuntu, please perform as much as possible of the SRU Procedure [1] to bring the need to a developer's attention.

[1]: https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

Regarding step 8, this is a separate issue, necessitating a separate report.

Changed in evince (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers