pdf: wrong proportions and margins

Bug #551480 reported by Willi E. on 2010-03-30
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
evince (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: evince

When using evince to display and print pdf documents the margins and proportions are wrong.

As test pdf I used the Ubuntu CUPS test page. The pdf has been printed by using evince (scale is set to 100% and no options of the "View" menu are set) and lpr with two different printers (HP Laserjet 4200 and HP Officejet Pro 8500). I put the two prints (of the Laserjet) together and scanned them - the result is attached to this bug report.
When using evince the top margin is much larger than using lpr. Printing with Adobe Reader or printing the same document using Windows is just like printing with lpr. But it is not only the top margin. If you move the evince sheet so the two top margins are beside each other you can see that the rest of the document is out of alignment as well. Additionally (as you can see) the line thickness isn't the same.

This report isn't a duplicate of others that report from bad margins only when printing - the bad alignment can already be seen in the GUI.

ProblemType: Bug
Architecture: amd64
Date: Tue Mar 30 09:18:43 2010
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/evince
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
KernLog:
 Mar 30 08:56:03 tappy kernel: [136395.601275] type=1503 audit(1269932163.416:31): operation="open" pid=3560 parent=3559 profile="/usr/lib/cups/backend/cups-pdf" requested_mask="::r" denied_mask="::r" fsuid=1000 ouid=0 name="/proc/filesystems"
 Mar 30 08:56:03 tappy kernel: [136395.604902] type=1503 audit(1269932163.426:32): operation="open" pid=3560 parent=3559 profile="/usr/lib/cups/backend/cups-pdf" requested_mask="::r" denied_mask="::r" fsuid=1000 ouid=0 name="/proc/filesystems"
NonfreeKernelModules: fglrx wl
Package: evince 2.28.1-0ubuntu1.2
ProcEnviron:
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-20.58-generic
SourcePackage: evince
Uname: Linux 2.6.31-20-generic x86_64

madbiologist (me-again) wrote :

There are reports that this is fixed in evince in Lucid. Are you able to boot the Ubuntu "Lucid Lynx" 10.04 Live CD and test?

Pedro Villavicencio (pedro) wrote :

setting this to incomplete, waiting for the test on lucid.

Changed in evince (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

Changed in evince (Ubuntu):
status: Incomplete → Invalid
hjs (hjstein) on 2010-10-25
Changed in evince (Ubuntu):
status: Invalid → New
hjs (hjstein) wrote :

I can reproduce this on 10.04. Margins are too large and some of the output is cut off. The problem occurs with Evince as well as with Adobe Reader 9, although it's slightly worse with Adobe Reader, and much worse with Adobe Reader when Page Scaling is set to Fit to Printable Area. Printing directly from the HPLIP app gives the same left & rt margins as Evince, but a smaller top margin.

hjs (hjstein) wrote :

Also, I just discovered that when turning off "scale to fit" in the print driver & in Adobe Reader, then Adobe prints my sample doc fine, but Evince & printing directly with HPLIP cut off the top & bottom. Converting to a .ps file (with Adobe) & then printing with lpr also cuts off the top & bottom.

AusIV (linux-ausiv) wrote :

I can reproduce this on 10.10. My margins are large enough that nothing is getting cut off, but the margins are about 1/4 inch too large. This would have gone unnoticed, except that my university measures the margins of theses and dissertations with a ruler. LPR prints pages with the correct margins.

Colan Schwartz (colan) on 2011-01-31
Changed in evince (Ubuntu):
status: New → Confirmed
tags: added: maverick
twipley (smt-infp) wrote :

[11.10] -- I too am suffering from this white-margins, improper-scaling problem.

Printing a PDF file through the Evince document viewer may by default add white margins both on top and bottom and on both sides. (I have been able to reproduce this issue using PDF files created through the LibreOffice PDF-file export, for it to be noted.)

One method to fix the issue -- and it seems to work for all cases in which a PDF file gets printed with too-wide margins, whether having or not been outputted through LibreOffice -- is to enable "select page size using document page size" by default.

That way, it seems to me, PDF files would get printed the way they really were intended to be printed.

Should it not, in that case, be best for that parameter to be selected in Evince right out of the box?

madbiologist (me-again) wrote :

twipley - What is the make and model of your printer?

twipley (smt-infp) wrote :

madbiologist: It is a "HP Deskjet F380 All-in-one."

I am just curious, also, as to the reason why that option is not ticked in by default.

twipley (smt-infp) wrote :

I am not affected by this issue, I have just realized -- the issue that affects me is present only on page printing:

https://bugs.launchpad.net/ubuntu/+source/evince/+bug/904323

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers