evince doesn't remember the window size

Bug #544639 reported by Diska on 2010-03-22
178
This bug affects 37 people
Affects Status Importance Assigned to Milestone
Evince
Expired
Medium
evince (Ubuntu)
Low
Didier Roche
Lucid
Low
Didier Roche

Bug Description

Currently uploaded in -proposed:

evince (2.30.1-0ubuntu1) lucid-proposed; urgency=low

  * New upstream release:
    Bug fixes:
    - Make inverted colors mode work in presentation mode too
      (#614693, Carlos Garcia Campos)
    - Respect GNOME22_USER_DIR env variable (#613637, Ray Strode)
    - Fix loading of local documents when uri contains a page
      destination (#616515, Carlos Garcia Campos)
    - Take default settings from last document opened. Fixes
      regression caused by migration to gio metadata (#606090, Carlos
      Garcia Campos) (LP: #544639, #503372)
    - Update icons to match gnome-icon-theme appearance (#614747,
      Hylke Bons, Carlos Garcia Campos)
    - Make sure there's a new valid page range before updating caches
      (fdo#27599, Carlos Garcia Campos)
    - Update FSF address everywhere (#514607, Arun Persaud)
    - Fix loading of compressed password-protected documents (#613959,
      Carlos Garcia Campos)
    - Close previewer window with control + w (#612972, Carlos Garcia
      Campos)
    - Fix keybindings in previewer window (#612972, Carlos Garcia
      Campos)
    Translation updates

Test Case:
install the new version of evince, try to open a pdf and go in preview mode.

---------------
Binary package hint: evince

evince starts with a small size and it doesn't remember the new size when
resized, it only happens when opening it without a document, it does remember
the size per document

DistroRelease: Ubuntu 10.04

Diska (discardi-nicola) wrote :
Diska (discardi-nicola) wrote :

right image

summary: - evince start smaller
+ evince doesn't remember the window size
Pedro Villavicencio (pedro) wrote :

Confirming, I've also sent this upstream at: https://bugzilla.gnome.org/show_bug.cgi?id=613695

Changed in evince (Ubuntu):
importance: Undecided → Low
status: New → Triaged
description: updated
James Troup (elmo) on 2010-03-25
tags: added: regression-potential
Changed in evince (Ubuntu):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)

This is what I reported in https://bugs.launchpad.net/bugs/555619

1. Ubuntu lucid (development branch) 10.04
2. 2.30.0-0ubuntu1 (lucid)
3. Documents that haven't been opened previously should open maximized if that's how I last set Evince's window.
4. Documents that haven't been opened previously always open non-maximized. (Once the window has been set to maximized, this setting will be remembered for that particular document.)

I have this same problem

Changed in evince:
status: Unknown → Confirmed
Didier Roche (didrocks) wrote :

Fixed in 2.30.1

See attached debdiff for sru

description: updated
Changed in evince (Ubuntu):
assignee: Canonical Desktop Team (canonical-desktop-team) → Didier Roche (didrocks)
Didier Roche (didrocks) wrote :
description: updated
Didier Roche (didrocks) on 2010-04-28
description: updated

Accepted evince into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in evince (Ubuntu Lucid):
status: Triaged → Fix Committed
tags: added: verification-needed

evince 2.30.1-0ubuntu1 (lucid-proposed) still has this same bug.

Martin Pitt (pitti) on 2010-04-29
tags: added: verification-failed
removed: verification-needed
Didier Roche (didrocks) wrote :

Are you sure you have the right version?
I can say that it's fixed for me:

- open a pdf
- resize the window
- close the pdf
- reopen it
and then, I have the window with exactly the same size

Can you please detail your steps which lead to your check?

tags: added: verification-needed
removed: verification-failed

Yes, if you open a pdf, maximize, close and open the SAME document, it remembers for THAT document. Before this bug was introduced, Evince would remember the general setting of maximized or not. So open it with a NEW document, and it again opens it un-maximized, even if you closed it maximized. Also if you open Evince without a document, maximize, close, reopen, it opens un-maximized.

Martin Pitt (pitti) wrote :

I accepted 2.30.1-0ubuntu2 into lucid-proposed which fixes a regression (bug 571725) . Please test the updated version. Thank you!

Evince 2.30.1-0ubuntu2 doesn't fix this bug (it's also not mentioned in the bug fixes).

Martin Pitt (pitti) wrote :

Copied lucid-proposed to maverick.

Changed in evince (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evince - 2.30.1-0ubuntu2

---------------
evince (2.30.1-0ubuntu2) lucid-proposed; urgency=low

  * add debian/patches/02_fix_dot_dir_creation.patch:
    fix dot dir creation when launching evince directly (LP: #571725)

evince (2.30.1-0ubuntu1) UNRELEASED; urgency=low

  * New upstream release:
    Bug fixes:
    - Make inverted colors mode work in presentation mode too
      (#614693, Carlos Garcia Campos)
    - Respect GNOME22_USER_DIR env variable (#613637, Ray Strode)
    - Fix loading of local documents when uri contains a page
      destination (#616515, Carlos Garcia Campos)
    - Take default settings from last document opened. Fixes
      regression caused by migration to gio metadata (#606090, Carlos
      Garcia Campos) (LP: #544639, #503372)
    - Update icons to match gnome-icon-theme appearance (#614747,
      Hylke Bons, Carlos Garcia Campos)
    - Make sure there's a new valid page range before updating caches
      (fdo#27599, Carlos Garcia Campos)
    - Update FSF address everywhere (#514607, Arun Persaud)
    - Fix loading of compressed password-protected documents (#613959,
      Carlos Garcia Campos)
    - Close previewer window with control + w (#612972, Carlos Garcia
      Campos)
    - Fix keybindings in previewer window (#612972, Carlos Garcia
      Campos)
    Translation updates
 -- Didier Roche <email address hidden> Fri, 30 Apr 2010 09:02:33 +0200

Changed in evince (Ubuntu Lucid):
status: Fix Committed → Fix Released
Martin Pitt (pitti) on 2010-05-03
Changed in evince (Ubuntu Lucid):
status: Fix Released → Fix Committed

Evince 2.30.1-0ubuntu2
If you open Evince without a document, it always opens unmaximized, no matter how you closed it.

Changed in evince:
status: Confirmed → Fix Released
Jeff Fortin Tam (kiddo) wrote :

I tested by upgrading evince, libpoppler5, libpoppler-glib4, poppler-utils to the lucid-proposed versions, and this fixes everything for me, as far as I can tell. This is pretty much the first time in years I see evince sizing itself in a somewhat "smart" way.

Martin Pitt (pitti) on 2010-05-24
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evince - 2.30.1-0ubuntu3

---------------
evince (2.30.1-0ubuntu3) lucid-proposed; urgency=low

  [ Jamie Strandboge ]
  * debian/apparmor-profile.abstraction: allow writes to removable media
    (LP: #490230)

  [ Didier Roche ]
  * debian/patches/03_fix_opening_hash_filename.patch:
    Fix opening files with '#' in its name (LP: #578996)

evince (2.30.1-0ubuntu2) UNRELEASED; urgency=low

  * add debian/patches/02_fix_dot_dir_creation.patch:
    fix dot dir creation when launching evince directly (LP: #571725)

evince (2.30.1-0ubuntu1) UNRELEASED; urgency=low

  * New upstream release:
    Bug fixes:
    - Make inverted colors mode work in presentation mode too
      (#614693, Carlos Garcia Campos)
    - Respect GNOME22_USER_DIR env variable (#613637, Ray Strode)
    - Fix loading of local documents when uri contains a page
      destination (#616515, Carlos Garcia Campos)
    - Take default settings from last document opened. Fixes
      regression caused by migration to gio metadata (#606090, Carlos
      Garcia Campos) (LP: #544639, #503372)
    - Update icons to match gnome-icon-theme appearance (#614747,
      Hylke Bons, Carlos Garcia Campos)
    - Make sure there's a new valid page range before updating caches
      (fdo#27599, Carlos Garcia Campos)
    - Update FSF address everywhere (#514607, Arun Persaud)
    - Fix loading of compressed password-protected documents (#613959,
      Carlos Garcia Campos)
    - Close previewer window with control + w (#612972, Carlos Garcia
      Campos)
    - Fix keybindings in previewer window (#612972, Carlos Garcia
      Campos)
    Translation updates
 -- Didier Roche <email address hidden> Thu, 13 May 2010 16:31:06 +0200

Changed in evince (Ubuntu Lucid):
status: Fix Committed → Fix Released
Malte Helmert (helmert) wrote :

I'm affected by this bug; I have to set the window size and deselect "Continuous" for every new PDF.

Is this a regression?

My evince version seems to be newer than the one containing the patch:

# apt-cache show evince
Package: evince
Priority: optional
Section: gnome
Installed-Size: 6368
Maintainer: Ubuntu Desktop Team <email address hidden>
Original-Maintainer: Marc 'HE' Brockschmidt <email address hidden>
Architecture: i386
Version: 2.30.3-0ubuntu1.1
Replaces: evince-gtk
Provides: djvu-viewer, evince-gtk, pdf-viewer, postscript-viewer
Depends: libatk1.0-0 (>= 1.29.3), libc6 (>= 2.7), libcairo2 (>= 1.6.0), libdbus-1-3 (>= 1.0.2), libdbus-glib-1-2 (>= 0.78), libdjvulibre21 (>= 3.5.22), libevdocument2 (>= 2.29.5), libevview2 (>= 2.29.5), libfontconfig1 (>= 2.8.0), libfreetype6 (>= 2.2.1), libgcc1 (>= 1:4.1.1), libgconf2-4 (>= 2.27.0), libglib2.0-0 (>= 2.23.5), libgnome-keyring0 (>= 2.22.2), libgtk2.0-0 (>= 2.16.0), libice6 (>= 1:1.0.0), libjpeg62, libkpathsea5, liblaunchpad-integration1 (>= 0.1.17), libpango1.0-0 (>= 1.14.0), libpoppler-glib4 (>= 0.12), libsm6, libspectre1 (>= 0.2.3), libstdc++6 (>= 4.1.1), libtiff4, libx11-6 (>= 0), libxml2 (>= 2.7.4), zlib1g (>= 1:1.1.4), gconf2 (>= 2.10.1-2), gnome-icon-theme (>= 2.17.1), shared-mime-info
Recommends: dbus-x11, gvfs
Suggests: unrar, poppler-data, nautilus, apparmor
Conflicts: apparmor (<< 2.3.1+1403-0ubuntu18), evince-gtk
Filename: pool/main/e/evince/evince_2.30.3-0ubuntu1.1_i386.deb
Size: 460076
MD5sum: 5a736a8fc46af14af05373e6ea453567
SHA1: 913976395209611c0c9b152bf21f3e91d1a37248
SHA256: 4c0bf7f45141006868ae030f1a7ef0d8a1f06a8b43df61e3b5678194576ce904
Description: Document (postscript, pdf) viewer
 Evince is a simple multi-page document viewer. It can display and print
 PostScript (PS), Encapsulated PostScript (EPS), DJVU, DVI and Portable
 Document Format (PDF) files.
 When supported by the document, it also allows searching for text,
 copying text to the clipboard, hypertext navigation, and
 table-of-contents bookmarks.
Homepage: http://www.gnome.org/projects/evince/
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu
Supported: 3y
Task: ubuntu-desktop, edubuntu-desktop, xubuntu-desktop, mythbuntu-backend-master, mythbuntu-backend-slave, mythbuntu-desktop, mythbuntu-frontend, ubuntu-netbook

Yes, it's back here too, same version as above, 2.30.3-0ubuntu1.1, while it was fixed in 2.30.1-0ubuntu3

Regression is still there in 2.31.90-0ubuntu2 on Maverick.

dORSY (dorsyka) wrote :

Here too. Maverick, latest updates.

Didier Roche (didrocks) wrote :

I can't reproduce the bug with evince 2.31.92, this one will be available in few hours after building + publishing, can you please try?

Changed in evince:
importance: Unknown → Medium
Jack Leigh (leighman) wrote :

I'm also getting this again in Maverick

Charlie (collinslyle) wrote :

As am I.

Jack Leigh (leighman) on 2010-12-04
Changed in evince (Ubuntu):
status: Fix Released → New
Didier Roche (didrocks) wrote :

Please do not reopen closed bug report. Here, the issue has the same effect but the cause is *totally* different (evince changed the way it's saving window settings and you have to save it explicitly by the file menu). So, to discuss this, open a new bug report please, and file one upstream as well. Thanks

Changed in evince (Ubuntu):
status: New → Fix Released
Changed in evince:
status: Fix Released → Confirmed
vanadium (ftack) wrote :

Ubuntu 12.10 and evince 3.6.0-0ubuntu2, fresh install, fully updated (21 november): this still seems to work flakey.
Launch one document, maximize, close
Launch another document: it is launched maximized: OK. Close
Launch a third document: it is launched unmaximized, although it fills the screen. Expectation: it should launch maximized.

Experiment done on a fresh install, with new documents that never were opened on the system before.

Regular User (dot.ru) wrote :

Here too, evince 3.6 ubuntu 12.10 although it does seem to remember the windows size for a previously opened PDF, it doesn't for a newly opened one. In this case the window will open in almost any position and any size apparently.

Mazay (mazay0) wrote :

Evince 3.14.1 is still affected.

Evince 3.4.0-0ubuntu1.8 in Xubuntu Ubuntu 12.04.5 LTS \n \l does not remember the window size and position used last time, if it is closed when viewing a PDF document, and reopened to display another or the same file.

Changed in evince:
status: Confirmed → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.