will not print some pdf files

Bug #533328 reported by Bill Reager on 2010-03-06
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
evince (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: evince

I have not had a problem printing pdf files until I came across this new file. I looked up the properties and found this information:
Producer- Adobe PDF Library 8.0
Creator-Adobe InDesign CS3 (5.0.4)
Format - PDF - 1.6

Evince will not print this document at all. XPDF will print this file with no problem.
Are there any settings that I can adjust to make Evince print this type of pdf?

ProblemType: Bug
Architecture: amd64
CheckboxSubmission: 9ac3756e0ac18fb8fec7e9b54a8a1e51
CheckboxSystem: fd6c484c0b5d20a2f1cd036ef0f63975
Date: Sat Mar 6 10:09:47 2010
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/evince
NonfreeKernelModules: nvidia
Package: evince 2.28.1-0ubuntu1.2
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-20.57-generic
SourcePackage: evince
Uname: Linux 2.6.31-20-generic x86_64

Bill Reager (thereagers) wrote :
madbiologist (me-again) wrote :

Thanks for filing this bug report.

If possible, please attach the problem document to this bug report. If that is not possible, please consider trying to print this document from the Ubuntu 10.04 "Lucid Lynx" alpha 3 Live CD and then let us know the outcome.

Bill Reager (thereagers) wrote :

I had a feeling I should have attached the file to this report. Sorry I didn't do it at the beginning.

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Is this reproducible with Lucid? Please test and provide us of feedback about it, Thanks in advance.

Changed in evince (Ubuntu):
status: New → Incomplete
importance: Undecided → Low
Bill Reager (thereagers) wrote :

I will try printing the file again as soon as I can get the upgrade to Lucid. I will let you know as soon as possible.

madbiologist (me-again) wrote :

I can reproduce this bug in Lucid. Launching evince from the terminal with this file gives five copies of the following error:

Error: Invalid Font Weight

The document still opens in evince though.

When I try to print the document to a Canon i965 attached locally via USB it appears in the print queue but does not appear at the printer. It stays in the print queue with the status "Processing". This could be a duplicate of bug #525161

Package versions:
evince 2.30.0-0ubuntu1
poppler 0.12.4-0ubuntu4
libcairo2 1.8.10-2ubuntu1

madbiologist (me-again) wrote :

The file attached to comment 3 specifies font weights of 700, 550, 400 and 300. After reading http://xep.xattic.com/xep/testsuite/features/bold.pdf I am wondering if the 550 is producing the error message "Invalid Font Weight".

I think the printing problem is caused by something else though.

Bill Reager (thereagers) wrote :

I have now upgraded to Ubuntu 10.04 and tried to print the file as previously requested. The file still will not print, it just sits in the print queue. I guess it is just a problem with evince, since it printed just fine with the other program mentioned earlier.

madbiologist (me-again) wrote :

With Ubuntu 10.10 "Maverick Meerkat" alpha 2 updated to the latest packages I can now print this file on the same hardware as in comment #6, although it prints a bit slower than other documents.

Uname: Linux 2.6.35-6-generic i686
Packages: evince 2.30.3-1ubuntu2
                  poppler 0.14.1-0ubuntu1

Changed in evince (Ubuntu):
status: Incomplete → New
status: New → Confirmed
status: Confirmed → Fix Released
sabujakash (avradip) wrote :

I am using Evince 2.32.0, and facing the same problem. Faced the problem just after upgrading to Maverick. Before everything was fine. Incidentally the attached pdf in this bug prints without any problem... but pdfs generated by pdflatex won't work (e.g. the attached file). May be this fix is the problem??

sabujakash (avradip) wrote :

Here is the pdf file generated by print to file option of the above.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers